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Welcome

G-CODE Editor Module 2026
Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

Welcome to the VisualCAM-G-Code Editor Online Help!  This help system contains helpful
information about every command and feature of the VisualCAM-G-Code Editor.  G-CODE Editor
can assist you with editing g-code files created with VisualCAM or from other sources.  It can also
be used to navigate and perform cut material simulations of g-code files.  Select a topic from the
Contents, Index or Search tabs located on the left.  You can also select a Related Topic from below
to get started.  The Features topic contains links to every command in the VisualCAM-G-Code
Editor!

For additional assistance and resources we invite you to visit the Find More Resources topic.  We
hope you enjoy  the VisualCAM-G-Code Editor!

On-line help compiled on: Thursday, March 12, 2026

Related Topics

Overview

Features

Understanding

Work Flow

1.1 Overview

G-CODE Editor is a companion module that runs inside of VisualCAM.  G-CODE Editor assists users
with editing g-code files created with VisualCAM or from other sources.  It can be used to navigate
and perform cut material simulations of g-code files. 

Related Topics

VisualCAM-G-Code Editor

Features

Understanding

Work Flow

https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2026.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QISEAjFqPkrNRyUTOYw9ZRZ
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1.2 Features

The following features are included in the VisualCAM-G-Code Editor module.

Project

· Machine MCS Setup

· Preferences

· Stock

· Tool Library

· Tool Stations

· Load G-Code File

· Project Information

· Merge Files

· Transform Project

· Z Instance Project

· XY Instance Project

· Save Project

· Output Project

Editing (Right-Click Menu)

· Cut/Copy/Paste

· Undo Last Command

· Print G-Code File

· Save File

· Go to Bottom

· Go to Top

· Go to next Tool

· Go to next Spindle

· Go to next Feedrate

· Find & Replace Text

Editing (Ribbon Bar Menu)

· Add Line Numbers

· Delete Line Numbers

· Insert Delimiter Spaces

· Delete Delimiter Spaces

· Make all Upper Case

· Make all Lower Case

· G-Code Information

· Find & Replace Text

Simulation

· Simulation Preferences

· Simulation Speed

· Simulation Mode

· Play Simulation

· Display Simulation in Levels

· Simulate to End

· Pause Simulation

· Stop Simulation

Related Topics

Welcome
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Overview

Understanding

Work Flow

1.3 Understanding

The VisualCAM-G-Code Editor module can edit g-code files that you create with VisualCAM.  It can
also be used to edit g-code files generated from other systems that produce ISO standard g-code
files.  You can also define tool libraries, tool cribs and perform cut material simulations.

Related Topics

VisualCAM-G-Code Editor

Overview

Features

Work Flow

1.4 Work Flow

The following is a basic procedural work flow for using the VisualCAM G-CODE Editor module:

Step 1: Load a G-Code Files

Run the VisualCAM G-CODE Editor module and Load the g-code file or files using the
commands on the Project tab.  Your g-code files will be listed in the Project tree.

Step 2: Edit G-Code Files

Edit the G-Code file using the Edit tab functions.  You can perform many automatic and
manual editing tasks, save and print your G-Code files.

Step 3: Tool Motion Simulations (Optional)

To perform tool motion simulations, simply place the cursor at the top of the G-Code file
and press the down arrow key and the tool motion will display on the graphics screen.

Step 4: Cut Material Simulations (Optional)

To perform a cut material simulations, load a Tool Library generated from VisualCAM,
setup your Tool Crib with the tool numbers used in your g-code files.  Then return to the
Project tab, right-click on the G-Code file and select Simulate. 

Step 5: Save your G-Code Files
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When you are done editing your g-code you can Save the g-code files or Output them
directly to another program, of your choice such as a DNC program to communicate them
directly to your CNC machine.  See Preferences > Text Editor to define your output
program.

Related Topics

Welcome

Overview

Features

Understanding
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Quick Start

G-CODE Editor Module 2026
Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

Quick Start Guides for each VisualCAM module are available in both PDF and Video format.  Refer
to the following information to access these guides:

What's New!

What's New in VisualCAD/CAM 2026

The Complete Quick Start Video Play List

Here is a link to the complete 2026 Video Play List

How to Access the Quick Start Guide Documents

To help you quickly get started in working with each module, select one of the Help
buttons located on the VisualCAM Learning Resources dialog.  

You will find:

· Quick Start Guides  

· What's New documents  

· Online Help links

The Quick Start Guides will help you step through an example tutorial which will
illustrate how to use the module.  To access the Learning Resources dialog:

1. From the VisualCAD Home Ribbon Bar, drop down the Main menu and select Learn ...  

https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2026.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QISEAjFqPkrNRyUTOYw9ZRZ
https://mecsoft.com/WhatsNew/WhatsNewInRhinoCAM2026.pdf
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To access the Learning Resources dilog in VisualCAM

2. Select a document from the Learning Resources dialog to get started using the
module of your choice.  

 You can also select the Open Quick Start Files Folder button located at the bottom
of the dialog to open the Quick Start folder where the source files (start and
completed versions) are located.
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Learning Resources Dialog

Related Topics

Find More Resources
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CAM Resource Guide

Download this PDF Guide for a list of the available VisualCAM Resources.

2025 VisualCAM Resource Guide

The 2026 VisualCAM Resource Guide!

18 Pages

Lists PDF downloads and Online resources including Quick Start
Guides, Reference Guides, Exercise Guides, Tutorials and
More.

Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2026.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QISEAjFqPkrNRyUTOYw9ZRZ
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User Interface

VisualCAM-G-CODE Editor adheres to the Windows standard for user interface design and is
seamlessly integrated into the  screen layout.  A screen image of VisualCAM-G-CODE Editor
running inside of  is shown below:

The User Interface

VisualCAM User Interface

Related Topics

Preferences

G-Code Browser

Project Tab

Edit Tab

Simulate Tab

4.1 Preferences

You can set various System Preferences that will be saved even after you exit the program. 
Select the Preferences icon from the G-Code Browser.  When you install a new VisualCAM

update you can choose to import your Preferences from one version to the next.

To Access this Command:

 click: 
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The Preferences Icon

Set System Preferences menu item

Related Topics

User Interface

System Preferences

Text Editor Preferences

Toolpath Preferences

Stock Preferences

Cutting Tools Preferences

Simulation Preferences

4.1.1 User Interface

Here you can set preferences related to the g-code text editor including colors and associated
programs and folders. You can use the Reset to defaults button if you want to revert to the default
factory install settings.

To Access this Command:

 click:  > User Interface

Preferences > Text Editor
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Preferences > User Interface

Language

System language
Use this to set the system language of the plugin's User Interface.

Tool Tips Preferences

Show Context Tool Tips
Check this box to display Context ToolTips when the mouse moves over a parameter in a
dialog.  A definition of the parameter will pop-up automatically.  Note that Context
ToolTips may not be available for ALL dialogs.  You can also set the ToolTip Delay in
seconds.  This is the amount of time it takes to display the Context ToolTip when the
mouse activate it.
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Show Expression Results in Tool Tips
You can enter expressions in any dialog field that expects a numerical value and the
value will be computed and entered automatically.  Check this box to pop-up the results
of any expressions in a ToolTip balloon.  An example is shown below.

Show Expressions in ToolTip

Tool Tip Delay
When Show context ToolTips is checked, this value defines the Delay in seconds it takes
for a ToolTip to display once the cursor moves over it.

Ribbon Style

This allows the selection of different themes that change how the Browser windows
appear. The borders, colors, highlighting, and shadowing of standard buttons, dialogs,
and windows are controlled by which theme is selected.

Example Ribbon Style: Office 2010 Silver

Additional Open File Extensions

If your g-code files have an extension other than *.nc you can add that extension here. 
Enter the extension in the field provided and then pick the Add button.

Save Preferences
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Save Current Preferences to Registry
If you have your preferences set the way you want them and do not want them top
change, select this button to save the current preferences to your Windows registry. 
Doing this will force them to be loaded when you create new files.

Related Topics

Text Editor Preferences

Toolpath Preferences

Stock Preferences

Cutting Tools Preferences

Simulation Preferences

4.1.2 Text Editor

Here you can set preferences related to the g-code text editor including colors and associated
programs and folders. You can use the Reset to defaults button if you want to revert to the default
factory install settings.

To Access this Command:

 click:  > Text Editor

Preferences > Text Editor

Preferences > Text Editor

Text Editor Colors
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You can specify the default colors to display for Rapid, Linear and Arc moves as well as for
Line Numbers and Comments within the G-Code Editor.  Use the color selector available
for each.

Text Editor Color Preferences

Save Directory

You can specify the default save directory.  Pick the  button to select a different
folder.  When you pick Save from the Project tab, this is the folder where the file is
saved.  To overwrite the original g-code, use the Save G-Code command from the Edit
tab. 

Related Topics

User Interface Preferences

Toolpath Preferences

Stock Preferences

Cutting Tools Preferences

Simulation Preferences

4.1.3 Toolpath

Here you can set Toolpath related preferences including colors, display, format and feedrate. You
can use the Reset to defaults button if you want to revert to the default factory install settings.

To Access this Command:

 click:  > Toolpath

Preferences > Toolpath
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Preferences > Toolpath

Toolpath Colors

You can specify the default colors to graphically display Rapid, Linear and Arc moves.  Use
the color selector available for each.

Toolpath Display Color Preferences

Toolpath Display

Here you can set the line thickness for the display of all toolpaths.
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Toolpath Display = 1
Toolpath Display = 2

Circle Center (I,J,K)

I,J,K refers to the center point location for arc motions.  In this section you can define
how arc motions are formatted in the output G-Code file.  Select from the following
options:

· Absolute  

· Vector from Center to Start  

· Vector from Start to Center  

· Unsigned Vector from Start to Center  

Feedrate Speed

Here you can specify feedrate values for the G-Code file.  Select from the following:

· Rapid Feed  

· Nominal Cut Feed  

Related Topics

User Interface Preferences

Text Editor Preferences

Stock Preferences

Cutting Tools Preferences

Simulation Preferences

4.1.4 Stock

Here you can set Toolpath related preferences including colors, display, format and feedrate. You
can use the Reset to defaults button if you want to revert to the default factory install settings.

To Access this Command:
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 click:  > Stock

Preferences > Stock

Preferences > Toolpath

Stock Colors

Here you can set the default colors for Stock and Cut Stock.  Use the color selector
available for each.

Stock Model Display Transparency

Use the slider to set the transparency of the Stock Model Display.

Related Topics

User Interface Preferences

Text Editor Preferences

Toolpath Preferences

Cutting Tools Preferences

Simulation Preferences

4.1.5 Cutting Tools

Here you can set Cutting Tool related preferences. You can use the Reset to defaults button if you
want to revert to the default factory install settings.

To Access this Command:
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 click:  > Cutting Tools

Preferences > Cutting Tools

Preferences > Cutting Tools

Cutting Tool Color

Here you can set the default color for the Cutting Tool during simulations.  Use the color
selector available for each.

Related Topics

User Interface Preferences

Text Editor Preferences

Toolpath Preferences

Stock Preferences

Simulation Preferences

4.1.6 Simulation

Here you can set Simulation related preferences. You can use the Reset to defaults button if you
want to revert to the default factory install settings.

To Access this Command:

 click:  > Simulation

Preferences > Simulation
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Preferences > Simulation

Simulation Mode

There are two simulation modes.

Simulate by Moves  
One pick of the Step icon on the Simulate tab moves the Cutting Tool one complete move
(i.,e., start to end).  See Maximum Display Interval below.  This option is the same as
checking the Simulate By Moves box on the Simulate tab.

Simulate by Distance  
One pick of the Step icon on the Simulate tab moves the Cutting Tool a specified
distance.  See Maximum Display Interval below.  This option is the same as un-checking
the Simulate By Moves box on the Simulate tab.

Maximum Display Interval  
You can control the speed of the simulation using the slider bar and the Maximum
Display Interval. When using Simulate by distance mode, the speed is determined as # of
Motions / Distance.

Simulation Accuracy

Use this slider to adjust the simulation display accuracy.

Simulation Tolerance

The Simulation Accuracy slider provides a high-level of adjustment and the Simulation
Tolerance provides a more granular level of control. Note that the Simulation Tolerance
will have a direct affect on simulation time. 
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Additional Options

Disable Advanced OpenGL
Check this box only if you have an older graphics card adapter that does not support
advanced OpenGL (i.e., OpenGL 2).  Some older cards may only support OpenGL 1 for
example.  If you experience graphics instability checking this box may help resolve the
issue.

Related Topics

User Interface Preferences

Text Editor Preferences

Toolpath Preferences

Stock Preferences

Cutting Tools Preferences

4.2 G-Code Browser

The G-Code Browser has four main modes of operation represented by tabs at the top of the
browser window. These are Project, Edit, G-Code Edit and Simulate. Each tabbed view also
incorporates a ribbon toolbar of commands at the top.  These toolbars group associated
commands into panes.  

Each menu tab is shown below:

The Project Tab
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G-Code Browser, Project Tab

The Edit Tab

 click:  >  >  > 
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G-Code Browser, Edit Tab

The Simulate Tab

 click:  >  >  >  (with Simulate Window
displayed)
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G-Code Browser, Simulate Tab

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Simulate Tab

4.2.1 Project Tab

The Project tab is Selecting the Program tab in the Mops Browser shows 3 groups of menus that
provide access for specifying Machine, Stock and defining Machining Operations.

To Access this Command:

 click:  

The Project Tab



VisualCAD/CAM 2026 G-Code Editor Reference28

© 2026 MecSoft Corporation

G-Code Browser, Project Tab

Ribbon Bar Options

 Contains Project related commands.

  Use these icons to maximize and minimize the ribbon bar menus.

 Display the Preferences dialog.

 Display the Online Help system.

Project Setup Pane

 Displays a menu of Stock definition commands.

 Displays the Tool Library dialog.

 Displays the Tool Crib dialog.

Project G-Code Pane

 Load a g-code file into the Project tree.

 Display Information about the g-code files currently loaded into the Project.
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Project File Operations Pane

 Merge two selected g-code files into one file.

 Displays the Transform g-code dialog.

 Displays the Z Instance g-code dialog.

 Displays the XY Instance g-code dialog.

 Saves all g-code files currently loaded into the Project. 

 Outputs the g-code files currently loaded into the Project.

Project Tab, Right-Click Menu

 Edit the selected G-Code file.

 Simulate the selected G-Code file.

 Display information about the selected G-Code file.

 Delete the selected G-Code file.

Related Topics

Project Tree

Edit Tab

Simulate Tab

Online Help

4.2.2 Project Tree

The Project tree is located under the Project tab.  It contains all of the elements
needed for a specific project, including stock model, tool library, tool crib and g-

code files.  The Project tree can also alert you to issues that need to be addressed by flagging
items for attention.

To Access this Command:

 click:  

The Project Tab

You must have the Project tab selected in order to see the Project tree.
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G-Code Browser, Project Tab

Returning to the Project Tab

You can return to the Project tab by selecting this icon  located on the top G-
Code Browser when either the Edit, G-Code Edit or Simulate tabs are active.

G-Code Browser, Return to Project Tab menu item

How Stock is Defined in the Project Tree
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If there no stock yet defined, the Stock icon in the Project tree will say "Stock -
None". Once a stock is defined, the Stock icon in the Project tree will indicate the
type of stock that is defined. Refer to the two Project tree images. The image on the
left has no Stock yet defined. The image on the right has Box Stock defined.

When Stock is not defined When Stock is defined

Red Flags in the Project Tree

If items are flagged in the Project tree it means that they need your attention.  

For example if a g-code file has been modified but has not yet been saved or output,
it will be flagged as shown in the example below.

When a g-code file is flagged

If you load a g-code file that uses a tool number that is currently undefined in your
tool crib, it will be flagged as shown below.
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When a tool is flagged

Related Topics

Project Tab

Edit Tab

Simulate Tab

Online Help

4.2.3 Edit Tab

When you double-left-click on a G-Code file from the Project tree, that file is loaded into
the G-Code Editor.  The Edit tab contains commands to Modify and Navigate the g-code

file.  The Edit tab and commands are listed below.

To Access this Command:

 click:  >  > 

Edit tab
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G-Code Browser, Edit Tab

Ribbon Bar Options

 Contains file Edit related commands.

 Returns to the Project tab.

 Minimizes and maximizes the ribbon bar menu.

 Displays the Preferences dialog.

 Displays the Online Help system.

Edit Tab

 Add line numbers to the g-code file.

 Insert spaces (i.e., delimiters) between g-codes.
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 Convert g-code to all UPPERCASE text.

 Delete line numbers from the g-code file.

 Delete spaces (i.e., delimiters) between g-codes.

 Convert g-code to all lowercase text.

 Cut the selected text to the clipboard.

 Copy the selected text to the clipboard.

 Paste the selected text to the current cursor location.

 Find text within the G-Code file.

 Find & Replace text within the G-Code file.

 Undo the last command.

 Print the G-Code file currently loaded in the editor.

 Save the G-Code file currently loaded in the editor.

 Display information about the current g-code file.

Edit Tab, Right-Click Menu

 Go to the Bottom (End) of the G-Code file.

 Go to the Top (Start) of the G-Code file.

 Go to the next Tool Change code.

 Go to the next Spindle code.

 Go to the next Feedrate code.

 Cut the selected text to the clipboard.

 Copy the selected text to the clipboard.

 Paste the selected text to the current cursor location.
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 Find text within the G-Code file.

 Find & Replace text within the G-Code file.

 Undo the last command.

Edit Tab, Display Toolbar

Display Toolbar

 Stock Model Visibility: Turn on/off stock model 

 Part Model Visibility: Turn on/off part model display during simulation.

 Toolpath Visibility: Turn on/off toolpath display

 Follow Toolpath Display: The toolpath is displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath after the tool passes. 

 Trace Toolpath Display: The toolpath is not displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath before the tool passes. 

 Segment Toolpath Display: The toolpath is only displayed for the segment that the
tool is currently on.

Related Topics

Project Tab

Project Tree

Simulate Tab

Online Help

4.2.4 Simulate Tab

When you double-left-click on a G-Code file from the Project tree, that file is loaded
into the G-Code Editor.  The Simulate tab contains commands to perform tool

motions and cut material simulations of the g-code file.  The Simulate tab and commands are
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listed below.  Note: You must have Stock, Tool Library and Tool Crib defined before performing a
Simulation.  

To Access this Command:

 click:  >  > 

Simulate tab

G-Code Browser, Simulate Tab

Ribbon Bar Options

Contains file Simulation related commands.

 Returns to the Project tab.

 Minimizes and maximizes the ribbon bar menu.

 Displays the Preferences dialog.

 Displays the Online Help system.

Simulate Tab, Options Pane

 Display Simulation Preferences.
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 Simulation speed adjustment (Left: Slow, Right: Fast).

 Check to simulate by moves.  Uncheck to simulate by distance.  See
Preferences to set the default mode.

Simulate Tab, Simulate Pane

 Play the simulation.

 Step through the simulation by distance or by moves.

 Display simulation in Levels.

 Go direction to the End result of the simulation.

 Pause the simulation.

 Stop the simulation.

Simulate Tab, Display Toolbar

Display Toolbar

 Stock Model Visibility: Turn on/off stock model 

 Part Model Visibility: Turn on/off part model display during simulation.

 Toolpath Visibility: Turn on/off toolpath display

 Follow Toolpath Display: The toolpath is displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath after the tool passes. 

 Trace Toolpath Display: The toolpath is not displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath before the tool passes. 

 Segment Toolpath Display: The toolpath is only displayed for the segment that the
tool is currently on.

Related Topics
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Project Tab

Project Tree

Edit Tab

Online Help

4.2.5 Online Help

You can access this online help system from the G-Code Browser.

To Access this Command:

 click: 

The Online Help Icon

Online Help menu item

VisualCAM-G-Code Editor Online Help System

Related Topics
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Project Tab

Project Tree

Edit Tab

Simulate Tab
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Project Tab

The Project tab is Selecting the Program tab in the Mops Browser shows 3 groups of menus that
provide access for specifying Machine, Stock and defining Machining Operations.

To Access this Command:

 click:  

The Project Tab

G-Code Browser, Project Tab

Ribbon Bar Options

 Contains Project related commands.

  Use these icons to maximize and minimize the ribbon bar menus.

 Display the Preferences dialog.

 Display the Online Help system.
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Project Setup Pane

 Displays a menu of Stock definition commands.

 Displays the Tool Library dialog.

 Displays the Tool Crib dialog.

Project G-Code Pane

 Load a g-code file into the Project tree.

 Display Information about the g-code files currently loaded into the Project.

Project File Operations Pane

 Merge two selected g-code files into one file.

 Displays the Transform g-code dialog.

 Displays the Z Instance g-code dialog.

 Displays the XY Instance g-code dialog.

 Saves all g-code files currently loaded into the Project. 

 Outputs the g-code files currently loaded into the Project.

Project Tab, Right-Click Menu

 Edit the selected G-Code file.

 Simulate the selected G-Code file.

 Display information about the selected G-Code file.

 Delete the selected G-Code file.

Related Topics

Project Tree

Edit Tab

Simulate Tab

Online Help
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5.1 Machine MCS Setup

You can set the cutting direction and alignment using the Machine
Coordinate System (MCS) dialog.  This orients the coordinates defined in the
any g-code files that are currently loaded into the editor.

To Access this Command:

 click:  >   double-click:

G-Code Browser: Project tab, Stock menu

Edit the Machine MCS

Dialog Box: Machine
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Dialog Box: Machine (MCS) Setup

The Machine Coordinate System (MCS)

The Machine Coordinate System (MCS) is displayed as a triad with Blue line
representing the Z-axis, Red representing X-axis and Green representing the Y-
axis. The WCS is displayed the same way as MCS and is located at the origin. The
lengths of the WCS arrows are shorter when compared to MCS.
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(MCS) (WCS)

Align to

This aligns the MCS orientation.  Select from the following:

Machine Tool Coordinate System
Aligns the Setup Coordinate System to Machine Tool Coordinate System.

Align To: World Coordinate System

Active View Construction Plane
Setting the MCS to the orientation of the active viewport of the construction
Plane.

Align To: Active Construction Plane

Geometry: Part Surface
User can select a point on a surface determine the alignment of MCS.
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Align To: Geometery, Part Surface

Geometry: Planar Curve
User can select a planar curve (2D sketch) to determine the alignment of MCS.

Align To: Geometry, Planar Curve

Set Orientation Parallel to

Allows you to set the Machine Coordinate System parallel to the World X Y or Z
co-ordinate axis.

World X orients the Z axis of MCS parallel to World X axis.

World Y orients the Z axis of MCS parallel to World Y axis.

World Z orients the Z axis of MCS parallel to World Z axis.
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Rotate about

Allows you to rotate the Machine Coordinate System in X Y Z coordinate axis by
any angle specified under Spin Angle.  Specify Spin Angle and click the axis to
rotate about. Clicking the same coordinate axis button multiple times rotates by
the specified angle incrementally. For example if you set the Spin Angle = 90
and click X Axis button 2 times, the MCS is rotated about X coordinate axis by
180 degrees.

Coordinate System Origin

This translates the MCS origin to the desired location. This can be set to any
location on the part geometry.
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Use Coordinate System Origin to translate the MCS origin to the desired location

Reset to Original

Resets MCS orientation to current MCS orientation.

Related Topics

G-Code Browser

Project Tab

Project Tree

5.2 Setup Pane

5.2.1 Stock

This menu contains commands to create different types of Stock material in
preparation for cut material Simulations.  If there is no stock defined, Simulations

will only show tool motions and not a cut material simulation.

To Access this Command:

 click:  > 

G-Code Browser: Project tab, Stock menu
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The Stock Menu

Related Topics

Stock Menu

Create Box Stock

Create Part Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.1 Box Stock

You can define the raw stock model as a simple box by selecting the Box Stock option
from the Stock menu on the Project tab of the G-Code Browser and entering the

Stock dimensions.

To Access this Command:

 click:  >  > Box Stock ...

Box Stock menu item
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G-Code Browser: Box Stock menu item

Dialog Box: Box Stock

You can define the box by simply typing in the Length, Width and Height of the box in the
corresponding edit boxes of the dialog. The corner position (origin) of the box can also
be repositioned by picking the desired coordinate or by specifying the coordinate values
in the corresponding edit boxes in the dialog (Xc, Yc, Zc). When you click on the OK
button, a stock model based on your definition will be created and displayed.
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Dialog Box: Box Stock

Copy Model Bounding Box

When Copy Model Bounding Box is selected, the system calculates the bounding box of
the part model as the XYZ extents of geometry of the part model and displays the X Y Z
Coordinate values under dimensions.

Ignore Wireframe Geometry in Bounds Computation

Check this box to ignores all 2D and 3D curve geometries present in the part from stock
bounding box computation.

Make sure to click Copy Model Bounding Box after you check or uncheck Ignore
Wireframe Geometry in Bounds Computation.
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Ignore Wireframe geometry - checked

Ignore Wireframe geometry – un-checked

Related Topics

Stock Menu

Create Part Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.2 Part Box Stock

You can define the raw stock model as a bounding box of the XYZ extents of
geometry of the part model.  You can then define offsets in any of the three

coordinate directions to apply to the computed bounding box.

To Access this Command:

 click:  >  > Part Box Stock ...

Part Box Stock menu item
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G-Code Browser: Part Box Stock menu item

Dialog Box: Part Box Stock

The system calculates the bounding box of the part model as the XYZ extents of
geometry of the part model. You can then define offsets in any of the three coordinate
directions to apply to the computed bounding box. The system will expand the bounding
box by the offset amount in each of the coordinate directions. When you click on the OK
button, a stock model based on your definition will be created and displayed.
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Dialog Box: Part Box Stock

Ignore Wireframe Geometry in Bounds Computation

Check this to ignore all 2D and 3D curve geometries present in the part from stock
bounding box computation.

Ignore Wireframe geometry - checked
Ignore Wireframe geometry – un-checked

Related Topics

Stock Menu
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Create Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.3 Cylinder Stock

You can define the raw stock model as a simple cylinder by selecting this option.
When creating a cylinder stock, the axis of the cylinder is automatically set to the

World Z Axis unless you select a different axis from the dialog.

To Access this Command:

 click:  >  > Cylinder Stock ...

Cylinder Stock menu item

G-Code Browser: CylinderStock menu item

Dialog Box: Cylinder Stock

You can define the cylinder by simply selecting the axis of the cylinder (either X Y or Z),
specifying the center coordinates by typing in the values or graphically picking the center
and then by specifying the radius and the length of the cylinder.

The Center (origin) of the stock can also be repositioned by specifying the coordinate
values in the corresponding edit boxes in the dialog (Xc, Yc, Zc). When you click on the
OK button, a stock model based on your definition will be created and displayed. You can
switch to the Simulate tab of the browser window to display the stock model that was
created.
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Dialog Box: Cylinder Stock

Copy Model Bounding Cylinder

User can also select Copy Model Bounding Cylinder to determine the smaller possible
stock model that fit the part geometry.

Ignore Wireframe Geometry in Bounds Computation

Check this ignore all 2D and 3D curve geometries present in the part from stock bounding
cylinder computation.

Make sure to click Copy Model Bounding Cylinder after you check or uncheck Ignore
Wireframe Geometry in Bounds Computation.
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Ignore Wireframe geometry - checked Ignore Wireframe geometry – un-checked

Related Topics

Stock Menu

Create Box Stock

Create Part Box Stock

Create Part Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.4 Part Cylinder Stock

You can define the raw stock model as a bounding cylinder of the XYZ extents of
geometry of the part model.  You can then define offsets to apply to the computed

bounding box.

To Access this Command:

 click:  >  > Part Cylinder Stock ...

Part Cylinder Stock menu item



Project Tab 57

© 2026 MecSoft Corporation

G-Code Browser: Part CylinderStock menu item

Dialog Box: Part Cylinder Stock

You can define the cylinder by simply selecting the axis of the cylinder (either X, Y or Z)
and defining the radial and the axial offset distances.  The bounding cylinder will be
calculated and these offset values will be used to expand the cylinder in both the radial
and axial direction. 

Additionally you can specify the axial offset to be applied in both the positive and
negative directions or only in the positive or only in the negative axial directions. 
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Dialog Box: Part Cylinder Stock

Ignore Wireframe Geometry in Bounds Computation

Check this to ignore all 2D and 3D curve geometries present in the part from stock
bounding cylinder computation.

When you click on the OK button, a stock model based on the part geometry and your
definition will be created.  You can switch to the Stimulate tab of the browser window to
display the stock model that was created.
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Ignore Wireframe geometry - checked Ignore Wireframe geometry – un-checked

Related Topics

Stock Menu

Create Box Stock

Create Part Box Stock

Create Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.5 Delete Stock

Use this command to Delete the currently defined Stock model.  If there is no stock
defined, Simulations will only show tool motions and not a cut material simulation.

To Access this Command:

 click:  >  > Delete Stock

Delete Stock menu item
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G-Code Browser: Delete Stock menu item

Related Topics

Stock Menu

Create Box Stock

Create Part Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Stock from Selection

5.2.1.6 Stock from Selection

You can define the raw stock model from the currently active selected 3-D geometry.
 You can select 3D surfaces and/or meshes and then selects Stock from Selection

option from Create Stock Model under the Program tab in Machining Browser.

No dialog will be invoked but the system will use the selected geometry and create a triangulated
stock model.  You can switch to the Stock tab of the browser window to display the stock model
that was created.

Stock from Selection will fail to create stock if the selected
3D geometry is not a watertight model.

To Access this Command:

 click:  >  > Stock from Selection

Stock from Selection menu item
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G-Code Browser: Stock from Selection menu item

Stock from Selection Example

You can switch to the Simulate tab of the browser window to display the stock model
that was created.

3D geometry selection  for stock

Stock created from 3D geometry

Related Topics
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Stock Menu

Create Box Stock

Create Part Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Delete Stock

5.2.2 Tool Library

Use this command to load a pre-defined Tool Library file (*.csv).  You can save a Tool
Library (*.csv) file from the MILL module Save Tool Library command.  When you

create your Tool Crib, the tools are selected from this Tool Library.

To Access this Command:

 click:  > > Load

Tool Library menu item

G-Code Browser: Tool Library menu item

Procedure

1. Select Library from the Project tab of the G-Code Browser and pick Load.

2. The File Open dialog will display.  Navigate to the Tool Library file and pick Open
to load it.  The file extension must be *.csv.  You can save a Tool Library (*.csv) file
from the MILL module Save Tool Library command.

3. The Tool Library is loaded.
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A Tool Library is loaded

4. Selecting a tool type icon from the menu at the top will display those tool types.

Listing only Drill Tools

5. The default Tool Library (*.csv) files saved from the MILL module contains the
following data fields as shown in each column of the dialog.  You can edit *.csv
files using an Excel compatible spreadsheet program.

Default Tool Data Fields Supported by the MILL Module are:

· Name  

· Tool Type  

· Diameter  

· Corner Radius  

· Taper  

· Flute Length  

· Tool Length  

· Tool Number  

· Tool Material  

· Spindle RPM  

· Cut Feed  

· Adjust Register  

· Cutcom Register  

· Comments  

Tool Library Toolbar

Select an icon from the toolbar to display only those tools.Displays the Online Help
system.
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 Ball

 Flat

 Corner Rad

 Vee

 Chamfer

 Taper

 Thread

 Face

 Dove Tail

 Fillet

 Lollypop

 User Defined

 Drill

 Center Drill

 Ream

 Tap

 Bore

RBore

 Show All

Related Topics



Project Tab 65

© 2026 MecSoft Corporation

User Interface

Project Tab

Stock Menu

Tool Crib

5.2.3 Tool Crib

Use this command to create a Tool Crib for the current Project.  This will assign a
tool station number to each tool you load into the Tool Crib.  Be sure to assign the

same Tools and Tool Numbers that are used in your g-code files.

To Access this Command:

 click:  > 

Tool Crib menu item

G-Code Browser: Tool Crib menu item

Procedure

1. Select Numbers from the Project tab of the G-Code Browser.

2. The Tool Crib dialog will display.  
Select the Add Station button to grab a tool from the default Tool Library.
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The Tool Crib dialog, Add Station button

3. The Tool Crib dialog will minimize and the Tool Library dialog will display.  Select a
tool from the library and then pick OK.  The selected tool will be assigned as tool
station #1 (i.e., Tool #1).

Select a Tool from the Library and pick OK.

4. You can use the icons on the right side of each Tool Station # to delete that station
or reassign a tool to that station.
Pick OK to accept the Tool Crib.

Related Topics

User Interface

Project Tab

Stock Menu

Tool Library
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5.3 G-Code Pane

5.3.1 Load

Use this command to Load a g-code file into the G-Code Browser.  You can load as many
g-code files as you wish and work with them from the Project tab of the G-Code

Browser.  The example below shows three files loaded.

To Access this Command:

 click:  > 

Then use the File Browser to select a G-Code file to load.

The following G-Code file type extensions are supported:

File Extensions Supported by G-Code Editor

Load menu item

G-Code Browser: Load g-code file menu item

Related Topics

User Interface

Project Tab
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Stock Menu

Tool Library

Tool Crib

Info

5.3.2 Info

Use this command to get Information about all of the g-code files that are currently
loaded into the Project of the G-Code Browser.  Information includes file Name, Tool #,

# of GoTo motions, Estimated Machining Time and file Size.

To Access this Command:

 click:  > 

Info menu item

G-Code Browser: Info menu item

G-Code Files Information Dialog
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Files Information Dialog

Related Topics

User Interface

Project Tab

Stock Menu

Tool Library

Tool Crib

Load

5.4 File Operations Pane

5.4.1 Merge Files

Use this command to merge g-code files that are currently loaded into the Project
tab of the G-Code Browser.  Merged files can be output as one g-code file using

the Output command.

To Access this Command:

 click:  > 

Merge Files menu item
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G-Code Browser: Merge Files menu item

Procedure

1. From the Project tab of the G-Code Browser, press and hold the <Ctrl> key while
left-click selecting the g-code files that you want to merge.

G-Code Browser: Merge Files menu item

2. With the g-code files highlighted and selected, pick the Merge Files command
from the Project tab.
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G-Code Browser: Merge Files menu item

3. In the example above we have selected three g-code files to merge.  The second
and third files are merged into the first selected file that appears in the Project.

The second and third files are merged into the first selected file that appears in the
Project.

4. Because the first g-code file has now changed, it is flagged (at the red arrow in the
image above) to let you know that it has not yet been saved.
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5. A double-left-click on the g-code file will load it into the G-Code Editor for
viewing.

The merged file is loaded into the G-Code Editor

6. When done editing the g-code file, select the Back to Project icon to return to the
Project tab.

Back to Project menu item

7. When satisfied, select the Output icon to save the new edited g-code file.
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The merged g-code file is displayed

Related Topics

User Interface

Project Tab

Load

Info

Transform

Z Instance

XY Instance

Save

Output

5.4.2 Transform

You can use this command to perform transformations on a selected g-code file. 
The transformations include Move, Rotate, Mirror and Scale.  Each method is

documented in the topics below.  Each tab of the Transform dialog below includes an example.

To Access this Command:

 click:  > 
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Transform menu item

G-Code Browser: Transform menu item

Procedure

1. Select the g-code file from the Project tab that you wish to transform.

2. Select Transform from the Project tab menu.  The Transform dialog will display.

3. Select the type of transformation to make by selecting the corresponding tap at
the top of the dialog (Move, Rotate, Mirror or Scale).

4. Complete the necessary data fields and then pick OK from the dialog to perform
the transformation.

5. The transformation is displayed in the graphics screen and the g-code file is
flagged for Output.

Transform dialog, Move tab

The Move tab of the Transform Toolpath dialog allows you to translate the toolpath by
specifying From and To points for the move. You can either specify these points by
coordinate entry in the corresponding edit fields or could graphically pick the points by
selecting the Pick buttons. Once the points are specified, selecting the apply button will
perform the move operation.
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Dialog Box: Transform Toolpath, Move tab

Move From
Enter the X,Y,Z coordinate values for the Move From point or select the Pick From Part
button to select a point from the model. 

Move To
Enter the X,Y,Z coordinate values for the Move To point or select the Pick To Part button
to select a point from the model. 

Number of Copies
You can also Copy the toolpath by entering the number of copies.

Example: The original g-code file is moved along the Y axis making 3 copies.
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Original G-Code Transfored (Moved with 2 copies) G-Code

Transform Dialog, Rotate tab

Selecting the Rotate tab allows you to rotate the toolpath.  

Dialog Box: Transform Toolpath, Rotate tab

Axis / About(P) / Angle
Rotation can be performed around any of the three principal axes.  The angle of rotation
as well as the point and Axis of rotation can be specified.  

The point of rotation could be one of the Origin, Center of the part, Minimum point of
the part and the Maximum point of the part. 
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The Axis of rotation could be the X, Y or the Z Axis. You can specify any arbitrary rotation
Angle.

Number of Copies
You can also Copy the toolpath by entering the number of copies.

Example: The original g-code file is rotated about the Z axis by 45 degrees.

Original G-Code Transfored (Rotated) G-Code

Transform Dialog, Mirror tab

Selecting the Mirror tab allows you to Mirror the selected toolpath.

Dialog Box: Transform Toolpath, Mirror tab

Mirror Plane
Select the Mirror Plane from the list (XY Plane, XZ Plane or YZ Plane).

Point (P)
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Select a Mirror Point (P) from the list (Origin, Center of the part, Minimum point of the
part) or enter the X,Y,Z coordinate values of the desired point.

You can also select the Pick Plane Point button to select a point from the model.

Create Copy
Check this box to create a Copy of the mirrored toolpath.

Example: The original g-code file is mirrored about the YZ plane keeping the original.

Original G-Code Transfored (Mirrored) G-Code

Transform Dialog, Scale tab

Selecting the Scale tab allows you to scale the selected toolpath.  All scaling is performed
about the zero of the coordinate axes. You can optionally scale from a mm to an inch or
vice-versa or by specifying a scale factor. You can also scale the selections uniformly or
perform non-uniform scaling in each of the three principal axes.
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Dialog Box: Transform Toolpath, Scale tab

Scale Units
Select the Scale Units from the list (To Millimeters or To Inches).

Uniform Scaling
Select this option and then enter the uniform X,Y and Z scale factors.

Non-Uniform Scaling
Select this option and then enter the actual non-uniform  X,Y and Z length values.

Example: The original g-code file is scaled by 1.5 times the size of the original.

Original G-Code Transfored (Scaled) G-Code

Related Topics

User Interface

Project Tab
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Load

Info

Merge Files

Z Instance

XY Instance

Save

Output

5.4.3 Z Instance

You can create multiple Z level instances of the toolpath via this dialog. This can be
useful in situations where you are manufacturing multiple instances of the same

part or want to create multiple z levels of the original path.

To Access this Command:

  > 

Z Instance menu item

G-Code Browser: Z Instance menu item

Procedure

1. Select the g-code file from the Project tab that you wish to Z Instance.

2. Select Z Instance from the Project tab menu.  The Z Instance dialog will display.
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3. Enter the Z Spacing and # in Z values and then pick OK from the dialog.

4. The g-code is instanced in the Z axis.

Instance Toolpath in Z dialog

The g-code will be copied multiple times in the Z axis.  Negative values can be specified
in the Z spacing. In this case the instances will proceed below the current location of the
toolpath.

Dialog Box: Instance Toolpath in Z Dialog

Spacing
Specify the Spacing between the toolpaths in the Z direction.

# in Z
Specify the total number of instances of the toolpath to create. 

Example: The original g-code file is moved along the Y axis making 3 copies.

Original G-Code  Z Instanced 4copies of G-Code

Related Topics
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User Interface

Project Tab

Load

Info

Merge Files

Transform

XY Instance

Save

Output

5.4.4 XY Instance

You can create multiple instances of the g-code using this command. This can be
useful in situations where you are manufacturing multiple instances of the same

part.

To Access this Command:

 click:  > 

XY Instance menu item

G-Code Browser: XY Instance menu item

Procedure
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1. Select the g-code file from the Project tab that you wish to Z Instance.

2. Select Z Instance from the Project tab menu.  The Z Instance dialog will display.

3. Enter the Z Spacing and # in Z values and then pick OK from the dialog.

4. The g-code is instanced in the Z axis.

Instance Toolpath in a Rectangular Array dialog

You can specify multiple instances in the X and Y directions in two different ways.

Dialog Box: XY Instance Dialog

Method = Spaced

Using the Spaced method, you specify the independent X Spacing and Y Spacing
values between the toolpaths. 

The spacing is then used and applied to the bounding box of the part geometry as
shown in the picture on the dialog.

Enter the number of copies of the instanced toolpath using the # in X and # in Y
values.

Method = Fitted
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Using the Fitted method, you specify a rectangle in which the toolpaths will be
fitted by using the X Length and Y Length values.

The bounding box of the part geometry is considered when computing the number
of toolpaths that can be fitted in the specified space. 

Order

The order of the instancing can also be specified by selecting either X First or Y
First. 

Example

Example: The original g-code file is arrayed on the XY plane spaced 2.5 apart in X
and 5.0 apart in Y with a total of 3 copies in each direction.

Original G-Code XY Instance of G-Code

Related Topics

User Interface

Project Tab

Load

Info

Merge Files

Transform

Z Instance

Save

Output

5.4.5 Save

Use this command to Save a selected G-Code file to the Save Directory specified in the
Preferences dialog under Text Editor Preferences.

To Access this Command:
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 click:  > 

Save menu item

G-Code Browser: Save menu item

Procedure

1. Select one or more g-code files from the Project tab.

2. Select Save from the Project tab menu.  The g-code files are saved to the Save
Directory specified in the Text Editor Preferences dialog.

This is the save directly by default:
C:\ProgramData\MecSoft Corporation\VisualCAM 2023\Edited files\

Related Topics

User Interface

Project Tab

Load

Info

Merge Files

Transform

Z Instance

XY Instance
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Output

5.4.6 Output

Use this command to Output a selected G-Code file to the program specified in the
Preferences dialog under Text Editor Preferences.  For example it could be output to

another text editor or a DNC program to go directly to your CNC machine.

To Access this Command:

 click:  > 

Output menu item

G-Code Browser: Output menu item

Procedure

1. Select a g-code files from the Project tab.

2. Select Output from the Project tab menu.  The g-code file is sent to the Program
to Output specified in the Text Editor Preferences dialog.

By default the Program to Output is set to notepad.

Related Topics

User Interface
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Project Tab

Load

Info

Merge Files

Transform

Z Instance

XY Instance

Save

5.5 Right-Click Menu

5.5.1 Edit-G-Code-File

Use this command to Edit a G-Code file that is currently loaded into the Project
tab of the G-Code Browser.

To Access this Command:

 click:  >  >  > 

Right-Click Menu
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G-Code Browser, Project Tab

Procedure

1. Select a G-Code file that is currently loaded into the Project tab of the G-Code
Browser.

2. Right-click and select Edit from the menu.

3. The G-Code file is loaded into the Edit tab of the G-Code Browser.

Related Topics

Edit-G-Code-File

Simulate G-Code File

Info on G-Code File

Delete G-Code File

5.5.2 Simulate G-Code File

Use this command to Simulate a G-Code file that is currently loaded into the
Project tab of the G-Code Browser.

To Access this Command:
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 click:  >  >  >  

Right-Click Menu

G-Code Browser, Project Tab

Procedure

1. Select a G-Code file that is currently loaded into the Project tab of the G-Code
Browser.

2. Right-click and select Simulate from the menu.

3. The G-Code file is loaded into the Simulate tab of the G-Code Browser.

Related Topics

Edit-G-Code-File

Simulate G-Code File

Info on G-Code File

Delete G-Code File
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5.5.3 Info on G-Code File

Use this command to display Information about a G-Code file that is currently
loaded into the Project tab of the G-Code Browser.

To Access this Command:

 click:  >  >  > 

Right-Click Menu

G-Code Browser, Project Tab

Procedure

1. Select a G-Code file that is currently loaded into the Project tab of the G-Code
Browser.

2. Right-click and select Info from the menu.

Related Topics

Edit-G-Code-File

Simulate G-Code File
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Info on G-Code File

Delete G-Code File

5.5.4 Delete G-Code File

Use this command to Delete a G-Code file that is currently loaded into the
Project tab of the G-Code Browser.

To Access this Command:

 click:  >  >  > 

Right-Click Menu

G-Code Browser, Project Tab

Procedure

1. Select a G-Code file that is currently loaded into the Project tab of the G-Code
Browser.

2. Right-click and select Delete from the menu.

3. The G-Code file is removed from the Project tab.
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Related Topics

Edit-G-Code-File

Simulate G-Code File

Info on G-Code File

Delete G-Code File
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Edit Tab

When you double-left-click on a G-Code file from the Project tree, that file is loaded into
the G-Code Editor.  The Edit tab contains commands to Modify and Navigate the g-code

file.  The Edit tab and commands are listed below.

To Access this Command:

 click:  >  > 

Edit tab

G-Code Browser, Edit Tab

Ribbon Bar Options

 Contains file Edit related commands.
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 Returns to the Project tab.

 Minimizes and maximizes the ribbon bar menu.

 Displays the Preferences dialog.

 Displays the Online Help system.

Edit Tab

 Add line numbers to the g-code file.

 Insert spaces (i.e., delimiters) between g-codes.

 Convert g-code to all UPPERCASE text.

 Delete line numbers from the g-code file.

 Delete spaces (i.e., delimiters) between g-codes.

 Convert g-code to all lowercase text.

 Cut the selected text to the clipboard.

 Copy the selected text to the clipboard.

 Paste the selected text to the current cursor location.

 Find text within the G-Code file.

 Find & Replace text within the G-Code file.

 Undo the last command.

 Print the G-Code file currently loaded in the editor.

 Save the G-Code file currently loaded in the editor.

 Display information about the current g-code file.

Edit Tab, Right-Click Menu

 Go to the Bottom (End) of the G-Code file.
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 Go to the Top (Start) of the G-Code file.

 Go to the next Tool Change code.

 Go to the next Spindle code.

 Go to the next Feedrate code.

 Cut the selected text to the clipboard.

 Copy the selected text to the clipboard.

 Paste the selected text to the current cursor location.

 Find text within the G-Code file.

 Find & Replace text within the G-Code file.

 Undo the last command.

Edit Tab, Display Toolbar

Display Toolbar

 Stock Model Visibility: Turn on/off stock model 

 Part Model Visibility: Turn on/off part model display during simulation.

 Toolpath Visibility: Turn on/off toolpath display

 Follow Toolpath Display: The toolpath is displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath after the tool passes. 

 Trace Toolpath Display: The toolpath is not displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath before the tool passes. 

 Segment Toolpath Display: The toolpath is only displayed for the segment that the
tool is currently on.

Related Topics
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Project Tab

Project Tree

Simulate Tab

Online Help

6.1 Add Line Numbers

Use this command to Add Line Numbers to the g-code file.  Comments are not
assigned line numbers.  These line numbers are included when you save or output

the g-code file.  The line numbers you see to the far left are for reference within the G-Code
Editor only and are not included in the g-code file.

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Add Line # menu item

G-Code Browser: Edit G-Code tab, Add Line # menu item

Procedure
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1. Select Add Line #s from the Edit tab.  This will insert consecutive line numbers at
the beginning of every line that contains g-code.  Note that comments are not
numbered.

Related Topics

User Interface

G-Code Browser

G-Code Edit Tab

Delete Line Numbers

Insert Spaces

Delete Spaces

Make Upper Case

Make Lower Case

Show G-Code Info

6.2 Insert Spaces

Use this command to Insert Spaces between g-codes.  These are also referred to
as "delimiters".  One space is inserted between each g-code.  An example of

inserted spaces is shown in the example below.

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Insert Spaces menu item
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G-Code Browser: Edit G-Code tab, Insert Spaces menu item

Procedure

1. Select Insert Spaces from the Edit tab.  This will insert one a space character
between all g-codes in the g-code file.

Related Topics

User Interface

G-Code Browser

G-Code Edit Tab

Add Line Numbers

Delete Line Numbers

Delete Spaces

Make Upper Case

Make Lower Case

Show G-Code Info

6.3 Make Upper Case

Use this command to convert all alphabetic letters to Upper Case in the g-code file.
 An example of this is shown in the menu example below.
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To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Upper Case menu item

G-Code Browser: Edit G-Code tab, Upper Case menu item

Procedure

1. Select Upper Case from the Edit tab.  This will convert all alphabetic letters to
Upper Case characters in the g-code file.

Related Topics

User Interface

G-Code Browser

G-Code Edit Tab

Add Line Numbers

Delete Line Numbers

Insert Spaces

Delete Spaces

Make Lower Case

Show G-Code Info
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6.4 Delete Line Numbers

Use this command to Delete Line Numbers in the g-code file.  Comments are not
assigned line numbers.  Line numbers, if displayed, are included when you save or

output the g-code file.  The line numbers you see to the far left are for reference within the G-
Code Editor only and are not included in the g-code file.

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Delete Line # menu item

G-Code Browser: Edit G-Code tab, Delete Line # menu item

Procedure

1. Select Del Line #s from the Edit tab.  This will remove all consecutive line
numbers from the beginning of every line that contains g-code.  Note that
comments are not numbered.

Related Topics

User Interface
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G-Code Browser

G-Code Edit Tab

Add Line Numbers

Insert Spaces

Delete Spaces

Make Upper Case

Make Lower Case

Show G-Code Info

6.5 Delete Spaces

Use this command to Delete Spaces between g-codes.  These are also referred to as
"delimiters".  One space is deleted between each g-code.  An example of deleted

spaces is shown in the example below.

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Delete Spaces menu item
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G-Code Browser: Edit G-Code tab, Delete Spaces menu item

Procedure

1. Select Del Spaces from the Edit tab.  This will remove all space characters
between all g-codes in the g-code file.

Related Topics

User Interface

G-Code Browser

G-Code Edit Tab

Add Line Numbers

Delete Line Numbers

Insert Spaces

Make Upper Case

Make Lower Case

Show G-Code Info

6.6 Make Lower Case

Use this command to convert all alphabetic letters to Lower Case in the g-code file.
 An example of this is shown in the menu example below.
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To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Lower Case menu item

G-Code Browser: Edit G-Code tab, Lower Case menu item

Procedure

1. Select Lower Case from the Edit tab.  This will convert all alphabetic letters to
Lower Case characters in the g-code file.

Related Topics

User Interface

G-Code Browser

G-Code Edit Tab

Add Line Numbers

Delete Line Numbers

Insert Spaces
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Delete Spaces

Make Upper Case

Show G-Code Info

6.7 Cut Text

Use this edit tool to Cut (i.e., delete) the currently highlighted text.  The cut text is added
to your Windows clipboard and can be Pasted back into any g-code file within the G-Code

Editor or other Windows program that can display text.

To Access this Command:

 click:  >  >  >  > 

or

 click:  >  >  > 

Cut Text (Right-Click Menu)
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G-Code Browser: Edit tab, Cut Text (Right-Click Menu)

Procedure

1. Use the mouse cursor left-click-drag to highlight the text you wish to remove.

2. Select Cut from the Edit tab or right-click and select Cut from the menu and the
text is removed and added to the Windows clipboard.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Copy Text

Paste Text

Undo Last Edit

Print G-Code
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Save G-Code

6.8 Copy Text

Use this edit tool to Copy the currently highlighted text.  The copied text is added to
your Windows clipboard and can be Pasted back into any g-code file within the G-Code

Editor or other Windows program that can display text.

To Access this Command:

 click:  >  >  >  > 

or

 click:  >  >  > 

Copy Text (Right-Click Menu)

G-Code Browser: Edit tab, Copy Text (Right-Click Menu)



Edit Tab 107

© 2026 MecSoft Corporation

Procedure

1. Use the mouse cursor left-click-drag to highlight the text you wish to copy.

2. Select Copy from the Edit tab or right-click and select Copy from the menu and
the text is copied to the Windows clipboard.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Paste Text

Undo Last Edit

Print G-Code

Save G-Code

6.9 Paste Text

Use this edit tool to Paste the contents of the Windows clipboard into the g-code file at
the location of the cursor.  

To Access this Command:

 click:  >  >  >  > 

or

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file.

Paste Text (Right-Click Menu)
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G-Code Browser: Edit tab, Paste Text (Right-Click Menu)

Procedure

1. Use the mouse to locate the cursor in the desired location.

2. Select Paste from the Edit tab or right-click and select Paste from the menu and
the text is inserted into the G-Code file at the cursor location.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Copy Text

Undo Last Edit

Print G-Code
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Save G-Code

6.10 Find Text

Use this dialog to Find text within your gcode file.  You can use additional options in
the Find dialog shown below.

To Access this Command:

 click:  >  >  >  

or

 click:  >  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file.

The Find dialog

Use this dialog to Find text within your gcode file.  

Find What
Enter the text you wish to find and then pick Find Next to locate it.

Find Next
Go to the next location of the text.

Options

· Match whole word only:  Only complete words will be located.
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· Match case: Use case sensitivity:  Only words that match the
upper/lower case will be located. 

Direction

· Search Up:  Search upwards in the g-code file.

· Search Down:  Search downwards in the g-code file.

Procedure

1. Select Find from the Edit tab or right-click and select Find from the menu.  The
Find dialog will display.

2. Enter the text to find and then pick Find Next.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Copy Text

Paste Text

Find & Replace Text

Undo Last Edit

Print G-Code

Save G-Code

6.11 Find & Replace Text

Use this dialog to Find & Replace text within your gcode file.  You can find and
replace all occurrences of text and use additional options in the Find & Replace

dialog shown below.

To Access this Command:

 click:  >  >  >  

or

 click:  >  >  >  > 
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Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file.

The Find & Replace dialog

Use this dialog to Find & Replace text within your gcode file. 

Find Text
Enter the text you wish to find and then pick Find Next to locate it.

Find Next
Go to the next location of the text.

Replace With
Enter the text you wish to replace with.

Replace
Replace the currently highlighted text with the text entered into the
Replace With field.

Replace All
Search the entire g-code file and replace all occurrences of the Find
Text with the text entered into the Replace With field.

Options

· Match whole word only:  Only complete words will be located.

· Match case: Use case sensitivity:  Only words that match the
upper/lower case will be located. 

Direction

· Search Up:  Search upwards in the g-code file.

· Search Down:  Search downwards in the g-code file.
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Procedure

1. Select Find & Replace from the Edit tab or right-click and select Replace from the
menu.  The Find & Replace dialog will display.

2. Use the Find & Replace dialog shown above to complete the process.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Copy Text

Paste Text

Find Text

Undo Last Edit

Print G-Code

Save G-Code

6.12 Undo Last Edit

Use this command to Undo the last edit made to the g-code file.  You can repeat the
selection to Undo all edits made in the current session.

To Access this Command:

 click:  >  >  >  > 

or

 click:  >  >  > 

Undo Last Edit (Right-Click Menu)
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G-Code Browser: Edit tab, Undo Last Edit (Right-Click Menu)

Procedure

1. Select Undo from the Edit tab or right-click and select Undo from the menu.  The
last edit will be undone.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Copy Text

Paste Text

Find Text

Find & Replace Text
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Print G-Code

Save G-Code

6.13 Print G-Code

Use this command to Print the current g-code file.  The default Windows Print dialog
will display allowing you to select a printing device and print preferences.

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Print menu item

G-Code Browser: Edit tab, Print menu item

Procedure

1. Select Print from the Edit tab.  This will display the Windows Print dialog allowing
you to select a printer or device to print to.

Related Topics

User Interface

Project Tab

Project Tree
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Edit Tab

Cut Text

Copy Text

Paste Text

Undo Last Edit

Save G-Code

6.14 Save G-Code

Select this command to Save the g-code file to the default Save Directory
defined in the Text Editor Preferences dialog.  You original g-code file IS NOT

overwritten.

To Access this Command:

 click:  >  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Save menu item

G-Code Browser: Edit tab, Save menu item

Procedure

1. Select Save from the Edit tab.  This will save the g-code file to the default Save
Directory defined in the Text Editor Preferences dialog.  You original g-code file
IS NOT overwritten.
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Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Copy Text

Paste Text

Undo Last Edit

Print G-Code

6.15 Save As

Select this command to save the g-code file as another name.  The Save As
dialog will display allowing you to select the save as folder and the name of the

saved file.

To Access this Command:

 click:  >  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Save menu item
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G-Code Browser: Edit tab, Save As menu item

Procedure

1. Select Save from the Edit tab and then Save As.  This will save the g-code file to
the folder of your choice.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Copy Text

Paste Text

Undo Last Edit

Print G-Code

6.16 Show G-Code Info

Use this command to display an information window of the current contents of the G-
Code Editor.
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To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Info menu item

G-Code Browser: Edit G-Code tab, Info menu item

Procedure

1. Select Info from the Edit tab.  

2. This will display the Information dialog containing information related to the
current g-code file.

Information dialog
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Related Topics

User Interface

G-Code Browser

G-Code Edit Tab

Add Line Numbers

Delete Line Numbers

Insert Spaces

Delete Spaces

Make Upper Case

Make Lower Case

6.17 Select Full Line

You can select the full line of code. To do so, first make sure Line Numbers are displayed by
selecting Add line #s from the Edit tab menu. Then select the line number displayed in the line
number column. This will select the full line of code. Refer to the example below.

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

Info menu item
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G-Code Browser: Edit G-Code tab, Select Whole Line

6.18 Right-Click Menu

6.18.1 Go to Bottom

Use this command to move the cursor to the last g-code numbered line in the
g-code file.

To Access this Command:

 click:  >  >  >  > 

Bottom (Right-Click Menu)
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G-Code Browser: Edit tab, Bottom (Right-Click Menu)

Procedure

1. Select Bottom from the Edit tab.  This will move the cursor to the last g-code
numbered line in the g-code file.

Related Topics

Go To Bottom

Go to Top

Go to Next Tool

Go to Next Spindle

Go to Next Feedrate

Cut Text

Copy Text

Paste Text

Undo Last Edit

6.18.2 Go to Top

Use this command to move the cursor to the first line in the g-code file.

To Access this Command:
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 click:  >  >  >  > 

Top (Right-Click Menu)

G-Code Browser: Edit tab, Top (Right-Click Menu)

Procedure

1. Select Top from the Edit tab.  This will move the cursor to the first line in the g-
code file.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Go to Bottom

Go to Next Tool

Go to Next Spindle

Go to Next Feedrate

6.18.3 Go to Next Tool

Use this command to move the cursor to the next line in the g-code file that
contains a tool number.
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To Access this Command:

 click:  >  >  >  > 

Next Tool (Right-Click Menu)

G-Code Browser: Edit tab, Next Tool (Right-Click Menu)

Procedure

1. Select Tool from the Edit tab.  This will move the cursor to the next line in the g-
code file that contains a tool number.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Go to Bottom

Go to Top

Go to Next Spindle

Go to Next Feedrate
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6.18.4 Go to Next Spindle

Use this command to move the cursor to the next line in the g-code file that
contains a Spindle code.

To Access this Command:

 click:  >  >  >  > 

Next Spindle (Right-Click Menu)

G-Code Browser: Edit tab, Next Spindle (Right-Click Menu)

Procedure

1. Select Spindle from the Edit tab.  This will move the cursor to the next line in the
g-code file that contains a Spindle code.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Go to Bottom

Go to Top
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Go to Next Tool

Go to Next Feedrate

6.18.5 Go to Next Feedrate

Use this command to move the cursor to the next line in the g-code file that
contains a Feedrate code.

To Access this Command:

 click:  >  >  >  > 

Next Feedrate (Right-Click Menu)

G-Code Browser: Edit tab, Next Feedrate (Right-Click Menu)

Procedure

1. Select Spindle from the Edit tab.  This will move the cursor to the next line in the
g-code file that contains a Feedrate code.

Related Topics

User Interface

Project Tab
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Project Tree

Edit Tab

Go to Bottom

Go to Top

Go to Next Tool

Go to Next Spindle

6.18.6 Cut Text

Use this edit tool to Cut (i.e., delete) the currently highlighted text.  The cut text is added
to your Windows clipboard and can be Pasted back into any g-code file within the G-Code

Editor or other Windows program that can display text.

To Access this Command:

 click:  >  >  >  > 

or

 click:  >  >  > 

Cut Text (Right-Click Menu)
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G-Code Browser: Edit tab, Cut Text (Right-Click Menu)

Procedure

1. Use the mouse cursor left-click-drag to highlight the text you wish to remove.

2. Select Cut from the Edit tab or right-click and select Cut from the menu and the
text is removed and added to the Windows clipboard.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Copy Text

Paste Text

Undo Last Edit

Print G-Code
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Save G-Code

6.18.7 Copy Text

Use this edit tool to Copy the currently highlighted text.  The copied text is added to
your Windows clipboard and can be Pasted back into any g-code file within the G-Code

Editor or other Windows program that can display text.

To Access this Command:

 click:  >  >  >  > 

or

 click:  >  >  > 

Copy Text (Right-Click Menu)

G-Code Browser: Edit tab, Copy Text (Right-Click Menu)
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Procedure

1. Use the mouse cursor left-click-drag to highlight the text you wish to copy.

2. Select Copy from the Edit tab or right-click and select Copy from the menu and
the text is copied to the Windows clipboard.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Paste Text

Undo Last Edit

Print G-Code

Save G-Code

6.18.8 Paste Text

Use this edit tool to Paste the contents of the Windows clipboard into the g-code file at
the location of the cursor.  

To Access this Command:

 click:  >  >  >  > 

or

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file.

Paste Text (Right-Click Menu)
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G-Code Browser: Edit tab, Paste Text (Right-Click Menu)

Procedure

1. Use the mouse to locate the cursor in the desired location.

2. Select Paste from the Edit tab or right-click and select Paste from the menu and
the text is inserted into the G-Code file at the cursor location.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Copy Text

Undo Last Edit

Print G-Code
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Save G-Code

6.18.9 Undo Last Edit

Use this command to Undo the last edit made to the g-code file.  You can repeat the
selection to Undo all edits made in the current session.

To Access this Command:

 click:  >  >  >  > 

or

 click:  >  >  > 

Undo Last Edit (Right-Click Menu)

G-Code Browser: Edit tab, Undo Last Edit (Right-Click Menu)
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Procedure

1. Select Undo from the Edit tab or right-click and select Undo from the menu.  The
last edit will be undone.

Related Topics

User Interface

Project Tab

Project Tree

Edit Tab

Cut Text

Copy Text

Paste Text

Find Text

Find & Replace Text

Print G-Code

Save G-Code
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Simulate Tab

When you double-left-click on a G-Code file from the Project tree, that file is loaded
into the G-Code Editor.  The Simulate tab contains commands to perform tool

motions and cut material simulations of the g-code file.  The Simulate tab and commands are
listed below.  Note: You must have Stock, Tool Library and Tool Crib defined before performing a
Simulation.  

To Access this Command:

 click:  >  > 

Simulate tab

G-Code Browser, Simulate Tab

Ribbon Bar Options

Contains file Simulation related commands.

 Returns to the Project tab.

 Minimizes and maximizes the ribbon bar menu.

 Displays the Preferences dialog.
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 Displays the Online Help system.

Simulate Tab, Options Pane

 Display Simulation Preferences.

 Simulation speed adjustment (Left: Slow, Right: Fast).

 Check to simulate by moves.  Uncheck to simulate by distance.  See
Preferences to set the default mode.

Simulate Tab, Simulate Pane

 Play the simulation.

 Step through the simulation by distance or by moves.

 Display simulation in Levels.

 Go direction to the End result of the simulation.

 Pause the simulation.

 Stop the simulation.

Simulate Tab, Display Toolbar

Display Toolbar

 Stock Model Visibility: Turn on/off stock model 

 Part Model Visibility: Turn on/off part model display during simulation.

 Toolpath Visibility: Turn on/off toolpath display

 Follow Toolpath Display: The toolpath is displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath after the tool passes. 
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 Trace Toolpath Display: The toolpath is not displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath before the tool passes. 

 Segment Toolpath Display: The toolpath is only displayed for the segment that the
tool is currently on.

Related Topics

Project Tab

Project Tree

Edit Tab

Online Help

7.1 Simulate Options

7.1.1 Simulation Preferences

Select this button to display the Simulation Preferences dialog.  This is the same as

selecting  > Simulation.  

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate tab, Preferences menu item

G-Code Browser: Simulate, Preferences menu item

Procedure
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1. Select Preferences from the Simulate tab.  This will display the Simulate
Preferences dialog.

Preferences > Simulation

2. Make desired changes and then pick Apply.  Pick OK to close the dialog.

Related Topics

Simulate Tab

Simulation Speed

Simulation Mode

7.1.2 Simulation Speed

You can use this slider to adjust the simulation speed.  Left is slower and
right is faster.  You can set the default speed for simulations from the

Simulation Preferences dialog.  

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate, Speed menu item
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G-Code Browser: Simulate, Speed menu item

Procedure

1. Left-click and drag the slider to adjust the Simulation Speed.  Left is slower and
right is faster.

Related Topics

Simulate Tab

Simulation Preferences

Simulation Mode

7.1.3 Simulation Mode

You can use this checkbox to Simulate by Moves.  If unchecked, the
simulation is calculated by distance as defined in the Simulation

Preferences dialog.  

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate, Mode menu item
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G-Code Browser: Simulate, Mode menu item

Procedure

1. Check the box to Simulate by Moves.  Uncheck the box to Simulate by Distance. 
The increment for moves and distance can be controlled from the Simulation
Preferences dialog.

Related Topics

Simulate Tab

Simulation Preferences

Simulation Speed

7.2 Simulation Controls

7.2.1 Play Simulation

Select this commend to Play the simulation.  If Stock is defined, a cut material simulation
is displayed.  If no Stock is defined only the tool motions is simulated.  

To Access this Command:

 click:  >  >  >  

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate, Play menu item
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G-Code Browser: Simulate, Play menu item

Procedure

1. Select Play from the Simulate tab and the simulation will begin from the current
tool location.

Related Topics

Simulate Tab

Step Thru Simulation

Display Simulation Levels

Simulate to End

Pause Simulation

Stop Simulation

7.2.2 Step Thru Simulation

Select this command to Step through the simulation.  Each step is determined by the
Simulation Mode.  You can control this from the Simulation Preferences dialog.  

To Access this Command:

 click:  >  >   >  (with Simulation Window
displayed)

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate, Step menu item
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G-Code Browser: Simulate, Step menu item

Procedure

1. Select Step from the Simulate tab and the simulation will advance by one
increment.  The increment is determined by the Simulation Mode.  You can
control this from the Simulation Preferences dialog.

Related Topics

Simulate Tab

Play Simulation

Display Simulation Levels

Simulate to End

Pause Simulation

Stop Simulation

7.2.3 Display Simulation Levels

If your toolpath has multiple Z levels, you can select this command to move the
tool to the end of each level.  If Stock is defined, the cut material simulation at

each Z level is displayed.

To Access this Command:

 click:  >  >  >  

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate, Step Levels menu item
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G-Code Browser: Simulate, Step Levels menu item

Procedure

1. Select Step Levels from the Simulate tab and the simulation will advance to the
end of the current Z level.

Related Topics

Simulate Tab

Play Simulation

Step Thru Simulation

Simulate to End

Pause Simulation

Stop Simulation

7.2.4 Simulate to End

You can select this command to move the End of the simulation.  If Stock is defined,
the final cut material simulation is displayed.  

To Access this Command:

 click:  >  >  >  (with Simulation Window
displayed)

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate, To End menu item
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G-Code Browser: Simulate, To End menu item

Procedure

1. Select To End from the Simulate tab to move the End of the simulation.

Related Topics

Simulate Tab

Play Simulation

Step Thru Simulation

Display Simulation Levels

Pause Simulation

Stop Simulation

7.2.5 Pause Simulation

You can select this command to Pause the simulation at the current tool location.  If
Stock is defined, the cut material simulation is also paused.  

To Access this Command:

 click:  >  >  >  

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate, Pause menu item
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G-Code Browser: Simulate, Pause menu item

Procedure

1. Select Pause from the Simulate tab to Pause the simulation at the current tool
location.

Related Topics

Simulate Tab

Play Simulation

Step Thru Simulation

Display Simulation Levels

Simulate to End

Stop Simulation

7.2.6 Stop Simulation

You can select this command to Stop the simulation at the current tool location.  If Stock
is defined, the cut material simulation is also stopped.  

To Access this Command:

 click:  >  >  > 

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

G-Code Browser: Simulate, Stop menu item
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G-Code Browser: Simulate, Stop menu item

Related Topics

Simulate Tab

Play Simulation

Step Thru Simulation

Display Simulation Levels

Simulate to End

Pause Simulation
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Functions from the MILL Module

You can access the G-Code Editor module from within the MILL module by clicking on the G-Code
icon located in each machining operation (Mop) folder as shown below if the icon is not flagged. 
However, ONLY the Edit tab is available and you cannot simulate G-Code. 

How G-Code is Stored

Your G-Code data is stored with your CAM part files.  When you generate a toolpath
operation in the MILL module the G-Code related to that operation is stored with the
CAM part file.  This means that you will always have access to the latest G-Code
generated for any operation.

To Access G-Code from the MILL Module

To access the G-Code Editor from an operation that you have generated within the MILL
module simply click on the G-Code icon within the mop folder as shown below:

G-Code Browser: Tool Crib menu item

The Machining Browser will be replaced with the Edit tab of the G-Code Editor as shown
below.  To return to the MILL module pick the left arrow icon at the top of the G-Code
Editor browser as shown below.
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G-Code Browser: Tool Crib menu item
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Find More Resources

Download this PDF Guide for a list of the available VisualCAM Resources.

2025 VisualCAM Resource Guide

The 2026 VisualCAM Resource Guide!

18 Pages

Lists PDF downloads and Online resources including Quick Start
Guides, Reference Guides, Exercise Guides, Tutorials and
More.

Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2026.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QISEAjFqPkrNRyUTOYw9ZRZ
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Cutting Tools     21

Simulation     22, 135

Stock     20

Text Editor     17

Toolpath     18

User Interface     14

Print G-Code     114

Project    

Tab     27, 40

Tree     29

- R -
Replace Text     110

Rotate G-Code     73

- S -
Save As     116

Save G-Code     84, 115

Scale G-Code     73

Select    

Full Line     119

Show G-Code Info     117

Simulate    

G-Code File     88

Tab     35, 133

Simulation    

Display Levels     140

Mode     137

Pause     142

Play     138

Preferences     22, 135

Speed     136

Step Thru     139

Stop     143

To End     141

Stock    

Box     48

Cylinder     54

Delete     59

from Selection     60

Menu     47

Part Box     51

Part Cylinder     56

Preferences     20



VisualCAD/CAM 2026 G-Code Editor Reference150

© 2026 MecSoft Corporation

Stock    

Toggle Visibility     32, 93

Transparency     20

- T -
Text Editor Preferences     17

Toggle Follow Toolpath Display     32, 93

Toggle Part Visibility     32, 93

Toggle Segment Toolpath Display     32, 93

Toggle Stock Visibility     32, 93

Toggle Toolpath Visibility     32, 93

Toggle Trace Toolpath Display     32, 93

Tool Crib     65

Tool Library     62
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Display width     18

Follow Display     32, 93

Preferences     18

Segment Display     32, 93

Toggle Visibility     32, 93
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Tools (See Cutting Tools)     62
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Rotate     73
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- U -
Undo Last Edit     112, 131

User Interface     13
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