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Quick Start

CAM Module 2026
Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

Quick Start Guides for each VisualCAD/CAM module are available in both PDF and Video format. 
Refer to the following information to access these resources:

What's New!

What's New in VisualCAD/CAM 2026

The Complete Quick Start Video Play List

Here is a link to the complete 2026 Video Play List

How to Access the Quick Start Guide Documents

To help you quickly get started in working with each module, select one of the Help
buttons located on the VisualCAD/CAM Learning Resources dialog.  

You will find:

· Quick Start Guides  

· What's New documents  

· Online Help links

The Quick Start Guides will help you step through an example tutorial which will
illustrate how to use the module.  To access the Learning Resources dialog:

1. From the VisualCAD Home Ribbon Bar, drop down the Main menu and select Learn ...  

https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2026.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QISEAjFqPkrNRyUTOYw9ZRZ
https://www.youtube.com/playlist?list=PLx9G05pFm0QKmM1LY2ydDA_vro-WPOo4E
https://www.youtube.com/watch?v=DhaKXniztt4&list=PLx9G05pFm0QKmM1LY2ydDA_vro-WPOo4E
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To access the Learning Resources dilog in VisualCAM

2. Select a document from the Learning Resources dialog to get started using the
module of your choice.  

 You can also select the Open Quick Start Files Folder button located at the bottom
of the dialog to open the Quick Start folder where the source files (start and
completed versions) are located.
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Learning Resources Dialog
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Resource Guide

Download this PDF Guide for a list of the available VisualCAD/CAM Resources.

2026 VisualCAD/CAM Resource Guide

The 2026 VisualCAD/CAM Resource Guide!

18 Pages

Lists PDF downloads and Online resources including Quick Start
Guides, Reference Guides, Exercise Guides, Tutorials and
More.

Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2026.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QISEAjFqPkrNRyUTOYw9ZRZ
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About this Guide

VisualCAD/CAM is a plug-in that is completely integrated within VisualCAD.  To become familiar
with the MILL module we will assume that you have previously completed one or more of these
guides.  If you have not, please do so before reviewing this workbook.

This guide will show you how to create tools and setup your first tool library in the
VisualCAD/CAM MILL module.  It is recommended that you do not attempt the Advanced Topics
section of the guide until you are familiar working with tools and tool libraries in the
VisualCAD/CAM MILL module.  

3.1 About the MILL Module

The MILL module offers fast gouge free solids/surface model machining technology coupled with
cutting simulation/verification capabilities running inside VisualCAD for programming CNC Mills.
This integration allows for seamless generation of toolpath and cut material
simulation/verification within VisualCAD, for programming milling machines that support 3, 4 and
5 axis continuous machining3 & 4 axis continuous machining and indexed 5 axis (3+2) machining.

The module also comes with numerous post-processors to output the programmed G-code to
some of the most popular machines on the market.  A simple and well thought out user interface
makes this system one of the most intuitive and easy to use milling systems available today.

You can work with the native VisualCAD data as well as use any of the data types that can be
imported into VisualCAD such as solids, surfaces and meshes. Then you can use the
VisualCAD/CAM MILL module with its wide selection of tools and toolpath strategies to create
machining operations and associated toolpaths for CNC Mills. These toolpaths can then be
simulated and verified, and finally post-processed to the controller of your choice.

On-line help compiled on: Wednesday, March 11, 2026

3.2 About the TURN Module

The VisualCAD/CAM-TURN Module (VisualTURN) is a unique turning product that is used for
offline programming of 2 Axis CNC Lathes.  This product is a module of VisualCAD/CAM, which is
completely integrated inside of VisualCAD.  This integration allows for the seamless generation of
toolpaths and cut material simulation/verifications inside of VisualCAD for programming turning
machines.  

The VisualCAD/CAM-TURN module also comes with numerous post-processors to output the
programmed G-code to some of the most popular CNC machine controllers on the market today. 
Additionally, the VisualCAD/CAM-TURN module also includes a post-processor generator that has
the capability to configure entirely new post-processors.  These features make programming CNC
Turning easy and affordable.

The VisualCAD/CAM-TURN module supports turning and hole making operations such as Turn
Roughing, Turn Finishing, Groove Roughing, Groove Finishing, Threading, Parting and Hole making
operations such as Drilling, Tapping, Boring, Reverse Boring and Threading. 

On-line help compiled on: Wednesday, March 11, 2026
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3.3 Using this Guide

The Tool Library Workbook will help you create your first Tool Library in VisualCAD/CAM MILL.  If
you have existing tool inventory in your shop, the Tool Worksheets located in the Reference
section of this guide can be printed out and used to record the information and dimensions that
VisualCAD/CAM MILL uses to define tools.  The Advanced Topics section is full of useful tips and
procedures that you can use to get the most from your VisualCAD/CAM MILL software.  

Here is a short list of things you can do with this guide:

1. How to create Tools in VisualCAD/CAM MILL.

2. How to create, save and load a Tool Library.

3. Help you gather information about your existing tool inventory and add them to a library.

4. How to use the Feeds & Speeds Calculator.

5. How to perform other Advanced tool related tasks in VisualCAD/CAM MILL.
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Getting Ready

4.1 After Installing VisualCAD/CAM MILL

After you install the VisualCAD/CAM module, determine if you have existing tools for your CNC
machine to work with.  If so, go to the Reference section of this guide and print out the Tool
Worksheets.  Use them to gather the correct information that VisualCAD/CAM will need to add
them to it's Tool Library.  See Add your Existing Tools to a Library for more information.

4.2 Locate the Tools Tab

After installing VisualCAD/CAM you can locate the Tools tab by referring to the image below.  It is
located below the Machining Browser and at the top of the Machining Objects Browser.  

· After installing VisualCAD/CAM load the MILL or TURN modules and locate the Tools tab
shown below.

4.3 The Create/Select Tools Dialog

To display the Create/Edit Tools dialog:

1. Select the Tools tab under Machining Objects Browser

2. Select the Create/Edit Tools. icon.

3. The Create/Edit Tools dialog will display.
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Dialog Box: Create/Select Tools
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Creating Tools

5.1 Create a Tool

You can create a tool anytime before or during the creation of a toolpath operation.  Here is the
basic procedure:

1. Select the Create/Edit Tools button from the Tools tab of the Machining Objects Browser
or from the Tools tab of the toolpath operation you are in the middle of creating.

or
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2. This will display the Create/Edit Tools dialog shown below.  Notice that you can enter
expressions in the parameter fields.  See Tool Related Preferences to see how to
enable/disable expressions in dialogs.
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Dialog Box: Create/Select Tools

3. Select one of the Tool Type icons from the top of the dialog.

4. In the Name field enter a name for the Tool.  A default name is provided but you should
consider giving more descriptive names for your tools.

5. Enter the physical dimensions of the tool you would like to create.  Default dimensions
are provided.  As you change the dimensions, the Preview of the Tool will update in the
dialog.  

However, it is very important that you enter the accurate dimensions of the actual tool
you plan to use.

6. Under the Properties tab (on the right of the dialog) select the Material of the Tool and
then enter the tool properties requested for the tool.  The Tool Number must be unique
to this tool and the Adjust Register and Cutcom Register are typically assigned the same
value of the Tool Number.  The Number of Flutes will affect the Spindle Speed and
computed Cut Feed Rate.  We'll get to those in a moment.  For a definition of each
parameter you can pick the Help button located at the bottom of the dialog.  If you enter
text in the Comments window they will be posted to your g-code file prior to the tool
number being called.
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7. Now select the Feeds & Speeds tab.  Here you can manually set the Spindle Parameters
and Feed Rates for this tool.  If you do not know what Feed Rate values to use, select the
Load from File button.  It displays what we refer to as the Feeds & Speeds Calculator.  It
will suggest values based on the Stock Material, Tool Material and other Tool parameters.  
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8. When you are done defining your tool's parameters, select the Save as New Tool
button.  The new tool is created and added to the Tools in Session list located on the
left side of the dialog.  This means that your tool is defined in your current session of
VisualCAD/CAM ONLY.  When you save your part file, the tool will be saved along with it.
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9. IMPORTANT: After your tool is listed in the Tools in Session list, if you make ANY
changes to the tool parameters, you must select the Save Edits to Tool button for your
revisions to be saved.

You can edit the tool properties and click Save Edits to Tool to save the changes.
You can create additional tools by assigning a different name and specify the tool

parameters.

10. When done, pick the OK button to close the Create/Edit Tools dialog.
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To save Tools to a library, Click Save Tool Library under the Tools tab in the
Machining Objects Browser and specify a folder location and file name in the

Save as dialog box. Saving a Tool library as a Knowledge base file (*.vkb) saves feeds
and speeds with tool properties.

See Create a Tool Library for instructions on how to do this.

5.2 Create a Tool Holder

You can create a Tool Holder anytime before or during the creation of a toolpath operation.  Here
are the basic steps.

1. Select the Create/Edit Tools button from the Tools tab of the Machining Objects Browser
or from the Tools tab of the toolpath operation you are in the middle of creating.

or
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2. This will display the Create/Edit Tools dialog shown below.  Notice that you can enter
expressions in the parameter fields.  See Tool Related Preferences to see how to
enable/disable expressions in dialogs.
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Dialog Box: Create/Select Tools

3. To create or edit your holders, pick the ... button to display the Create/Select Holder
dialog.  Holders are save with your tool library.

Location of the Holders menu

4. Use the Create/Edit Tool Holder dialog to define your Tool Holders.
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Dialog Box: Create/Edit Tool Holders

5. In the Name field enter a name for the Tool Holder. The name must be unique to the
holder being defined.

6. Tool Holders are created in segments. Each segment has three dimensions. These are:
Diameter, Length and Taper.

7. When you are satisfied with your segment dimensions, select the Add button and the
segment will be added to the Holder Segments list.

8. To edit a segment, first select it from the list and then pick the Edit Active button.

9. Select a segment and then use the Move Up and Move Down buttons to arrange the
segments in the proper order that defines the holder being created. 

10. A preview of the active Tool Holder is displayed on the right. 

11. Use the buttons under the preview window to Save, Edit or Delete the the active Tool
Holder.

12. When your holder is defined, select the Exit button to return to the Create/Select Tool
dialog. 

13. To use a Holder, first select a Tool or create one using the Create/Select Tool dialog.

14. Then drop down the Holder menu and select a Holder for that Tool.

5.3 Create a Tool Library

When you create tools they are only saved with the part file you are working on.  To reuse tools
efficiently in VisualCAD/CAM, from one job to the next, you should create a Tool Library that
contains all of the tools in your CNC shop's inventory.



Creating Tools 23

© 2026 MecSoft Corporation

VisualCAD/CAM automatically installs a Tool Library that you can customize with
your tools.  It is available in both English and Metric versions.  See the topic Use

The Pre-Installed Tool Library for more information.

The steps below will walk your through creating your own tool library.

1. Complete the steps in the topic Create a Tool to create to create your first tool.  It should
be listed under the Tools tab:

2. From the Tools tab menu select the Save Tool Library icon from the menu:

3. From the Save As dialog that displays, change the Save as Type selector to *.vkb.  Both
formats (*.vkb or *.csv) allow the Feeds & Speeds parameters to be saved along with each
tool definition but the *.vkb format is recommended.

Select a folder location that is unique to your company or computer and NOT
located within the install path of VisualCAD/CAM.  For example this can be a

network drive or even just your Desktop.

4. Now enter a name for your Tool Library (i.e., My_First_Tool_Library.vkb) and pick Save.

5. See the topic Tool Related Preferences to learn how to make your Tool Library load
automatically every time a new part is created in VisualCAD.
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5.4 The Feeds & Speeds Calculator

The MILL Module has a built-in Feeds & Speeds Calculator. 
That’s right, you can ask the program to suggest feeds & speeds
values based on your current stock material and active tool
parameters!  Once a Cut Feed is calculated, you can then choose
to automatically assign feed rate values for the various toolpath
motions in your operation including Plunge, Approach, Engage,
Retract and Departure!  The percentages of the Cut Feed to
assign are all controlled from the CAM Preferences dialog.

Of course you can override any of these calculated values at any
time, for any tool and for any operation.

Feeds & Speeds Associated with a Tool

In the MILL Module, feeds & speeds can be defined and associated with a specific tool. 
This allows you the flexibility to have different tool definitions based on the type of
material being cut (i.e., steel, wood, acrylic, etc.) or the operation type (Pocketing,
Facing, etc.).  The Create/Select Tool dialog includes a Feeds & Speeds tab where these
values are defined.  When the tool is saved, the feeds & speeds values are saved with it.

Dialog Box: Create/Select Tools

Feeds & Speeds Associated with an Operation

Each toolpath operation type also has a Feeds & Speeds tab in its dialog.  This allows you
the flexibility to assign feeds & speeds values specific to that operation.  The 2½ Axis



Creating Tools 25

© 2026 MecSoft Corporation

Pocketing operation dialog is shown here.

Each Feeds & Speeds tab also contains a button called Load from Tool.  This allows you to
load the feeds & speeds values that you have previously associated with active tool.  The
Active Tool simply refers to the tool that you have selected from the Tools tab of the
dialog.

As you can see, just between the tool and the operation type, you have a wide range of
flexibility for defining your feeds & speeds strategy.

The Feeds & Speeds Calculator

You may have noticed that both the Feeds & Speeds tab of the Create/Select Tool dialog
and the Feeds & Speeds tab of the operation dialog have a button called Load from File …
 Selecting this button will display the Feeds & Speeds Calculator dialog.  This dialog
allows you to load feeds & speeds values that are calculated from information stored in
an external Materials XML file.

How does it Work?

There are two parts to the calculator.

Data from Table
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This information is extracted from the default Materials XML table file and is based on
the following parameters:

1. The Stock Material is selected from the Materials dialog located on the Program
tab.

2. The Tool Material is selected from the Properties tab of the Create/Select Tools
dialog.

The values for Surface Speed (measured in units per minute) and Feed per Tooth
(measured in units) are retrieved from the XML file and displayed in the dialog.  Units
refers to the part file’s current Units setting.

Input Variables

The values for Tool Diameter and # of Flutes are automatically loaded based on the tool
selected for the operation (i.e., the active tool).  Based on these parameters, the
program computes a Spindle Speed value measured in RPM (Rotations per Minute).   

Computed Cut Feedrate

A Cut Feed value is also calculated for you (measured in Units/Minute) based on Stock
Material, Tool Material, Tool Diameter, and # of Flutes.  Changing the Spindle Speed
updates the Cut Feed and vice versa.

When you pick OK from this dialog, the computed Feeds & Speeds values are submitted
to either the active tool or the active toolpath operation.

Formulas Used for Cut Feed Computation

Units in Inches

Spindle Speed
(RPM) 

Surface Speed (SFM) x 12 / x Tool Diameter(in))

Cut Feed (IPM) Feed Per Tooth(IPT) x # of Flutes x Spindle Speed(RPM)

SFM: Surface Feet Per Minute
IPT: Inches Per Tooth
RPM: Revolutions per Minute
IPM: Inches Per Minute

Units in Millimeters

Spindle Speed
(RPM) 

Surface Speed (SMM) * 1000 / x Tool Diameter (mm))

Cut Feed (IPM) Feed Per Tooth(MMPT) x # of Flutes x Spindle Speed(RPM)
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SMM: Surface Meters Per Minute
MMPT: Millimeters Per Tooth 
RPM: Revolutions per Minute
MMPM: Millimeters Per Minute

Let’s Review:

1. You can associate unique feeds & speeds values with each tool or with each
operation.

2. You can invoke the Feeds & Speeds Calculator from either the Create/Select Tool
dialog or from any toolpath operation dialog.

3. The Feeds & Speeds Calculator extracts data from an external XML file and
combines it with your stock material and tool parameters to calculate suggested
Spindle Speed and Cut Feed values.

4. Changing parameters such as Tool Diameter, Surface Speed, Material, etc. will
calculate new Spindle Speed and Cut Feed values automatically.

5. A percentage of the calculated Cut Feed can be assigned for Plunge, Approach,
Engage, Retract and Departure motions.  These percentages are set in the CAM
Preferences Dialog.

6. You can override ANY or ALL of the suggested feeds & speeds values at any time!

More information about the Load from File button:

This loads the Feeds & Speeds values from the Feeds & Speeds Table file.  This will display the
Load Feeds from Table dialog box to make your selections. 

Dialog Box: Load Feeds from Table

Selecting OK from this dialog transfers the spindle speed and cut feedrate to the Feeds &
Speeds tab. The plunge, approach, engage, retract and departure feeds are determined
using a percent of the cut feed.  The percent to use for transferring the computed cut
feed can be set under Feeds & Speeds Preferences.
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Dialog Box: Load Feeds from Table

Data from Table

Stock Material
Selecting a Stock Material and Tool Material displays the Surface Speed and Feed/Tooth.
This information is contained in a feeds and speeds data file which can be edited to add
newer materials.

Tool Material
Selecting a Stock Material and Tool Material displays the Surface Speed and Feed/Tooth.
This information is contained in a feeds and speeds data file which can be edited to add
newer materials.

Surface Speed
Selecting a Stock Material and Tool Material displays the Surface Speed and Feed/Tooth.
This information is contained in a feeds and speeds data file which can be edited to add
newer materials.

Feed/Tooth
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Selecting a Stock Material and Tool Material displays the Surface Speed and Feed/Tooth.
This information is contained in a feeds and speeds data file which can be edited to add
newer materials.

Input Variables

The input variables - Work Diameter is automatically loaded from the Stock Radius. 
Based on this parameter and the Variables Limits parameters, the program computes
Spindle Speed and Cut Feedrate (Cf). measured in Unites/Revolution.  Changing the
spindle speed modifies the cut feedrate.

Maximum Limits for Computation

Here you can set the Max Spindle Speed and Max Cut Feed (Cf) values.  Once these two
values are set, the Spindle Speed and Cut Feed calculated by this dialog will not exceed
these values even if you attempt to enter higher values into the Computed Variables
fields.  To exceed these values, change them here or you must edit the operation or tool
parameters manually.

Computed Variables

The variables for Spindle Speed and Cut Feed (Cf) are computed for you based on the
selections made in this dialog but will not exceed the values set in the Maximum Limits
for Computation section of the dialog.  These values are then assigned to the active
toolpath operation or tool.  You can override either of these variables and the other will
update automatically.  Since this dialog is a Feeds & Speeds Calculator, you cannot
override both values.  To do so, you must edit the operation or tool parameters
manually.

5.5 Use The Pre Installed Tool Libraries

VisualCAD/CAM MILL. comes with two Tool Libraries (INCH and METRIC) each containing over 50
Tools that you can use and modify to create your own customized Tool Library.  To see a complete
list of the tools in these default libraries, visit the Default Tool Libraries section of this guide.

How to load the default Tool Library:

1. Go to the Tools tab and select the Load Tool Library icon.
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2. Navigate to the /Data folder of the install path in VisualCAD/CAM.
By default it is located at: C:\ProgramData\MecSoft Corporation\VisualCAM 20xx\Data

3. In the File Open dialog, change the file type to Tool Library Text Files (*.csv).

4. Select the DefaultEnglishTools.csv or the DefaultMetricTools.csv file and then pick Open.

5. The message will inform you of the total number of tools that were loaded.

6. The tools in the library will also be listed in the Tools tab.
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7. If you DO NOT see the tools listed, make sure the icon for List tool only used in operations
IS NOT toggled on.

8. You can now edit each of these tools as needed to start your own Tool Library!
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Dialog Box: Create/Select Tools

5.6 Add your Existing Tools to a Library

If you have existing tool inventory in your shop, the Tool Worksheets located in the Reference
section of this guide can be printed out and used to record the information and dimensions that
VisualCAD/CAM MILL uses to define tools.

Here are the basic steps to get started:

1. Go to the Tool Worksheets located in the Reference section of this guide and print out the 
Worksheet for each tool type.

2. Fill out a worksheet for each of the tools in your existing shop's inventory.  Each
worksheet lists the key dimensions that are needed to define each tool in
VisualCAD/CAM.  Here is an example worksheet:
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3. With worksheets in hand, Create a Tool or load and/or create a Tool Library.  See Create a
Tool and Create a Tool Library in this guide for more information about how do this.

4. Note: The tool spec sheet from your tool vendor will have a lot of information.  Pay close
attention to which dimensions you need to write down.  For example, if your tool has an
insert (i.e., a boring tool), you only need to document the total Tool Diameter.

5. When done entering all of your existing tools be sure to Save your Tool Library and use a
unique file name and location outside of VisualCAD/CAM install path.

5.7 More about the Tools Tab

Here is additional information about the Tools tab:

The Machining Objects (Mobs) Browser, Tools Tab
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The Machining Objects (MObs) Browser, Tools Tab

VisualCAD/CAM supports 2 types of tool library file format *.vkb and *.csv (*.vkb is
recommended).

Tools Tab Functions

Summary

Available Configuration

Xpress
(XPR)

Standard
(STD)

Expert
(EXP)

Professional
(PRO)

Premium
(PRE)

Tools Tab Functions

Create/Edit Tools: This button brings up the tool dialog that
enables the creation and saving of tools. All milling, drilling and
user defined tools can be created here.  Refer to Tool section
for a detailed description on creating tools and defining tool
parameters.

Load Tool Library: The load tool library button enables the
loading of a previously saved tool library.  Refer to the
following section for additional information - Load Tool Library

Select Tools from Library: The select tool library button enables
you to select tools from a previously saved tool library.  Refer to
the following section for additional information - Select Tools
from Library

Save Tool Library: This button enables the created tools to be
saved in a tool library file. The file can be saved in the desired
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directory and read in when required.  Refer to the following
section for additional information - Save Tool Library

Unload Tool Library: This button will unload the current Tool
Library.

List Tools: The button brings up all the tool properties
associated with the tools currently recorded in the current MILL
session.  Refer to the following section for additional
information - List Tools

Compute Tool Holder Collisions*: Determines tool holder
collision with the part geometry.  Refer to the following section
for additional information - Compute Tool Holder Collisions

Right-click Options on Tools

You can right-click on a Tool listed in the Mobs Browser to perform various functions. 
These are listed below:

Right-click Options on a Tool

Edit  
Displays the Create/Edit Tool dialog allowing you to edit the Tool parameters.

Rename  
Allows you to Rename the selected tool.
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Cut / Copy / Paste  
These options allow you to Cut or Copy the selected Tool to the Windows
Clipboard and then Paste it back to the Tools list to create a new tool using the
previous tool as a template.

Add to Library
This allows you to Add the selected Tool to an exiting Tool Library *.csv data file.

Preview
This will display a Preview of the selected Tool in the Graphics Window similar
to how the Tool displays during Simulation.  The Tool will display at the origin of
the MCS for the current operation. 

Tools Toolbar Functions

The following Tool Sorting rules (when set) will apply to both the Tools tab of the
Machining Objects Browser and the Create/Select Tools dialog.

Sorting Selector: This allows you to sort the tool list.  You can
select No Sort or sort by Name, Number, Type and Diameter.

Sort in Ascending/Descending Order: This icon acts like a toggle to
switch between Ascending and Descending sort order.

List on the Tool used in Machining Operations: Toggle this icon to
list ONLY the tools currently assigned to an operation.  Note: You
must Generate an operation for the assigned tool to be listed. 

If you do not see any of your tools listed, check to make sure
this icon is toggled OFF.  If no operations are using tools yet

and this icon is ON, then no tools will be listed!
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Tools Sorted by Name

Tools Sorted by Used

Tools Status Bar

The status bar displays the currently selected tool, tool tip radius & angle, spindle speed
and cut feedrate.

Status Bar, Tools Tab, Machining Objects Browser

5.8 More about the Create/Select Tools dialog

Here is some additional information specific to the Create/Select Tool dialog:

Tool Holder Types

Tool Holder

Types

Configuration

Xpress
(XPR)

Standard
(STD)

Expert
(EXP)

Professional
(PRO)

Premium
(PRE)

Vertical
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Tapered

Multi-Segment

Tool Types by Configuration

Tool
Types

Configuration

Xpress
(XPR)

Standard
(STD)

Expert
(EXP)

Professional
(PRO)

Premium
(PRE)

Ball Mills

Flat Mills

Corner Radius Mills

Vee Mills

Chamfer Mills

Taper Mills

Thread Mills

Face Mills

Dovetail Cutters

Fillet Mills

Lollypop Cutters

User Defined Cutters
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Drills

Center Drills

Reamers

Taps

Bore Tool

Reverse Bore Tool

Knife Tool

Saw Tool

Plasma Tool
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Tool Related Answers

It is recommended that you do not attempt some of these more Advanced Topics until you are
familiar working with tools and tool libraries in the VisualCAD/CAM MILL module.

6.1 Where can I find Tool related Preferences?

Listed below are the CAM Preferences that are related to Tools and Tool Libraries:

1. Locate the CAM Preferences icon to the right of the Program tab and select it.

2. Select the User Interface item from the left.  Here are a couple of Preferences that will help
you with the tools related dialogs:

Show context ToolTips

Check this box to display Context ToolTips when the mouse moves over a parameter in a
dialog.  A definition of the parameter will pop-up automatically.  Note that Context
ToolTips may not be available for ALL dialogs.  You can also set the ToolTip Delay in
seconds.  This is the amount of time it takes to display the Context ToolTip when the
mouse activate it.

Show Expressions in Tooltip

You can enter expressions in any dialog field that expects a numerical value and the value
will be computed and entered automatically.  Check this box to pop-up the results of any
expressions in a ToolTip balloon.  An example is shown below.
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Show Expressions in ToolTip

3. Select the Cutting Tools item from the left.

CAM Preferences > Cutting Tools
Note: Menu selections on the left may change depending on module and configuration

4. You can select the Default Tool Library to load for new part files.  You can also check the box to
Load the last loaded tool library on startup.  This will ensure that your Tool Library loads every
time the program runs.

5. You can also set the Colors used when the Tool is displayed on the screen.
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6. Now select the Feeds & Speeds section from the left.

7. Here you can decide if you want default Feeds & Speeds loaded from the Tool for new
operations.  If you set this to Tool and define your Speeds & Feeds for each of your tools, you
can be sure those Feeds & Speeds are being used when a new operation is created that uses
that tool.

CAM Preferences > Feeds & Speeds

8. You can also set the % of the computed Cut Feed to use for the various types of transfer
motions.  For example, in the Feeds & Speeds Calculator (displayed when you select Load
from File from either the Create/Select Tools dialog or from the Feeds & Speeds tab of any
operation type) a Cut Feed value is calculated and suggested.  These percentages listed in
this CAM Preferences dialog will determine how much of that Cut Feed value is used for
each of they remaining tool motion types. 

9. You can also check the box to Always track Operations Feeds/Speeds to used Tool.  When
this is checked, changing the feeds/speeds parameters of a tool and saving the edits, will
automatically update the feeds/speeds on each operation that utilizes this tool in addition to
marking the operations as dirty.
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6.2 How can I Print a Tool List?

Follow the steps outlined below to print your Tool List:

1. The Tool List is based on the tools currently listed under the Tools tab of the Machining
Objects Browser.  If you want to print your tool library list, first Load your Tool Library so
that all of your are listed in the Tools tab.  See Create a Tool Library to learn how to Load
your Tool Library.

2. From the Tools tab, select the Tool List icon:

3. From the Cutting Tools Information dialog, pick the Print button.
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6.3 How can I add a Custom Tool?

Available in: Xpress Standard Expert Professional Premium

The MILL module allows creation of special purpose tools like form tools. These can be defined
under user defined tool in the create/select tool dialog.

User Defined Tools can be used in Drill operations to allow multi-
function tools to be defined as user defined tools and used in

drilling operations.  See User Defined Tools for more information.

Steps to create a user defined tool

Steps to create a user defined tool

Steps to create a user defined tool:
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1. Draw half the tool profile from the top view (XY plane of the world coordinate
system) as shown in the picture above.

2. Make sure one end of the curve (tool tip) is at origin (0,0) and the other end at
X0, Y<value>.

3. From the Tools tab under the Machining Objects Browser, click Create/Select
Tool and select User Defined Tool.

click Create/Select Tool and select User Defined Tool

4. Click Load selected tool profile curve.

Click Load selected tool profile curve

5. Specify the Holder Diameter, Holder Length, Properties, Feed & Speeds and Click
Save as New Tool.
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Preview your Tool

Preview Tool allows you to preview the highlighted tool in the workspace as seen below.
The tool is previewed at the WCS origin.

Preview your Tool

6.4 Why are my Feed Rate values too High/Low?

If your Feed Rate values in your posted g-code are too High or too Low, you can adjust the
High/Low parameters in the Post Processor following the steps outlined below:

1. Click on Post (Set Post-Processor Options), then click Edit.
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2. From the Post Processor Generator dialog, select the Feed Rate tab from the left.

3. Then make the necessary changes under the Feed Rate Value section for either the High
Value or Low Value.

4. Then pick Save.
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6.5 What about Tapping Feed Rates?

For tap operations, the feedrate can be computed in different ways. This depends on what is
expected by the controller. 

Spindle Speed x Thread Pitch  

Thread Pitch  

1/Thread Pitch  

Cut Feedrate  

The post needs to be setup with the appropriate variable to output the feedrate.  The Thread
Pitch is defined under the Tool definition and Spindle Speed is set under Feeds/Speed tab of the
Tap operation.

Use the following macro’s in the post to output the feedrate

[CYCL_IPR] – Spindle Speed x Thread Pitch

[CYCL_TPI] – Thread Pitch

[CYCL_1/TPI] – 1/Thread Pitch

[CUT_FEED] – Cut Feedrate

6.6 How can I Optimize Machining Time Estimates?

Optimize Machining Time Estimates!

In any MecSoft CAM product you can get an Information report
about a selected toolpath operation, a Setup or all operations in
the Machining Job. This report contains some very useful
information that includes the Tool #s used, the Cut Feed, the # of
GOTO motions and most importantly, the estimated Machining
Time.

Read the full article...

https://mecsoft.com/blog/optimize-machining-time-estimates/
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More Advanced Topics

7.1 How can I add Tool Comments?

You can add comments associated with a Tool.  These Comments are saved with the Tool in your
Tool Library.  They are also posted to your g-code when the tool is used.  

Here are the steps to add Comments to a Tool:

1. Edit the Tool using the Create/Select Tool dialog.

2. Select the Properties tab on the right.

3. Add text to the Comments window.
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4. Make sure Comments are enabled in your post.

A. Click on Post (Set Post-Processor Options), then click Edit.

B. From the Post Processor Generator dialog, select the General tab from the left.
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C. Check the box to Output Comments.  You can also change the start and end
characters to use.

D. Then pick Save or Save As.

5. Now post your operations and see your comments:

...

...

G1 X0.5301 Y-0.7171 Z0.7480

G3 X0.7801 Y-0.4671 I0.0000 J0.2500 F2.6

G1 X0.7801 Y-0.2171 Z0.7480 F6.9

G0 Z0.9843

G0 X0.7801 Y-0.2171 

(2 1/2 Axis Profil ing)

(My Tool Comments Here!)

S18000

G0 Z0.9843

G0 X0.5301 Y-0.7097 

G1 X0.5301 Y-0.7097 Z0.7480 F6.9

G1 X0.5873 Y-0.7097 Z0.7480 F3.4

G1 X0.5873 Y-0.6345 Z0.7480

G1 X0.4729 Y-0.6345 Z0.7480

...

...

6. If you want to post g-codes instead of comments, just place a $ character prior to the
comment in the Create/Select Tools dialog.  Adding $ as prefix will skip the comment start
& end characters in the posted code.
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...

...

G1 X0.4655 Y-0.7171 Z0.7480

G1 X0.5301 Y-0.7171 Z0.7480

G3 X0.7801 Y-0.4671 I0.0000 J0.2500 F2.6

G1 X0.7801 Y-0.2171 Z0.7480 F6.9

G0 Z0.9843

G0 X0.7801 Y-0.2171 

(2 1/2 Axis Profil ing)

My g-code Here!

S18000

G0 Z0.9843

G0 X0.5301 Y-0.7097 

G1 X0.5301 Y-0.7097 Z0.7480 F6.9

G1 X0.5873 Y-0.7097 Z0.7480 F3.4

G1 X0.5873 Y-0.6345 Z0.7480

...

...

7.2 How can add a Tool Change Point?

Implementing a Tool Change Point can be useful.  For example in 2 and 3 Axis, you may want to
change tools manually between operations (i.e., your CNC machine does not have an automatic
tool changer).  Also in 4 Axis you may want to ensure the tool is moved to a save location prior to a
table rotation.  To output a Tool Change Point to your posted g-code files, please do the following:
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For 2 and 3 Axis Output

1. From the Machine Setup dialog (Program tab > Machine > General Parameters >
Tool Change Pt), enter your required tool change point coordinates.

2. For the sample code (shown at the end of this section) we entered the following
values in the Machine Setup dialog:

X: -4, Y: 0 Z: 0

3. Edit your post processor by selecting Program tab > Post > Edit.
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4. From the Post Process Generator dialog, select the Tool Change section from the
left side of the dialog.

5. In the Tool Change Macro block section, replace the first line of text with the
following two lines of text at the top of the macro.  
These two lines of text should precede the line that includes T[TOOL_NUM] as
shown in the examples below.

[SEQ_PRECHAR][SEQNUM][DELIMITER]G0 Z[TOOL_CHG_PT_Z]
[SEQ_PRECHAR][SEQNUM][DELIMITER]G0 X[TOOL_CHG_PT_X] Y[TOOL_CHG_PT_Y]
[SEQ_PRECHAR][SEQNUM][DELIMITER]T[TOOL_NUM]
...
...
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6. If your controller expects to see an optional stop call BEFORE each tool change,
you can add another line like below:

[SEQ_PRECHAR][SEQNUM][DELIMITER]G0 Z[TOOL_CHG_PT_Z]
[SEQ_PRECHAR][SEQNUM][DELIMITER]G0 X[TOOL_CHG_PT_X] Y[TOOL_CHG_PT_Y]
[SEQ_PRECHAR][SEQNUM][DELIMITER]M01
[SEQ_PRECHAR][SEQNUM][DELIMITER]T[TOOL_NUM]
...
...

7. From the Post Process Generator dialog, pick Save As.

8. Enter a unique name for your post file (*.spm) for testing and pick Save.

9. From the Set Post-Processor Options dialog, select the revised post from the
Current Post Processor list.

10. Note: If you do not see your revised post in the list, select the "..." button to the
right of the "Folder where post-processor file are located" and select the folder
where you saved your revised post file to (see Step 7 above) and pick OK.

11. You should now see your revised post in the list.  Select it and pick OK.

12. Post a sample toolpath using the revised post.

13. Review the g-code test file and locate the first tool change lines of code. 

14. Your sample test should look something like this depending on your post (based
on the tool change point we used in Step 2 above).  Note the tool change
coordinates in blue:

...
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...
N66 ;2 1/2 Axis  Profi l ing
N68 G0 Z0.
N70 G0 X-4. Y0.
N72 T1 M06
...
...

15. That's it!

For 4 Axis Output

1. From the Program tab select 4 Axis.

2. From the 4 Axis menu select 4 Axis Options.

3. From the 4 Axis Operation Options dialog check the box to Always retract tool to
Tool Change Point before each Table Rotate Operation.

4. Now from the Program tab select Machine and then Manual Definition.

5. For the Machine Type select 4 Axis.

6. Under General Parameters, enter the X, Y and Z coordinate values for the Tool
Change Point.
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7. Then check the box to Output all coordinates in local Setup Coordinate System
and then pick OK to close the dialog.

8. Post the 4 Axis toolpath operation and verify that the Tool Change Point is being
posted before the table rotation angle similar to this:

...

...
(Setup 2)
N6263 Z10.
N6264 X0.Y0.
(Horizonta l  Roughing)
N6265 A180.F300.
...
...

7.3 How can I add more Materials?

This topic is intended for advanced users who are familiar with XML text editing and have
administrative access to their Windows Operating System.  VisualCAD/CAM has a built-in Feeds &
Speeds Calculator that can suggest Spindle Speeds and Cut Feed Rates based on your stock
material and active tool parameters!  

However, what if you are cutting stock material that is currently not in our Materials Library?  Or
what if you don’t like what is currently assigned for the material of your choice in the Materials
Library?  

This topic will show you how to customize VisualCAD/CAM to add and manage multiple material
files as well to add your own stock materials.  If you are new to VisualCAD/CAM, you can review
the topic The Feeds & Speeds Calculator.

How Materials are used
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First let’s review how material definitions are used in VisualCAD/CAM.  From the Stock
pane of the Program tab in the Machining Browser you will find the Material icon. 
Selecting it will display the Select Stock Material dialog.  Here you can select a stock
material from the Material File.  If there is an associated Material Texture file, then this
texture is assigned to the stock model and rendered in the graphics window.  This
texture rendering on the stock can be toggled on or off using the Material Texture
Visibility icon, located at the base of the Machining Browser.

MILL Module shown, Similar for MILL-TURN,
TURN and Profile-NEST

The Material icons in the Machining Browser /
MILL Module shown, Similar for MILL-TURN,

TURN and Profile-NEST The Select Stock Material dialog

Also, from the Feeds & Speeds tab on the Create/Select Tool dialog you can select Load
from File to display the Feeds & Speeds Calculator dialog.  The Material selection in this
dialog will default to the stock Material you have previously selected from the Select
Stock Material dialog (shown above).

Location of Material Files

The Material selections available to you from these dialogs are retrieved from a Feeds &
Speeds XML file installed with the program.  There are separate files for INCH and
METRIC units.  The files are located in the \Materials folder of the ProgramData install
path of the program.  

Here is an example: C:\ProgramData\MecSoft Corporation\Program Name &
Version\Materials.  

By default, the Windows Operation System does not display the
ProgramData folder to you.  If you do not see it, log in as

Administrator and from the Windows Control Panel, navigate to the
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File Explorer Options dialog, select the View tab and then select the
option to Show hidden files, folders, and drives and pick OK.

Maintaining Multiple Material Files

You can create your own Material Files and store them in the default folder.  The CAM
system on startup will load all material files in the folder specified in the dialog above as
long as the units of the material files match the part units that you are working with.  If
the system finds multiple material files with matching units, it will populate the drop-
down control in the Materials dialog allowing you to select a specific material file to suit
your needs.

You need to make sure that you have the units specified correctly
in your customized materials XML files or your material files will

not appear in the dialog list.  See item #5 in the Editing the Feeds &
Speeds XML File section below for the correct Units format.

Having multiple material files can help manage different materials and associated feeds
& speeds data without having to cram all of the data into one file.  In addition, multiple
material files may be useful if you have multiple machines in the shop with different
power capabilities and you want to use different feeds and speeds settings per machine.
 Under this scenario you could have one material file per machine saved in the default
folder and load the correct material file depending on which machine you are
programming toolpaths for.

Editing the Feeds & Speeds XML File

Material files can be edited to customize the data stored in these files to suit your shop
needs.

CAUTION!! - Before editing material files - Make sure you create a
copy and keep them in a safe place, outside of the install path of

the program.  Also, make sure you maintain the XML format of these
files or the Feeds & Speeds Calculator may not work properly!  The
file names are:

FeedsSpeedsDataINCH.xml
FeedsSpeedsDataINCH.xml

Here are the steps required to add new material definitions.  Be sure to read these steps
carefully:

1. Make a backup copy of the Feeds & Speeds XML files!
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2. Edit the XML file to add the material definitions needed, paying close attention
to the format of the XML file.  This file can be edited with any ASCII text editor
such as Notepad or any XML editor.

3. Each Material defined in the XML file has several records (or lines of text)
associated with it.  Each line of text defines information about that Material for
each instance it is referred to by the Feeds & Speeds Calculator.  Here is a sample
section for Aluminum.

<Vers ion>1.0</Vers ion>

<Units>Imperia l</Units>

<FeedsSpeeds>

 <Materia l>

    <Name>ALUMINUM - 2026</Name>

    <TextureFi le>ALUMINUM.bmp</TextureFi le>

    <FeedsSpeedsRecord>MILLING, CARBIDE, 1600.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, HSS, 400.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, CERAMIC, 400.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CARBIDE, 960.00, 0.0048</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, HSS, 240.00, 0.0048</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CERAMIC, 240.00, 0.0048</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CARBIDE, 1800.00, 0.0200</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERAMIC, 1800.00, 0.0200</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERMET, 1800.00, 0.0200</FeedsSpeedsRecord>

 </Materia l>

...

...

Here is what the file looks like in tabulated form:
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4. You will need to know the Surface Speed and Feed/Tooth specifications for each
instance of the Material you are adding to the XML file.  Here is the information
format:

<FeedsSpeedsRecord>MILLING, HSS, 400.00, 0.0040</FeedsSpeedsRecord>

5. You need to make sure that you have the Units format specified correctly in your
custom material XML files.  It is defined on the 2nd line of the Materials XML file.
 For Inch units use <Units>Imperial</Units> and for Metric units use
<Units>Metric</Units> as shown here for Inch:

<Vers ion>1.0</Vers ion>
<Units>Imperia l</Units>
<FeedsSpeeds>
<Materia l>
...
...

6. There is also a bitmap image file (*.bmp) associated with each Material type
defined in the XML file.  This image defines the texture that is applied to the
Stock material when the Toggle Material Texture Visibility icon is enabled.  The
image is also displayed in the Select Stock Material dialog.
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Dialog Box: Select Stock Material

Here is the list of the material texture map files currently installed.  Make sure
your bitmap image file name matches the name entered into the Materials XML
file or the No Texture Map icon will display instead.
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Let’s Review

Adding specific materials you use regularly in your shop to the Feeds & Speeds Calculator
in VisualCAD/CAM can save toolpath programming time and help ensure cut surface
quality and machining time accuracy.  Just be sure to review this post carefully.  A
summary is also listed below.  If you need help, you can always contact us at MecSoft
Support via the phone, web or email.

1. You can select a Material to be applied to your Stock definition.

2. The selection of materials are retrieved from an external data file (example:
FeedsSpeedsDataINCH.xml) located in the install path of VisualCAD/CAM on your
computer.

3. The XML data file can be edited with any ASCII text or XML file editor.

4. The XML data file also contains information about the CAM Module, Tool
Material, Surface Speed and Feed/Tooth for each instance of the material.

5. The stock material selected is used by the Feeds & Speeds Calculator to suggest
Surface Speeds and Cut Feed Rates.

6. The Feeds & Speeds Calculator is displayed when you select Load from File from
the Feeds & Speeds tabs of the Create/Select Tool dialog or from each toolpath
operation dialog.
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7. You can manually add more materials to the XML data file.  You will need to know
the recommended Surface Speed and Feed/Tooth specifications for the material
you are adding based on each Tool Material type.

8. It is very IMPORTANT that you make a backup copy of these XML files if you plan
to edit them.  Also, the text format of the XML files is VERY IMPORTANT.  If the
format is incorrect, the Feeds & Speeds Calculator may not work properly!  Make
sure that the Units format on line 2 matches the Units you plan to use in your part
files.

9. Each material also has a bitmap image texture file (*.bmp) that is located in the
same folder.  The material texture image is shown in the Select Stock Material
dialog and is also applied as a texture map to your stock when the Toggle
Material Texture Visibility icon is enabled.

7.4 How can I enable Cutter Compensation?

All toolpaths except engraving are automatically compensated for the tool geometry.  Cutter
compensation is used typically to compensate for the difference in the dimensions of the actual
cutter used in machining and the cutter used for programming in VisualCAD/CAM.  For example, if
the cutter used in programming is 0.25 inches and due to tool wear the actual cutter is only 0.24
inches in size, you can compensate for this at the controller rather than having to re-program the
operation in VisualCAD/CAM.  

Cutter compensation is used extensively in production (high volume) machining where the
machine operator can compensate for tool wear before having to stop and replace the tool or
insert.

In order to do this the user needs to do the following:

1. Turn cutter compensation on in the operation to Auto/ON or CONTROL/ON.

2. Specify the cutter compensation value and the compensation register in the controller
(the controller needs to be capable of doing this).

3. Please make sure the post processor is configured to output cutter compensation. This is 
defined under the Cutter Compensation section in the post processor generator. Most
controllers expect an X & Y motion on the same line as cutter compensation.

Cutter Compensation Left

[SEQ_PRECHAR][SEQNUM] G41 [G_CODE] X[NEXT_NONMDL_X] Y[NEXT_NONMDL_Y] D[TOOL_CUTCOM_REG]

Cutter Compensation Right

[SEQ_PRECHAR][SEQNUM] G42 [G_CODE] X[NEXT_NONMDL_X] Y[NEXT_NONMDL_Y] D[TOOL_CUTCOM_REG]

Cutter Compensation Off

[SEQ_PRECHAR][SEQNUM] G40
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A few things to watch out for:

1. Cutter compensation makes sense only in 2-1/2 axis operations.  If you are using roughing
(pocketing & facing) the compensation will be turned on only in the final passes.

2. Make sure you are using Climb or Conventional cut traversal in any of the methods that
you want to turn compensation on.

3. Make sure you have a linear motion for the controller to turn on the compensation for.  If
your first motion is an arc the controller will not be able to turn on the compensation. 
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Thus, in 2-1/2 axis profiling, make sure there is a linear entry motion for the controller to
be able to turn compensation on & linear exit to turn off compensation.

If you are looking to compensate for the full tool diameter, set Stock = -0.125 under the cut
parameters tab. (0.125 being the radius of the tool). This would generate the toolpath ON the
curve. This would invalidate the simulation as the tool tip stays on the drive geometry.

Note:  The Cutcom Register is set under the Create/Select Tool definition dialog.
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Reference

8.1 MILL Holder Worksheet
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8.2 Mill Tool Worksheets

The following Mill Tool Worksheets are available:

1. Ball Mill Worksheet

2. Flat Mill Worksheet

3. Corner Radius Mill Worksheet

4. Vee Mill Worksheet

5. Chamfer Mill Worksheet

6. Taper Mill Worksheet

7. Thread Mill Worksheet

8. Dovetail Mill Worksheet

9. Fillet Mill Worksheet

10. Lollipop Mill Worksheet

11. User Defined Mill Worksheet

12. Drag Knife Worksheet

13. Saw Tool Worksheet

14. Laser Tool Worksheet
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8.2.1 Ball Mill Worksheet
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8.2.2 Flat Mill Worksheet
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8.2.3 Corner Radius Mill Worksheet
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8.2.4 Vee Mill Worksheet
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8.2.5 Chamfer Mill Worksheet
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8.2.6 Taper Mill Worksheet
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8.2.7 Thread Mill Worksheet
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8.2.8 Face Mill Worksheet
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8.2.9 Dovetail Mill Worksheet
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8.2.10 Fillet Mill Worksheet
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8.2.11 Lollipop Mill Worksheet
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8.2.12 User Defined Mill Worksheet
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8.2.13 Drag Knife Worksheet
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8.2.14 Saw Tool Worksheet
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8.2.15 Laser Tool Worksheet
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8.3 Drill Tool Worksheets

The following Drill Tool Worksheets are available:

1. Drill Worksheet

2. Center Drill Mill Worksheet

3. Reamer Worksheet

4. Tap Worksheet

5. Bore Worksheet

6. Reverse Bore Worksheet
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8.3.1 Drill Worksheet
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8.3.2 Center Drill Worksheet
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8.3.3 Reamer Worksheet
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8.3.4 Tap Worksheet
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8.3.5 Bore Worksheet
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8.3.6 Reverse Bore Worksheet



Reference 91

© 2026 MecSoft Corporation

8.4 Turn Tool Worksheets

The following TURN Tool Worksheets are available:

1. Diamond Insert Mill Worksheet

2. Triangular Insert Worksheet

3. Round Insert Worksheet

4. Trigon Insert Worksheet

5. Parallelogram Insert Worksheet

6. Groove Insert Worksheet

7. Thread Insert Worksheet

8. Part Off Insert Worksheet
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8.4.1 Diamond Insert Worksheet
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8.4.2 Triangular Insert Worksheet
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8.4.3 Round Insert Worksheet
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8.4.4 Trigon Insert Worksheet



Cutting Tools Workbook96

© 2026 MecSoft Corporation

8.4.5 Parallelogram Insert Worksheet
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8.4.6 Groove Insert Worksheet
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8.4.7 Thread Insert Worksheet
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8.4.8 Part Off Insert Worksheet
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8.5 Feeds & Speeds Data

8.5.1 Feeds & Speeds Data (INCH)

For INCH units, the Surface Speed and Feed/Tooth provided in the Feeds & Speeds Calculator are
derived from the file FeedsSpeedsDataINCH.xml.  You can customize this file to add your own
materials. 

This file is located at: C:\ProgramData\MecSoft Corporation\VisualCAM 20xx\Materials

CAUTION!! - Before editing this file - Make sure you create a copy of this file and
keep it in a safe place, outside of the install path of VisualCAD/CAM.  Also, make

sure you maintain the XML format of this file or the Feeds & Speeds Calculator may
not work properly. 

Here is the tabulated format of the file.  It will help you understand the XML files format for
recording data.

Below is an excerpt from the FeedsSpeedsDataINCH.xml XML file:

<Version>1.0</Version>

<Units>Imperial</Units>

<FeedsSpeeds>

 <Material>

    <Name>ALUMINUM - 2026</Name>

    <TextureFile>ALUMINUM.bmp</TextureFile>

    <FeedsSpeedsRecord>MILLING, CARBIDE, 1600.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, HSS, 400.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, CERAMIC, 400.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CARBIDE, 960.00, 0.0048</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, HSS, 240.00, 0.0048</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CERAMIC, 240.00, 0.0048</FeedsSpeedsRecord>
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    <FeedsSpeedsRecord>TURNING, CARBIDE, 1800.00, 0.0200</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERAMIC, 1800.00, 0.0200</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERMET, 1800.00, 0.0200</FeedsSpeedsRecord>

 </Material>

 <Material>

    <Name>ALUMINUM - 5050</Name>

    <TextureFile>ALUMINUM.bmp</TextureFile>

    <FeedsSpeedsRecord>MILLING, CARBIDE, 1600.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, HSS, 400.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, CERAMIC, 400.00, 0.0040</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CARBIDE, 960.00, 0.0048</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, HSS, 240.00, 0.0048</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CERAMIC, 240.00, 0.0048</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CARBIDE, 1800.00, 0.0200</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERAMIC, 1800.00, 0.0200</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERMET, 1800.00, 0.0200</FeedsSpeedsRecord>

 </Material>

...

...

8.5.2 Feeds & Speeds Data (METRIC)

For METRIC units, the Surface Speed and Feed/Tooth provided in the Feeds & Speeds Calculator
are derived from the file FeedsSpeedsDataMM.xml.  You can customize this file to add your own
materials. 

This file is located at: C:\ProgramData\MecSoft Corporation\VisualCAM 20xx\Materials

CAUTION!! - Before editing this file - Make sure you create a copy of this file and
keep it in a safe place, outside of the install path of VisualCAD/CAM.  Also, make

sure you maintain the XML format of this file or the Feeds & Speeds Calculator may
not work properly. 

Here is the tabulated format of the file.  It will help you understand the XML files format for
recording data.
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Below is an excerpt from the FeedsSpeedsDataMM.xml XML file:

<Version>1.0</Version>

<Units>Metric</Units>

<FeedsSpeeds>

 <Material>

    <Name>ALUMINUM - 2026</Name>

    <TextureFile>ALUMINUM.bmp</TextureFile>

    <FeedsSpeedsRecord>MILLING, CARBIDE, 487.68, 0.1016</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, HSS, 121.92, 0.1016</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, CERAMIC, 121.92, 0.1016</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CARBIDE, 292.61, 0.1219</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, HSS, 73.15, 0.1219</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CERAMIC, 73.15, 0.1219</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CARBIDE, 548.64, 0.5080</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERAMIC, 548.64, 0.5080</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERMET, 548.64, 0.5080</FeedsSpeedsRecord>

 </Material>

 <Material>

    <Name>ALUMINUM - 5050</Name>

    <TextureFile>ALUMINUM.bmp</TextureFile>

    <FeedsSpeedsRecord>MILLING, CARBIDE, 487.68, 0.1016</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, HSS, 121.92, 0.1016</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>MILLING, CERAMIC, 121.92, 0.1016</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CARBIDE, 292.61, 0.1219</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, HSS, 73.15, 0.1219</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>DRILLING, CERAMIC, 73.15, 0.1219</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CARBIDE, 548.64, 0.5080</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERAMIC, 548.64, 0.5080</FeedsSpeedsRecord>

    <FeedsSpeedsRecord>TURNING, CERMET, 548.64, 0.5080</FeedsSpeedsRecord>

 </Material>

 <Material>
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...

...

8.6 Default Tool Libraries

8.6.1 Default English Tools Library

The following table lists each tool included in the DefaultEnglishTools.csv library file.

This file is located at: C:\ProgramData\MecSoft Corporation\VisualCAM 20xx\Data
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8.6.2 Default Metric Tools Library

The following table lists each tool included in the DefaultMetricTools.csv library file.

This file is located at: C:\ProgramData\MecSoft Corporation\VisualCAM 20xx\Data
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Where to go for more help

Download this PDF Guide for a list of the available VisualCAD/CAM Resources.

2026 VisualCAD/CAM Resource Guide

The 2026 VisualCAD/CAM Resource Guide!

18 Pages

Lists PDF downloads and Online resources including Quick Start
Guides, Reference Guides, Exercise Guides, Tutorials and
More.

Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoftcorp.github.io/VisualCADCAM-2026/Resources/VisualCADCAM2026-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2026.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QISEAjFqPkrNRyUTOYw9ZRZ
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