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Quick Start

G-CODE Editor Module 2025
Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

Quick Start Guides for each VisualCAM module are available in both PDF and Video format.  Refer
to the following information to access these resources:

How to Access the Quick Start Guide Documents

To help you quickly get started in working with each module, select one of the Help
buttons located on the VisualCAM Learning Resources dialog.  

You will find:

· Quick Start Guides  

· What's New documents  

· Online Help links

The Quick Start Guides will help you step through an example tutorial which will
illustrate how to use the module.  To access the Learning Resources dialog:

1. From the VisualCAD Home Ribbon Bar, drop down the Main menu and select Learn ...  

https://mecsoftcorp.github.io/VisualCADCAM-2025/Resources/VisualCADCAM2025-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2025.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QKmM1LY2ydDA_vro-WPOo4E
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To access the Learning Resources dilog in VisualCAM

2. Select a document from the Learning Resources dialog to get started using the
module of your choice.  

 You can also select the Open Quick Start Files Folder button located at the bottom
of the dialog to open the Quick Start folder where the source files (start and
completed versions) are located.
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Learning Resources Dialog
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Resource Guide

Download this PDF Guide for a list of the available VisualCAM Resources.

2025 VisualCAM Resource Guide

The 2025 VisualCAM Resource Guide!

18 Pages

Lists PDF downloads and Online resources including Quick Start
Guides, Reference Guides, Exercise Guides, Tutorials and
More.

Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

https://www.mecsoft.com/ResourceGuides/2024/VisualCADCAM/VisualCADCAM2024-Resource-Guide.pdf
https://mecsoftcorp.github.io/VisualCADCAM-2025/Resources/VisualCADCAM2025-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2025.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QKmM1LY2ydDA_vro-WPOo4E
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About this Guide

VisualCAD/CAM 2023

Saturday, February 15, 2025

3.1 Useful Tips

Here are some useful tips that will help you use this guide effectively.

1. Copy the tutorial files to a location other than the installation folder to make sure you
have read/write privileges to the files. 

2. Once you start working with the tutorial file, save your work periodically!

3. Don’t stress out too much if you are having trouble with the tutorial.  Call us or send us
email and we can help you out.

4. Most of all have fun!
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3.2 About this Module

G-CODE Editor is a companion module that runs inside of .  G-CODE Editor assists users with
editing g-code files created with VisualCAM or from other systems that produce ISO standard g-
code files.  You can also define tool libraries, tool cribs to perform tool motion and cut material
simulations.

3.3 Using this Guide

If you have installed VisualCADCAM successfully on your computer and are now looking at the
blank screen of VisualCAD and wondering what to do next, this is the guide for you.  This guide
will explain how to get started in using the VisualCAM module to edit a simple g-code file through
an example.

This guide has associated VisualCAD files that you can find located in the QuickStart folder under
the installation folder of VisualCAM.  These files are shown and listed below.

List of Included Source Files

· Source G-Code File: 
G-CODE-EDITQuickStartGuide.nc  

· Source Part File: 
G-CODE-EDITQuickStartGuide.vcp  

· Source Tool Library File: 
G-CODE-EDITQuickStartGuide.csv   

· Source Part File (Completed): 
G-CODE-EDITQuickStartGuide_Completed.vcp  

· Note: Source part files are not required to view or edit G-Code
files in the G-Code Editor module.

Included Source Files
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Source G-Code File: 
G-CODE-EDITQuickStartGuide.nc

Source Part File:
G-CODE-EDITQuickStartGuide.vcp

Source Tool Library File:
G-CODE-EDITQuickStartGuide.csv
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Source Part File (Completed):
G-CODE-EDITQuickStartGuide_Completed.vcp

3.4 Watch the Video!

Want to see a video demonstration of this quick start guide?  Just click on the play list below and
watch the G-Code Editor Quick Start Guide video.

Here is a link to the complete 2023 Video Play List

https://www.youtube.com/playlist?list=PLx9G05pFm0QIs6Web4a_oGF7LLOBg-RQv
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Getting Ready

4.1 Running VisualCAM

Locate the VisualCAD/CAM 2023 shortcut on your desktop and double click to launch the
application.   

Alternatively you can also click on the Windows Start button and select All Programs.  Go to the
program group containing VisualCAD/CAM 2023. (The name of this program group will usually be
called VisualCAD/CAM 2023, unless you specified otherwise during setup.)

Once you locate the program group, select it and then select VisualCAD/CAM 2023 to launch the
application.

If the installation was successful, upon launching of VisualCAD/CAM 2023 you should observe a
menu entry called VisualCAM 2023 on the Home Ribbon Bar menu of VisualCAD.

If you do not see this menu entry then please check the On Line Help document of the product
(found in the installation folder) for help with trouble shooting the installation.

4.2 About the VisualCAM Display

Before we begin, let's talk a bit about the VisualCAD display.  When you run VisualCAD for the
very first time, your screen may look this.  

These windows on the left belong to plug-in modules that are currently loaded.  For now, let's
close all of them.  
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With all plug-in modules closed your screen will look like this:

4.3 Load the G-Code Edit Module

Now, let's begin by launching the VisualCAM G-CODE EDITOR module.

1. From the Plugins pane of VisualCAD's Home Ribbon Bar, drop down the VisualCAM 2023
main menu and select G-CODE EDITOR.
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2. Docked on the left you will see the G-CODE Editor Browser.  You can move or re-size the
browser as desired.

4.4 Load the G-Code Files

Your G-Code files can be created from VisualCAD/CAM or you can load G-Code files created from
any other CAM system that supports ISO standard g-code.  For this guide we will be loading a part
file and a G-Code file created from VisualCAD/CAM.

You DO NOT need to have a part geometry file loaded in order
to edit G-Code files!  It is loaded in this guide because this is

the part file the G-Code was posted from.  You can load any
standard ISO G-Code file into the G-CODE Editor and perform edits,
tool simulations without a part file loaded!

Load the Part File

1. From the VisualCAD Main Menu, select File / Open.

2. From the Open dialog box, select the G-CODE-EDITQuickStartGuide.vcp  file from
the C:\ProgramData\MecSoft Corporation\VisualCAM 2023\QuickStart\ folder. 
As mentioned before, it is advisable to make a copy of this part at a suitable
alternative folder so that you have write privileges to modify the part.

By default, the ProgramData folder is "hidden" from view.  Here are
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the steps to Show hidden files and folders:

1. For Windows 8 users: Go to Control Panel > Appearance and
Personalization > Folder Options.  
For Windows10 users: Go to Control Panel > Appearance and
Personalization > File Explorer Options.  

2. Select View tab and under advanced settings select Show Hidden files
and folders, clear the check boxes for:

· Hide extensions for known file types  

· Hide protected operating system files (Recommended)  

3. Click Apply and OK.

When the Load Settings from File dialog appears, pick No for this file.  In the
future you may have older files whose CAM System Preferences you wish to use
so leave the box Do not display dialog again unchecked for now.

The part appears as shown below
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Source Part File:
G-CODE-EDITQuickStartGuide.vcp

3. From the View toolbar, select the Isometric View to work in.

Load the G-Code File

1. From the Project tab of the G-CODE Editor Browser, select Load. 

2. From the Open dialog box, select the G-CODE-EDITQuickStartGuide.nc file from
the C:\ProgramData\MecSoft Corporation\VisualCAM 2023\QuickStart\ folder. 
As mentioned before, it is advisable to make a copy of this part at a suitable
alternative folder so that you have write privileges to modify the part.

The G-Code file is loaded into the Project tree of the G-Code Editor Browser. 
Notice that the G-Code file name appears in the Project tree with each tool
referenced by the file listed below it.
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Why are the tools flagged?  The flag on the tool icons   indicate
that the tool numbers referenced within the loaded G-Code file could not
be found in the Tool Crib.  These flags do not need to be resolved in order to
perform edits to your G-Code file!

Refer to the Load Your Tool Library section for more information.

3. The backplot of the G-Code file is also displayed in the graphics screen coincident
with the part geometry. 

As we mentioned previously, you DO NOT need to have a part geometry
file loaded in order to edit G-Code files!  It is loaded in this guide because

this is the part file the G-Code was posted from.  You can load any standard ISO
G-Code file into the G-CODE Editor and perform edits, tool motions and
simulations without a part file loaded!

4. If the backplot of your G-Code file displays arc motions incorrectly as shown
below, select the Preferences icon.
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5. From the Preferences dialog select Toolpath from the left.  Here you can set the
Circle center (I,J,K) format to match the G-Code file that you load.  For example if
the CAM system that generated the G-Code has arc centers formatted using
Vector from Start to Center, the backplot of the G-Code file may show arcs being
displayed incorrectly.  If this occurs you can set the same option here and pick OK
or Apply and see that the arcs display properly.
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8. Your part and G-Code backplot should now look like this:

4.5 G-Code Editing Strategy

The G-Code editing strategy you employ at any given time may be dictated by your preferences or
how your CNC machine controller expects the G-Code files to be formatted.  The majority of the
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format adjustments can be addressed within the post definition file using the PPG (Post-
Processor Generator) included with VisualCAM.

However, there will be times when you may want or need to make manual edits to your G-Code
files without having to revert back to the CAM system.  Our editing strategy for this guide is
outlines below.

G-Code Edit Strategy

We will follow the steps listed below for editing our G-Code file:

1. Load the G-Code file into the G-Code Editor Browser.  

2. Perform some quick formatting edits and then output and save the G-Code file.

3. Load a Tool Library and define a Tool Crib in preparation for G-Code simulations.

4. Perform Tool Motion Simulations.

5. Define a Stock model and perform Cut Material Simulations.

6. Perform addition G-Code edits, estimate machine time and then save our
changes to the G-Code file.
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Edit the G-Code File

5.1 How Tools are Used

G-CODE Editor allows you to load a Tool Library and setup a Tool Crib.  This allows you to match the
tools that are referenced by the G-Code file.  The Tool Library file (*.csv) can be generated and
saved from within the MILL module while the part file with the CAM toolpaths is loaded.  The Tool
Crib is defined from within G-CODE Editor.

You DO NOT need to have a Tool Library or a Tool Crib loaded in
order to edit G-Code files!  You can load and edit any standard ISO

G-Code file with the G-CODE Editor.

5.2 Add Character Spaces

You can make edits to your G-Code file as soon as it is loaded into the editor.  As mention
previously, you do not need a Tool Library or Tool Crib defined in order to edit the G-Code file.  In
this step we will add character spaces to the G-Code file.

1. Right-click on the selected G-Code file located in the Project tree and select Edit.

2. Pick Yes from the message that is displayed.  Because no tools are defined yet, a default
tool is used and displayed in the graphics window.

3. You will see that the Project tab is replaced with Edit & Simulate tabs and the G-Code file
is loaded into the editor.  The Edit tab contains all of the edit commands available in the
current update of VisualCAM.



Edit the G-Code File 23

© MecSoft Corporation

4. From the Edit tab, select .

5. Character spaces are inserted into the G-Code file as shown.

6. When you want to return to the Project tab just select the icon shown below.
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7. You see now that the G-Code file is also flagged.  This indicates that an edit was made and
that the file was not saved.  We will make some additional edits so let's continue. 

5.3 Load Your Tool Library

In this step we will load a Tool Library containing the tools that are referenced from the G-Code
file.  The Tool Library file for this guide was generated from the MILL module and saved in the
QuickStart folder of your VisualCAD/CAM install path.

1. From the Project tab select  and then Load from the menu.
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2. From the Open dialog box, select the G-CODE-EDITQuickStartGuide.csv file from the  C:
\ProgramData\MecSoft Corporation\VisualCAM 2023\QuickStart\ folder and then pick OK
to load the file.  

As mentioned previously, it is advisable to make a copy of this file at a suitable alternative
folder so that you have write privileges to modify it if needed.

The MILL module supports two types of Tool Library files (*.vkb
and *.csv)  G-CODE Editor requires the *.csv file format. 

3. The Tool Library is then displayed allowing you to preview in the Tool information.

4. Now pick OK to close the Tool Library dialog.  You will notice that the tools listed in the
Project tree under the G-Code file and still flagged.   That's because we need to setup the
Tool Crib.
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5.4 Define Your Tool Crib

In this step we will define our Tool Crib.  The Tool Crib allows you to select the Tools from your
Tool Library that are listed in the G-Code file.  The reason for the Tool Crib is to two fold, (1) it
mimics how tools are defined and selected for your CNC machine and (2) because a Tool Library
can have multiple tools with the same Tool# , the Tool Crib allows you to define which tool to use
for the current G-Code file(s).

1. From the Project tab select  to display the Tool Crib dialog.

1. From the Tool Crib dialog select .
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The Tool Library dialog will display.

2. Our G-Code file references ALL of the tools in this library so you can drag a selection
window encompassing all of the tool records until they highlight.

3. Now pick OK from the Tool Library dialog and the Tool Crib dialog will reappear with the
tools listed.  This will be the Tool Crib for this guide.   Now pick OK from the Tool Crib
dialog to close it.
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4. Now you will notice in the Project tab that all of the flags on each tool listed under the G-
Code file are gone!  This means that each tool was located in the Tool Crib.
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5.5 Add Line Numbers

1. Right-click on the selected G-Code file located in the Project tree and select Edit.

2. You will see that the Project tab is replaced with Edit & Simulate tabs and the G-Code file
is loaded into the editor as shown below.

3. You can navigate quickly thru the G-Code by accessing the right-click menu shown below. 
The upper portion of the menu provides go to navigation commands.  For example
selecting Tool will move the cursor to the next line containing a Tool# call.  You can also
move quickly to the Top and Bottom of the file and to the next Feedrate and Spindle
codes.  
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4. You will notice that line numbers are displayed in the left side column of the G-Code
Editor.  These are for reference only and are not in the G-Code file.  To add Line Numbers

to your G- Code file, select  from the Edit tab.

5. Line numbers are appear in the G-Code file as shown.
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5.6 Saving Changes

Use the following techniques to save your G-Code files.

1. To save and write over your original G-Code file, select  from the Edit tab.

2. Pick OK to save over the original G-Code file.  If you do not want to overwrite your original
file, select Save As from the Save menu and enter a different file name and pick OK.

3. Now return back to the Project tab.
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4. You will notice that the G-Code file is flagged because it has not been saved.

5. You can also save your G-Code file from the Project tab by selecting  from the
Project tab menu. 
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G-Code Simulations

6.1 Tool Motion Simulation

Now that we have a Tool Library loaded and a Tool Crib defined all simulations that we do will
display the correct tool.  Our first simulation will be a Tool Motion simulation.  The tool will be
displayed in the graphics screen as it follows each line in the G-Code file.

1. Select the G-Code file from the Project tab, right-click and select Simulate. 

2. The G-Code file is loaded into the Simulate tab and the cursor begins at the top of the file
and proceeds to the bottom of the file while a graphical display of the tool is shown in the
graphics screen at each line in the G-Code file.  

3. Here are some operations tips when running a Tool Motion Simulation:

A. You can toggle the display of the stock using the icon provided at the bottom of the
Simulate tab.
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B. During the tool motion simulation, you can use the icons on the Simulate tab to
Pause, Stop and Start the simulation.

C. Once the simulation is Paused, Stopped or reaches the end of the G-Code file, you can
then manually move the cursor to any line in the G-Code file to see the exact tool
position at that line.  This is very helpful for locating the exact line of code that is
causing a problem.

D. If you are getting an error message from your CNC machine controller and it reports a
line # where the error occurred, you can analyze the G-Code and tool position at that
line number.  This is very helpful for understanding the error and how best to take
corrective action. 

6.2 The Simulate Tab

The Simulate tab provides commands for running simulations and access to simulation
preferences.  Here is a brief description of the Simulate tab.  These commands work in the same
manner as those in the MILL module.

1. Select the G-Code file from the Project tab, right-click and select Simulate. 

2. While the Tool Motion Simulation is running you can select the Pause button to stop the
simulation at the current line in the G-Code file.  Selecting Play will continue the
simulation.  Step will run the simulation incrementally.  You can also select Preferences to
access the Simulation Preferences.  These are the same Preferences located in the
Preferences dialog. 

Optionally you can Pause the simulation and then use the Up and Down Arrow Keys on
your keyboard to move the simulation Forward or Reverse line by line.
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6.3 Define Your Stock

In order to run a Cut Material Simulation you must have a Stock defined.

1. Pause or Stop any simulation that is currently running by selecting the appropriate
command from the Simulate tab.
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2. Return to the Project tab. 

3. From the Project tab select  and then select Box Stock ... from the menu. 
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4. This will display the Box Stock dialog similar to the MILL module.
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5. Select the Copy Model Bounding Box button.  The stock model will be displayed in the
graphics window that matches the size of the part model.
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6. Now enter 1.125 for the Height (H) dimension in the Box Stock dialog.  This will add 0.125
to the height of the Stock model.

7. Now pick OK to close the Box Stock dialog.  

6.4 Cut Material Simulation

With our Stock defined we can now perform a Cut Material Simulation.  With Stock defined,
selecting Simulate will now display the in-process cut stock at each line in the G-Code file!

1. First let's hide the display of the Part model to see the Cut Material Simulation more
clearly.
Select the Part model from the graphics screen and then press the (Ctrl + H) keyboard
short cut to hide the Part model.

Now only the Stock model and the G-Code backplot are displayed in the graphics window.



G-Code Simulations 41

© MecSoft Corporation

2. Now select the G-Code file from the Project tab, right-click and select Simulate. 

3. The G-Code file is loaded into the Simulate tab and the cursor begins at the top of the file
and proceeds to the bottom of the file while a graphical display of the tool is shown in the
graphics screen at each line in the G-Code file. 



VisualCAD/CAM 2025 G-CODE Editor Quick Start42

© MecSoft Corporation

More G-Code Edits

7.1 Estimate Machining Time

You can get additional Information about the G-Code files currently loaded into the G-CODE
Editor.

1. Select the Edit tab to return to the Edit menu.

2. Now select  from the Edit menu to display the Information dialog. 
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3. You can also perform this task from the Project tab.  Return to the Project tab, select the G-

Code file and then select  from the Project menu to display the Information
dialog.

You can also right-click on the G-Code file and select Info to display the Information
dialog.
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7.2 More Edits

Let's perform one additional edit before we complete this guide.

1.  Right-click on the selected G-Code file located in the Project tree and select Edit.

1. If you recall back in the section Add Line Numbers, you were warned that no appropriate
tools were found.  That's because we did not have a Tool Library and Tool Crib loaded yet.

Now when you go to the Edit tab, the first tool # is loaded and displayed in the graphics
screen at the beginning of the first tool motion.

2. You will see that the Project tab is replaced with Edit & Simulate tabs and the G-Code file
is loaded into the editor as shown below.
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3. One edit than many users find useful is to retract the tool to a higher Z height once cutting
is completed.  
From the Edit tab right-click on any line in the G-Code file and select Bottom to go directly
to the end of the file.

4. Now place the cursor on the last G0 line and notice where the tool is position in the
graphics screen.
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5. Now change Z1.5 to Z5.0 and notice that the tool rises up to the Z5.0 location.  
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6. Refer to the section Saving Changes to update your external G-Code file will all of the
latest changes.
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Where to go for more help

Download this PDF Guide for a list of the available VisualCAM Resources.

2025 VisualCAM Resource Guide

The 2025 VisualCAM Resource Guide!

18 Pages

Lists PDF downloads and Online resources including Quick Start
Guides, Reference Guides, Exercise Guides, Tutorials and
More.

Prefer Printed Documentation? Click Here!

What's New  |  Quick Start Play List 

https://www.mecsoft.com/ResourceGuides/2024/VisualCADCAM/VisualCADCAM2024-Resource-Guide.pdf
https://mecsoftcorp.github.io/VisualCADCAM-2025/Resources/VisualCADCAM2025-Resource-Guide.pdf
https://mecsoft.com/WhatsNew/WhatsNewInVisualCADCAM2025.pdf
https://www.youtube.com/playlist?list=PLx9G05pFm0QKmM1LY2ydDA_vro-WPOo4E
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