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Welcome

RhinoCAM"®
G-CODE Editor Module 2026

Prefer Printed Documentation? Check Here!

What's New | Quick Start Play List

Welcome to the RhinoCAM-G-Code Editor Online Help! This help system contains helpful
information about every command and feature of the RhinoCAM-G-Code Editor. G-CODE Editor
can assist you with editing g-code files created with RhinoCAM or from other sources. It can also
be used to navigate and perform cut material simulations of g-code files. Select a topic from the
Contents, Index or Search tabs located on the left. You can also select a Related Topic from below
to get started. The Features topic contains links to every command in the RhinoCAM-G-Code
Editor!

For additional assistance and resources we invite you to visit the Find More Resources topic. We
hope you enjoy the RhinoCAM-G-Code Editor!

[T Related Topics
Overview
Features

Understanding
Work Flow

1.1 Overview

G-CODE Editor is a companion module that runs inside of RhinoCAMRhinoceros. G-CODE Editor
assists users with editing g-code files created with RhinoCAM or from other sources. It can be
used to navigate and perform cut material simulations of g-code files.

[ Related Topics
RhinoCAM-G-Code Editor

Features

Understanding
Work Flow

© 2026 MecSoft Corporation
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1.2 Features

The following features are included in the RhinoCAM-G-Code Editor module.

[T] Project

Machine MCS Setup

Merge Files

e Preferences Transform Project
e Stock Z Instance Project
e Tool Library XY Instance Project

Tool Stations

Load G-Code File

Project Information

[ Editing (Right-Click Menu)

Cut/Copy/Paste

Undo Last Command

Print G-Code File

Save File

Go to Bottom

[ Editing (Ribbon Bar Menu)

Add Line Numbers

Delete Line Numbers

Save Project
Output Project

GotoTop

Go to next Tool

Go to next Spindle

Go to next Feedrate

Find & Replace Text

Make all Upper Case

Make all Lower Case

e Insert Delimiter Spaces e G-Code Information

e Delete Delimiter Spaces e Find & Replace Text

[ Simulation

e Simulation Preferences e Display Simulation in Levels
e Simulation Speed e Simulate to End

e Simulation Mode e Pause Simulation

e Play Simulation e Stop Simulation

[ Related Topics

Welcome
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1.3

1.4

Overview

Understanding
Work Flow

Understanding

The RhinoCAM-G-Code Editor module can edit g-code files that you create with RhinoCAM. It can
also be used to edit g-code files generated from other systems that produce 1SO standard g-code
files. You can also define tool libraries, tool cribs and perform cut material simulations.

[T]

Related Topics
RhinoCAM-G-Code Editor

Overview
Features

Work Flow

Work Flow

The following is a basic procedural work flow for using the RhinoCAM G-CODE Editor module:

[T]

Step 1: Load a G-Code Files

Run the RhinoCAM G-CODE Editor module and Load the g-code file or files using the
commands on the Project tab. Your g-code files will be listed in the Project tree.

Step 2: Edit G-Code Files

Edit the G-Code file using the Edit tab functions. You can perform many automatic and
manual editing tasks, save and print your G-Code files.

Step 3: Tool Motion Simulations (Optional)

To perform tool motion simulations, simply place the cursor at the top of the G-Code file
and press the down arrow key and the tool motion will display on the graphics screen.

Step 4: Cut Material Simulations (Optional)

To perform a cut material simulations, load a Tool Library generated from RhinoCAM,
setup your Tool Crib with the tool numbers used in your g-code files. Then return to the
Project tab, right-click on the G-Code file and select Simulate.

[T] Step 5: Save your G-Code Files

© 2026 MecSoft Corporation
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When you are done editing your g-code you can Save the g-code files or Output them
directly to another program, of your choice such as a DNC program to communicate them
directly to your CNC machine. See Preferences > Text Editor to define your output
program.

[T] Related Topics
Welcome
Overview

Features

Understanding

© 2026 MecSoft Corporation
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Quick Start

RhinoCAM"®
G-CODE Editor Module 2026

Prefer Printed Documentation? Check Here!

What's New | Quick Start Play List

Quick Start Guides for each RhinoCAM module are available in both PDF and Video format. Refer
to the following information to access these guides:

1] What's New!
What's New in RhinoCAM 2026

[T The Complete Quick Start Video Play List
Here is a link to the complete 2026 Video Play List

[T] How to Access the Quick Start Guide Documents

To help you quickly get started in working with each module, select one of the Help
buttons located on the RhinoCAM Learning Resources dialog.

You will find:

e Quick Start Guides

e What's New documents
e Online Help links

The Quick Start Guides will help you step through an example tutorial which will
illustrate how to use the module. To access the Learning Resources dialog:

1. From the Rhino Main Menu, drop down the Main menu and select Learn ...

© 2026 MecSoft Corporation
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To access the Learning Resources dilog in RhinoCAM

2. Select a document from the Learning Resources dialog to get started using the
module of your choice.

¥ You can also select the Open Quick Start Files Folder button located at the bottom
of the dialog to open the Quick Start folder where the source files (start and
completed versions) are located.
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| Learning Resources

Welcome to RhinoCAM 2025!

Toget started as quickly as possible use the following resources.

1"

MILL TURM
i | @
What's New? Web Resources On-Line Help Quick Start On-Line Help Quick Start
Profile-MEST G-Code
@ U e W |
On-Line Help Quick Start On-Line Help Quick Start
MEST ART
@ U e W
On-Line Help Quick Start On-Line Help Quick Start

Where to go for more help:
Togetyourspecific support questions answered click here to fill out a support form.

Forall otherinformation visit ourweb-site www.mecsoftcom

Open Quick Start Files Folder |

Learning Resources Dialog

[ Related Topics

Find More Resources
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CAM Resource Guide

Download this PDF Guide for a list of the available RhinoCAM Resources.

[T] 2025 RhinoCAM Resource Guide

S Y The 2026 RhinoCAM Resource Guide!
RhinoCAM

. 18 Pages
Resource Guide |

Lists PDF downloads and Online resources including Quick Start
Guides, Reference Guides, Exercise Guides, Tutorials and
More.

— Prefer Printed Documentation? Check Here!

What's New | Quick Start Play List

© 2026 MecSoft Corporation
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User Interface

RhinoCAM-G-CODE Editor adheres to the Windows standard for user interface design and is

seamlessly integrated into the Rhinoceros screen layout. A screen image of RhinoCAM-G-CODE
Editor running inside of Rhinoceros is shown below:

I:D The User Interface
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RhinoCAM User Interface

1] Related Topics
Preferences

G-Code Browser

Project Tab
Edit Tab

Simulate Tab

41 Preferences
You can set various System Preferences that will be saved even after you exit the program.

Select the Preferencesicon from the G-Code Browser. When you install a new RhinoCAM
update you can choose to import your Preferences from one version to the next.

I:D To Access this Command:
mclick:

© 2026 MecSoft Corporation
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[T] The Preferences Icon

Project £ = @
T'l

[a]n]=]

‘1 Library @ Info ﬁ’?’% Transform LJ—_J Save

["‘aStDck & i Load Jf Merge Files 888 XY Instance

! ]' Mumbers &= Z Instance |_‘._, Output
Setup G-Code File Operations

Preferences

Set System Preferences menu item

[T] Related Topics
User Interface

System Preferences

Text Editor Preferences

Toolpath Preferences

Stock Preferences

Cutting Tools Preferences

Simulation Preferences

411 User Interface

Here you can set preferences related to the g-code text editor including colors and associated
programs and folders. You can use the Reset to defaults button if you want to revert to the default

factory install settings.

[1] To Access this Command:

%click: L > User Interface

[T] Preferences > Text Editor

© 2026 MecSoft Corporation
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Preferences >
IUser Interface l Language
Text Editor System Language: English {United States) w
Toolpath Tool Tips Preferences
Stock B show Context Tool Tips
Cutting Tools B show Expression Result in Tool Tip
Simulation Tool TipDelay: 0.5 = sec
Ribbon Style
System w~

Additional Open File Extensions

Enter Extension for Import File

(example : .abc, .xyz) Add

Save Preferences

Save Current Preferences to Registry

Reset to Defaults Cancel Apply Help

Preferences > User Interface

[T] Language

System language
Use this to set the system language of the plugin's User Interface.

[T] Tool Tips Preferences

Show Context Tool Tips

Check this box to display Context ToolTips when the mouse moves over a parameterin a
dialog. A definition of the parameter will pop-up automatically. Note that Context
ToolTips may not be available for ALL dialogs. You can also set the ToolTip Delay in
seconds. This is the amount of time it takes to display the Context ToolTip when the
mouse activate it.

5t Hista _]
(®) % Teod D= 125 L=l T
DD'Q % Tool Diameter allows you to set the stepover
distance for the cumrent operation as a
percentage of the active tool diameter
I

O] Abwsys Keep Tood Down

Ciinsde () Outssde
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Show Expression Results in Tool Tips

You can enter expressions in any dialog field that expects a numerical value and the
value will be computed and entered automatically. Check this box to pop-up the results
of any expressions in a ToolTip balloon. An example is shown below.

Location of Cut Geometry

(JAtTop (@) AL Bottom
(O Pick Top 0 -

Cut Depth Control

Total Cut Depth: =
Rough Depth:
|:|.5 - _ -

Show Expressions in ToolTip

Tool Tip Delay
When Show context ToolTips is checked, this value defines the Delay in seconds it takes

for a ToolTip to display once the cursor moves over it.
1] Ribbon Style

This allows the selection of different themes that change how the Browser windows
appear. The borders, colors, highlighting, and shadowing of standard buttons, dialogs,
and windows are controlled by which theme is selected.

T | b
MILL|'#3| Program Simulate o g -8 -@

39 Machine §) Stock * o™ WorkZero e 4 Axis ~ 3§
% Post BB mign - | = omis - (@ smis B -

Setup ~ $= Material a'\j, 3 Auis Adv ~ |l§-| Holes ~

Machine Setup Stock Machining Operations

Example Ribbon Style: Office 2010 Silver

[T] Additional Open File Extensions

If your g-code files have an extension other than *.ncyou can add that extension here.
Enter the extension in the field provided and then pick the Add button.

Additional Open File Extensions
Enter Extension for Import File I:I d4d
(example : .abc, .xyz) A

[T] Save Preferences
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Save Current Preferences to Registry

If you have your preferences set the way you want them and do not want them top
change, select this button to save the current preferences to your Windows registry.
Doing this will force them to be loaded when you create new files.

[ Related Topics

Text Editor Preferences

Toolpath Preferences

Stock Preferences

Cutting Tools Preferences

Simulation Preferences

41.2 TextEditor

Here you can set preferences related to the g-code text editor including colors and associated
programs and folders. You can use the Reset to defaults button if you want to revert to the default
factory install settings.

[1] To Access this Command:

%click: s > Text Editor

[1T] Preferences > Text Editor

Preferences X
User Interface Text Editor Colors
Text Editor rapidmove [ - Line number [ ~
1
Toolpath
P Linear move [ - Comment B -
Stock
Arc move - -
Cutting Tools
Simulation Program to output
notepad

Feset to Defaults Cancel Apply Help

Preferences > Text Editor

[T] Text Editor Colors

© 2026 MecSoft Corporation
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You can specify the default colors to display for Rapid, Linear and Arc moves as well as for
Line Numbers and Comments within the G-Code Editor. Use the color selector available
for each.

%

=40 4% GBO G98

sSetup 1

$2 1/2 Awis Profiling (Outer) «£ Comments
20 G290

510000 MO3

MO7

GO0 Z0.5 € Rapid Moves

[ Y S U

()]

TR e ]
|
[N§]
i

Linear Moves

[l
A

25 I0. J-0.125 F195. €«—— Arc Moves

I
[ Y T A
L
S
|
I
|
I
r
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|
I
EJ
|
[
|
|
;
I
s
r

()]

Text Editor Color Preferences

1] Save Directory

You can specify the default save directory. Pick the III button to select a different
folder. When you pick Save from the Project tab, this is the folder where the file is
saved. To overwrite the original g-code, use the Save G-Code command from the Edit
tab.

1] Related Topics

User Interface Preferences

Toolpath Preferences

Stock Preferences

Cutting Tools Preferences

Simulation Preferences

41.3 Toolpath

Here you can set Toolpath related preferences including colors, display, format and feedrate. You
can use the Reset to defaults button if you want to revert to the default factory install settings.

[T] To Access this Command:

b click: > Toolpath

[1] Preferences > Toolpath
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Preferences -

User Interface Toolpath Colors

Text Editor Rapid B - Cut Arc B -
Toolpath
_ Cut I -
Stock
Cutting Tools Toolpath Display
Simulation z

Toolpath Display Thickness: 1

Circle center (I, 1, K)
D 2Absolute () Wector from Start to Center
() Wector from Center to Start () Unsigned Vector from Start to Center

Feedrate speed

Rapid Feed 29.334 =

Mominal Cut Feed 14.667 =

Reset to Defaults Cancel Apply Help

Preferences >Toolpath

[T Toolpath Colors

You can specify the default colors to graphically display Rapid, Linear and Arc moves. Use
the color selector available for each.

Rapid SR
¥ 2N
< :

> :\1/3

Cut > Arc

Toolpath Display Color Preferences
1] Toolpath Display

Here you can set the line thickness for the display of all toolpaths.
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()

/]
AR
Ny
U

: c o>

L
L

Toolpath Display =1
Toolpath Display =2

] Circle Center (1,J,K)

I,J,K refers to the center point location for arc motions. In this section you can define
how arc motions are formatted in the output G-Code file. Select from the following
options:

e Absolute
e Vector from Center to Start
e Vector from Start to Center

e Unsigned Vector from Start to Center

1] Feedrate Speed
Here you can specify feedrate values for the G-Code file. Select from the following:
e Rapid Feed

e Nominal Cut Feed

1] Related Topics

User Interface Preferences

Text Editor Preferences

Stock Preferences

Cutting Tools Preferences

Simulation Preferences

41.4 Stock

Here you can set Toolpath related preferences including colors, display, format and feedrate. You
can use the Reset to defaults button if you want to revert to the default factory install settings.

[1] To Access this Command:
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% click: o > Stock

[1] Preferences > Stock

Preferences >
Izer Interface Stock Colors
Text EditDF Stodk I:l -
Toolpath
? cutstock [ -
Stack |
Cutting Tools Stock Model Display Transparency
) ) Opague Transparent
Simulation

Reset to Defaults Cancel Apply Help

Preferences >Toolpath

[T] Stock Colors

Here you can set the default colors for Stock and Cut Stock. Use the color selector
available for each.

[T] Stock Model Display Transparency
Use the slider to set the transparency of the Stock Model Display.

(1] Related Topics

User Interface Preferences

Text Editor Preferences

Toolpath Preferences

Cutting Tools Preferences

Simulation Preferences

41.5 Cutting Tools

Here you can set Cutting Tool related preferences. You can use the Reset to defaults button if you
want to revert to the default factory install settings.

[T] To Access this Command:
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% click: = > Cutting Tools

[T Preferences > Cutting Tools

Preferences >

User Interface Cutting Tool Color

Text Editor Tool Color E

Toolpath

Stock

[ Cutting Tools ]

Simulation

Reset to Defaults oK Cancel Apply Help

Preferences > Cutting Tools

[T] Cutting Tool Color

Here you can set the default color for the Cutting Tool during simulations. Use the color
selector available for each.

1] Related Topics

User Interface Preferences

Text Editor Preferences

Toolpath Preferences

Stock Preferences

Simulation Preferences

41.6 Simulation

Here you can set Simulation related preferences. You can use the Reset to defaults button if you
want to revert to the default factory install settings.

[T] To Access this Command:

%click: W Simulation

[1] Preferences > Simulation
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Preferences >

Uszer Interface simulation Made

Text Editor 0 simulate By Moves () Simulate By Distance
Toolpath i . Max
Stock Maximum Display In1_:erva| (# 100 a
Cutting Tools of Moves Distance): <
[ Tt | Simulation Accuracy
Standard Mediurn Fine

Simulation tolerance: 0.01

Additional Options

[ pisable advanced OpenGL

Reset to Defaults Cancel Apply Help

Preferences >Simulation

[1] Simulation Mode
There are two simulation modes.

Simulate by Moves

One pick of the Step icon on the Simulate tab moves the Cutting Tool one complete move
(i.,e., start to end). See Maximum Display Interval below. This option is the same as
checking the Simulate By Moves box on the Simulate tab.

Simulate by Distance

One pick of the Step icon on the Simulate tab moves the Cutting Tool a specified
distance. See Maximum Display Interval below. This option is the same as un-checking
the Simulate By Moves box on the Simulate tab.

Maximum Display Interval

You can control the speed of the simulation using the slider bar and the Maximum
Display Interval. When using Simulate by distance mode, the speed is determined as # of
Motions / Distance.

1] Simulation Accuracy
Use this slider to adjust the simulation display accuracy.

Simulation Tolerance

The Simulation Accuracy slider provides a high-level of adjustment and the Simulation
Tolerance provides a more granular level of control. Note that the Simulation Tolerance
will have a direct affect on simulation time.
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4.2

[T] Additional Options

Disable Advanced OpenGL

Check this box only if you have an older graphics card adapter that does not support
advanced OpenGL (i.e., OpenGL 2). Some older cards may only support OpenGL 1 for
example. If you experience graphics instability checking this box may help resolve the
issue.

(1] Related Topics

User Interface Preferences

Text Editor Preferences

Toolpath Preferences

Stock Preferences

Cutting Tools Preferences

G-Code Browser

The G-Code Browser has four main modes of operation represented by tabs at the top of the
browser window. These are Project, Edit, G-Code Edit and Simulate. Each tabbed view also
incorporates a ribbon toolbar of commands at the top. These toolbars group associated
commands into panes.

Each menu tab is shown below:

[T] The Project Tab
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Project o @ @
8 Stock - —L Load ?f Merge Files EEEKYInstance
I Library - @ Info ﬁi@ﬁ Transform H Save
1‘[I' Mumbers &= 7 Instance B» Cutput
Setup G-Code File Operations

= | Project

3 b achine
[Ei Stack

m Tool Library
12"[r Toal Mumbers

“f Toaol 14
[ Tool#d
“f Tool 2

=l ol G-CODE-EDITOuickStatGuide. ne

% Edit

@ Simulate
i Info

|& Delete

G-Code Browser, Project Tab

(1] The Edit Tab

%click:. Project

> 1| Load >®> | Edit

25
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Edit | Simulate = o g 0
é: Add Line #s ~_ Del Line#s o Cut M Find... == Print
AV |nsert Spaces | AY Del Spaces ~ Copy ¢ Replace.. |g= Save
‘“:gq Upper Case ’-iﬂ Lower Case - Paste H-'] Undo 9 Info

1 % ~
2 oo
3l M1G40G49%GE0
4! | BEGIN TCCL LIST )
5 ( TOOL 1{, —~~—"""= "5 INCH - DESC: 2.5
& ( TooL 4| * Bottom INCH - DESC: 0.25C
7 ( TOOL 2| %] Top - DESC: 0.5000 DIZ
5 ( ENDOF | g o
S [(Setup 1
100 (2 1/2 af ¥ Spindle
11; H2 ({Tool | g Feedrate Length = 2.0 )
12) 13654
13 wagzoTial °%  Cut
14; M5 510001 =y Copy [%
15, NEGI0GOX| 1  pacte
16 M7G43Z1.
17 N8 Glagg| M Find.
18; N9 GO ¥A  Replace...
1% N10 G1lzZ1
20 N11 x2.5( 9 Undo
21 N1z G17
22073 (E0A¥3,4682Y-1.25I-F 1471,

G-Code Browser, Edit Tab

[T] The Simulate Tab

[ dlick:, Preiest |5 /47 Load >®> 3 Simulate

displayed)

(with Simulate Window
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Edit | Simulate = o & @
&';‘l Preferences g Play EI Tz End
[ | m Step ml Pausze

Simulate by Mowves & Step Levels |[]] Stop

Opticns Simulate
1 % ~
2 Q1234
3 HOOD1l G40 G4%5 G830
4! WOOD2zZ | STCOCE SIZE: X2.125 Y2.125 2Z0.2
5 { BEGIN TCOL LIST )
g | TOOL 1 - FlacMill:0.25 - DESC: 0.2500
Ti { TOOL 2 - FlatMill:0.125 - DESC: 0.1250
g { TOCL 3 - Drill: 1/4"™ - DESC: 0.2500 DL
9 { EWNDOF TCOL LIST )
10 ] [(Setup 1)
11;: HOO4 (Work Zero)
12; HOODS G54

Ty,

G-Code Browser, Simulate Tab

[T Related Topics

User Interface

Project Tab

Project Tree
Edit Tab

Simulate Tab

421 ProjectTab

The Project tab is Selecting the Program tab in the Mops Browser shows 3 groups of menus that
provide access for specifying Machine, Stock and defining Machining Operations.

[T] To Access this Command:
%click:. Project

[T] The Project Tab
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Project LA @

@Stu:uck & —_:_ Load Jf Merge Files EEEXYInstance
I Library - @ Info ﬁ"ﬁe Transform L—j Save

! [ Mumbers &= 7 Instance |_: Cutput
Setup G-Code File Operations

= | Project

3 b achine
@ Stack

ﬂ Tool Library
12]' Tool Murnbers
[SENRE G-C00E-EDITQuickStartGuide. ne

[ Tool#14 | Edit
Tool #4 @ Simulate
[ Toolt2 @ Info
|& Delete

G-Code Browser, Project Tab

[1] Ribbon Bar Options

Projeet | Contains Project related commands.

] . L C .
Use these icons to maximize and minimize the ribbon bar menus.

il Display the Preferences dialog.

@ Display the Online Help system.

[1] Project Setup Pane
(] stock ~ Displays a menu of Stock definition commands.
|4 Library - Displays the Tool Library dialog.

|
2 If Numbers Displays the Tool Crib dialog.

(1] Project G-Code Pane
tlbtead | hada g-code file into the Project tree.

@ Info Display Information about the g-code files currently loaded into the Project.
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[T] Project File Operations Pane
& MergeFiles \ 1o rge two selected g-code files into one file.
“#: Transform Displays the Transform g-code dialog.
= Zlnstance picp)avs the Z Instance g-code dialog.
885 XY Instance Displays the XY Instance g-code dialog.

e Save Saves all g-code files currently loaded into the Project.

L Output outputs the g-code files currently loaded into the Project.

[1] Project Tab, Right-Click Menu
|5 Edit . .
Edit the selected G-Code file.
[ Simulate Simulate the selected G-Code file.
Ep—— Display information about the selected G-Code file.

LE—— Delete the selected G-Code file.

[T] Related Topics
Project Tree
Edit Tab

Simulate Tab

Online Help

42.2 ProjectTree

= | Project The Project tree is located under the Project tab. It contains all of the elements
needed for a specific project, including stock model, tool library, tool crib and g-
code files. The Project tree can also alert you to issues that need to be addressed by flagging

items for attention.

[T] To Access this Command:
Ikclick:. Project

[T] The Project Tab

You must have the Project tab selected in order to see the Project tree.
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Project o @ @
ﬁ Stock - —L Load ?f Merge Files EEEKYInstance

Library = | U@ Info . Transform Save
y o L]
1‘[I' Mumbers &= 7 Instance B» Output

Setup G-Code File Operations

= | Project

3 b achine
[Ei Stack

m Tool Library
12"[r Toal Mumbers

=l ol G-CODE-EDITOuickStatGuide. ne

T Toolth14 | Edit
!
Tool #4 @ Simulate
[ Toolt2 @ Info
|& Delete

G-Code Browser, Project Tab

[T] Returning to the Project Tab

You can return to the Project tab by selecting this icon “ Jocated on the top G-
Code Browser when either the Edit, G-Code Edit or Simulate tabs are active.

Edit | Simulate = o & @

i Addline#s Delline® o Cut @®Find... [Back to Project
f’*_‘f Insert Spaces f‘;{ Del Spaces o Copy i;’? Replace... Save

"::r_‘,l Upper Case “-iﬂ Lower Case | > Paste ) Undo @ Info
1 % -
Zi 00
3 HW1G40G49GE0
4: ( BEGIN TOCOL LIST )
5 ( TOOL 14 - FACEMILL-Z.5 INCH - DESC: 2Z.5C
6 | TCOOL 4 - FlatMill-1/2 INCH - DESC: 0.25C
T AT 2 TILL-™S2 TM — MESC: 0.5°00 DI~

G-Code Browser, Return to Project Tab menu item

[T] How Stock is Defined in the Project Tree
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If there no stock yet defined, the Stock icon in the Project tree will say "Stock -
None". Once a stock is defined, the Stock icon in the Project tree will indicate the
type of stock that is defined. Refer to the two Project tree images. The image on the
left has no Stock yet defined. The image on the right has Box Stock defined.

= | Project =-| | Project
y Machine y M achine
@ Stock - Hone h fiﬂ Stock - Box Stack, «

Iﬂ T ool Librany Iﬂ Tool Library
lﬂ.'_" T ool Mumbers 12|J' Tool Humnbers
= | % G-CODE-EDITQuickStartGuide.no = | % G-CODE-EDITQuickStanGuide.ne
[ Tool#4 [ Tool#g
[ Tooi#4 | Toolttd
[ Tool#z [ Toolwz
When Stock s not defined When Stockis defined

[T] Red Flags in the Project Tree
If items are flagged in the Project tree it means that they need your attention.

For example if a g-code file has been modified but has not yet been saved or output,
it will be flagged as shown in the example below.

- | Project

y b achine
fiﬂ Stock,

' ﬂ T ool Librarny

L J’ Tool Mumbers

= ‘1} G-CODE-EDIT QuickStartGuide.ne

J’ Tool #14
[ Tool 4
J’ Tool #2

When ag-code file is flagged

If you load a g-code file that uses a tool number that is currently undefined in your
tool crib, it will be flagged as shown below.
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E-| | Project

‘y M achine
@ Stock,

H T ool Library
12'J' T ool Humbers
[=ESRN G-CO0E-EDITQuickStartGuide. no
W Tool #14

When atool is flagged

[T Related Topics

Project Tab
Edit Tab

Simulate Tab

Online Help

423 EditTab

Edit

When you double-left-click on a G-Code file from the Project tree, that file is loaded into

" the G-Code Editor. The Edit tab contains commands to Modify and Navigate the g-code

file. The Edit tab and commands are listed below.

[T] To Access this Command:

(% click:) Proiect |, ¢ Load|, | Edit

[T] edit tab

© 2026 MecSoft Corporation



User Interface

Edit | Simulate = o & @
é: Add Line #s __ Delline®#s = Cut O Find.. ot Print
AV |nsert Spaces | AY Del Spaces = Copy {?Replace... b Save
“u Upper Case '-iﬂ Lower Case | |- Paste "-'} Undo 9 Info

1 % L
2i Q0

3 H1G40G4SGE0

q { BEGIN TOCL LIST )

] ( TOOL 1y~~~ 1/ IHCH - DESC: 2.5C
& ( TooL 4| * Bottom INCH - DESC: 0.25C
T [ TCOL 2 ?I' Top - DESC: 0.5000 DIF
g { EHDOFE 7 t]- Taal

S [(Setup 1 g )

10 |:2 J.,-"E Al = SplﬂdlE

11; H2 ({Tool | g Feedrate Length = 2.0 )

12; H3G54

13 waG2oT14] %%  Cut

14; M5 510001 =y Copy %

15 HeG90G0X- Paste

lg; HTGE43Z1.) )

17. Ns Glasg|O® Find..

18; N9 GO ¥A  Replace...

1% H10 Gl1lZ1

20 w11 x2.5(9) Undo

21; H1z2 G17

27 3 E0AY3 . 4eE2Y-1,.25I1-F “14.J] .

G-Code Browser, Edit Tab

1] Ribbon Bar Options

Edit

_Contains file Edit related commands.

Returns to the Project tab.

A .. — .
Minimizes and maximizes the ribbon bar menu.

Ll Displays the Preferences dialog.

@

[T edit Tab

1
z

Displays the Online Help system.

5 AddLine s aAqq |ine numbers to the g-code file.

*E'.’T Insert Spaces

Insert spaces (i.e., delimiters) between g-codes.

33
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A UpperCase conyert g-code to all UPPERCASE text.

— Delline®s pojete line numbers from the g-code file.

AV . -
1 DelSpaces pojete spaces (i.e., delimiters) between g-codes.

gy Lower Case o5 nvert g-code to all lowercase text.

i . Cut the selected text to the clipboard.

| S9P¥|copy the selected text to the clipboard.

1
.F‘ast;*
Paste the selected text to the current cursor location.
O Find... £ind text within the G-Code file.
47 Replace... £ind g Replace text within the G-Code file.
)
Undao

-

Undo the last command.
== Print print the G-Code file currently loaded in the editor.
B save - Save the G-Code file currently loaded in the editor.

@ Info Display information about the current g-code file.

[1T] Edit Tab, Right-Click Menu

L] Bottom Go to the Bottom (End) of the G-Code file.

d " Top Go to the Top (Start) of the G-Code file.
I Tool Go to the next Tool Change code.
% Spindle Go to the next Spindle code.
§  Feedrate Go to the next Feedrate code.
Sr— Cut the selected text to the clipboard.
Copy Copy the selected text to the clipboard.
Paste

Paste the selected text to the current cursor location.
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Ar— Find text within the G-Code file.

A Replace... . I .
Find & Replace text within the G-Code file.

) Unde

Undo the last command.

1] Edit Tab, Display Toolbar

Display Toolbar

=
@ Stock Model Visibility: Turn on/off stock model

s 1
5 Part Model Visibility: Turn on/off part model display during simulation.
T =l

&5 | Toolpath Visibility: Turn on/off toolpath display

Follow Toolpath Display: The toolpath is displayed as it follows the behind the

movement of the tool (i.e., you will only see the toolpath after the tool passes.
Trpee |

Trace Toolpath Display: The toolpath is not displayed as it follows the behind the

movement of the tool (i.e., you will only see the toolpath before the tool passes.
e |

Segment Toolpath Display: The toolpath is only displayed for the segment that the
tool is currently on.
[1] Related Topics

Project Tab
Project Tree

Simulate Tab

Online Help

424 Simulate Tab

Simulate | When you double-left-click on a G-Code file from the Project tree, that file is loaded
into the G-Code Editor. The Simulate tab contains commands to perform tool
motions and cut material simulations of the g-code file. The Simulate tab and commands are
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listed below. Note: You must have Stock, Tool Library and Tool Crib defined before performing a
Simulation.

[1] To Access this Command:

%click;_ Project | 4| Load , | Simulate

[T] Simulate tab

Edit | Simulate = o 5 @
(—iﬂ Preferences g Play El To End
| 3| Step M| Pause
Simulate by Mowves &5 Step Levels |[]] Stop
Options Simulate
1 % ~
2 ©l234
3 HNOOl G40 G4% GBO
4: MNOO2Z | STOCE S5IZE: X2.125 ¥2.125 Z20.2
5 { BEGIN TCOL LIST )
& { TCOL 1 - FlatMill:0.25 - DESC: 0.2500
7 { TOOL 2 - FlatMill:0.125 - DESC: 0.1250
] { TOOL 3 — Drill: 1/74™ - DESC: 0.2500 DL
S { ENDCOF TOCOL LIST )
100 M003 (Setup 1)
11} HOO4 (Work Zero)
12 HOOS G54

iy,

G-Code Browser, Simulate Tab

[1] Ribbon Bar Options

Simulate . . . .
Contains file Simulation related commands.

“= Returns to the Project tab.
- Minimizes and maximizes the ribbon bar menu.
L Displays the Preferences dialog.

@

Displays the Online Help system.

[1T] Simulate Tab, Options Pane

&.‘ﬂ Preferences pjisplay Simulation Preferences.
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Simulation speed adjustment (Left: Slow, Right: Fast).

Simulate by Moves . . .
4] - Check to simulate by moves. Uncheck to simulate by distance. See

Preferences to set the default mode.

[T] Simulate Tab, Simulate Pane
O Play Play the simulation.
L) step Step through the simulation by distance or by moves.
&5 Step Levels gy lay simulation in Levels.,

£ To End Go direction to the End result of the simulation.

[JPause payse the simulation.

[ stop Stop the simulation.

[T] Simulate Tab, Display Toolbar

Display Toolbar
2
Stock Model Visibility: Turn on/off stock model

T |

5 Part Model Visibility: Turn on/off part model display during simulation.
l

&5 [ Toolpath Visibility: Turn on/off toolpath display

e

Follow Toolpath Display: The toolpath is displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath after the tool passes.
[42]

Trace Toolpath Display: The toolpath is not displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath before the tool passes.
)

Segment Toolpath Display: The toolpath is only displayed for the segment that the
tool is currently on.

[T] Related Topics
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Project Tab

Project Tree
Edit Tab

Online Help

4.2.5 Online Help

&) You can access this online help system from the G-Code Browser.

D:I To Access this Command:

%click: @

1] The Online Help Icon

Project

ﬁ Stock ~ ='|:|
‘I Library L]
.IL[r Mumbers

Setup

Load
Info ﬁ‘% Transform H Save

G-Code

* Merge Files ﬁggx‘flnstance Help

= 7 Instance B;' Cutput

File Operations

'_.‘3' RhinsLAM-G-Code Edtor 2031 On-Line Help

© 0 & & £ @
S Rebeh Pt Opters

- -

Conterts |ndex Seach Faeorbes

[ o
o Quick Szam
W0 CAM Resouwce Guide
# @ User Interlace
4 i Project Tab
o @ Edit Tab
5 @ Simulate Tab
[5) Find Mcre Resources

Online Help menu item

S
RunoCAM
o

MecSoft COrporation] . q.; couro 1ases dsyein cons Fie sey
BCopyright 190 -HGT 0 GNOTH0IELDANTALN AT

Prefer Printed Documentation? Check Here!

Waelcgme to the RhinpCAM-G-Code Editor Onling Help! This help system containg
hlpful information about every command and feature of the RhinoCaM-G-Code
Editor. G-CODE Editor can assist you with editing g-code files oreated with RhinoCAM or
from other sources. It can also be used to navigate and perform cut material
timulations of g-oode files. Select &topic from the Conténts, Index or Search tabs
located on the left. You can also select a Related Topic from below 1o get started. The
Features topic contains links to every command in the RhincelAM-G-Code Editor]

For additipnal assistance and resclanoes we invite you to visit the Fing More Resources
topic. 'We hope you enjoy the RhinoCAM-G-Code Editor!

O Related Topics

RhinoCAM-G-Code Editor Online Help System
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[T] Related Topics

Project Tab

Project Tree
Edit Tab

Simulate Tab

39
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Project Tab

The Project tab is Selecting the Program tab in the Mops Browser shows 3 groups of menus that
provide access for specifying Machine, Stock and defining Machining Operations.

[1] To Access this Command:
%click:. Project

[ The Project Tab
Project o & @

@Stn:nck = '.:. Load 3§ Merge Files Eﬁﬁﬂlnstance
'|'J Library = @ Info I:"qiz- Transform H Save

! | Numbers &= £ Instance |_: Output
Setup 5-Code File Operations

= | Project

y b achine
@ Stock,

'ﬂ Tool Library
12]’ Tool Murnbers
=Sl G-C00E-EDITOuickStatGuide. e

[ Tool#14 | Edit
Tool #4 @ Simulate
[ Tool#2 @ Info
|& Delete

G-Code Browser, Project Tab

[T] Ribbon Bar Options

Prejeet | contains Project related commands.

“ Use these icons to maximize and minimize the ribbon bar menus.
L Display the Preferences dialog.

@ Display the Online Help system.
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[1] Project Setup Pane
f_‘b Stock ~ Displays a menu of Stock definition commands.
|4 Library - Displays the Tool Library dialog.

! [ Numbers . I
E Displays the Tool Crib dialog.

[1] Project G-Code Pane
+ Load | hada g-code file into the Project tree.

@ Info Display Information about the g-code files currently loaded into the Project.

[T] Project File Operations Pane
¥ Merge Files Merge two selected g-code files into one file.
#i Transform Displays the Transform g-code dialog.
&= Zlnstance niop)ays the Z Instance g-code dialog.
BEE XY Instance Displays the XY Instance g-code dialog.

e Save Saves all g-code files currently loaded into the Project.

Ly Output Outputs the g-code files currently loaded into the Project.

[T Project Tab, Right-Click Menu
|3 Edit . .
Edit the selected G-Code file.
[ Simulate Simulate the selected G-Code file.
p——— Display information about the selected G-Code file.

|@ Delete Delete the selected G-Code file.

1] Related Topics

Project Tree
Edit Tab

Simulate Tab

Online Help
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5.1 Machine MCS Setup

= | Project You can set the cutting direction and alignment using the Machine
3 Machine Coordinate System (MCS) dialog. This orients the coordinates defined in the
any g-code files that are currently loaded into the editor.

1] To Access this Command:

= | Project
(% ick:. 7=t 5 [ double-dlick: 3 Machine

[T] G-Code Browser: Project tab, Stock menu

Project £y g8y @

[a]n]=]

1 Library ~ @ Info ﬁ’?’% Transform LJ—_J Save

["‘aStDck & i Load Jf Merge Files 888 XY Instance

! ]' Mumbers == Z Instance |_‘._, Output
Setup G-Code File Operations

= | Project
3 Maching .
@ Stock, L\\T %' {EK}
ﬂ Tool Librany

12' J’ Tool Mumnbers

- % G-CODE-EDITQuickStantGuide.ne
fe 1) i T

Edit the Machine MCS

[] Dialog Box: Machine
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Machine Tool Setup by

Machine Tool Coordinate System

Cutting |
Direction

Waorld
Coordinate Machine
System Coordinate System

Align to
Waorld Coordinate System Artive Construction Plane

Geometry
Select Surface: | By | Select Planar Curve: | R

Set Orientation parallel to

Warld X Warld ¥ Warld Z

Rotate about

Spin Angle: = X Axiz | | Y Axiz | | Z Axis

Coordinate System Origin

oI5

= EE

Reset to Qriginal

ok | [ cance

Dialog Box: Machine (MCS) Setup

[T The Machine Coordinate System (MCS)

The Machine Coordinate System (MCS) is displayed as a triad with Blue line
representing the Z-axis, Red representing X-axis and Green representing the Y-
axis. The WCS is displayed the same way as MCS and is located at the origin. The
lengths of the WCS arrows are shorter when compared to MCS.
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(mMcs) (wcs)

1] Align to
This aligns the MCS orientation. Select from the following:

Machine Tool Coordinate System
Aligns the Setup Coordinate System to Machine Tool Coordinate System.

Align To: World Coordinate System

Active View Construction Plane
Setting the MCS to the orientation of the active viewport of the construction
Plane.

Align To: Active Construction Plane

Geometry: Part Surface
User can select a point on a surface determine the alighment of MCS.
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Align To: Geometery, Part Surface

Geometry: Planar Curve
User can select a planar curve (2D sketch) to determine the alignment of MCS.

Align To: Geometry, Planar Curve

I:D Set Orientation Parallel to

Allows you to set the Machine Coordinate System parallel to the World XY or Z
co-ordinate axis.

World X orients the Z axis of MCS parallel to World X axis.
World Y orients the Z axis of MCS parallel to World Y axis.
World Z orients the Z axis of MCS parallel to World Z axis.
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Orientation
Parallel to MCS Visibility ON

WCSVisibility OFF

AT

World X I\

World Y

World Z

[T] Rotate about

Triad Display

WCS Visibility ON
MCS Visibility OFF

MCS Visibility ON
WCS Visibility ON

K<
+
L

Allows you to rotate the Machine Coordinate System in XY Z coordinate axis by
any angle specified under Spin Angle. Specify Spin Angle and click the axis to
rotate about. Clicking the same coordinate axis button multiple times rotates by
the specified angle incrementally. For example if you set the Spin Angle =90
and click X Axis button 2 times, the MCS is rotated about X coordinate axis by

180 degrees.

[T] Coordinate System Origin

This translates the MCS origin to the desired location. This can be set to any

location on the part geometry.
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Use Coordinate System Origin to translate the MCS origin to the desired location

1] Reset to Original

Resets MCS orientation to current MCS orientation.

[1] Related Topics
G-Code Browser
Project Tab
Project Tree

5.2 Setup Pane
5.21 Stock

L‘j Stock E] This menu contains commands to create different types of Stock material in
preparation for cut material Simulations. If there is no stock defined, Simulations

will only show tool motions and not a cut material simulation.

[D To Access this Command:

%click:. Project _>85t°‘:k3]

I:D G-Code Browser: Project tab, Stock menu

© 2026 MecSoft Corporation



48 RhinoCAM 2026 G-Code Editor Reference

Project 2 gF @
i Load Jf Merge Files 888 XY Instance

["‘a Stock | T, gog
Box J@ck ransform LJ—_J Save

Part Box Stock ... lInstance | % Output
Cylinder Stock... File Operations

Part Cylinder Stock ...
Delete Stock

[l§ ToorLibrary
12]’ T ool Humbers

= % PPG-Decoded-haas"nhyp 1.nc
e

The Stock Menu

[ Related Topics
Stock Menu

Create Box Stock

Create Part Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.1 Box Stock

ﬁj Stock - You can define the raw stock model as a simple box by selecting the Box Stock option
from the Stock menu on the Project tab of the G-Code Browser and entering the
Stock dimensions.

[1] To Access this Command:

Iéclick:. Project | | |E30 Stock | 5 Boy Stock ...

[T] Box Stock menu item
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Project

‘:“ﬁ Stock | i Load
Box Stock .. b
Part Box Stock ...

Cylinder Stock...

Part Cylinder Stock ...

Delete Stock
[lg ToorLibrary
1

L J’ Tool Mumbers

& i @

& Merge Files B85 XY Instance

[a]=]=]

ransform L_l—_JSave
! Instance |_' Output

File Operations

= % PPG-Decoded-hass-Setup 1.no

FoTaw

G-Code Browser: Box Stock menu item

[1] Dialog Box: Box Stock

You can define the box by simply typing in the Length, Width and Height of the box in the
corresponding edit boxes of the dialog. The corner position (origin) of the box can also
be repositioned by picking the desired coordinate or by specifying the coordinate values
in the corresponding edit boxes in the dialog (Xc, Yc, Zc). When you click on the OK
button, a stock model based on your definition will be created and displayed.
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Box Stock pd

Stock Geometny

Hesight (H)

k"f Length L) e
X

Comer Coordinates
N = DR S e TR = 1Y
Dimenzions

Lles JE wls 5 oels S

| Copy Madel Bounding Box |

[] Ignaore ‘Wireframe Geometry in Bounds Computation

| k. || Cancel || Help

Dialog Box: Box Stock

1] Copy Model Bounding Box

When Copy Model Bounding Box is selected, the system calculates the bounding box of
the part model as the XYZ extents of geometry of the part model and displays the XY Z
Coordinate values under dimensions.

[T] Ignore Wireframe Geometry in Bounds Computation

Check this box to ignores all 2D and 3D curve geometries present in the part from stock
bounding box computation.

Make sure to click Copy Model Bounding Box after you check or uncheck Ignore
Wireframe Geometry in Bounds Computation.
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Ignore Wireframe geometry —un-checked

[T] Related Topics
Stock Menu
Create Part Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.2 Part Box Stock

ﬁ Stock -/ You can define the raw stock model as a bounding box of the XYZ extents of
geometry of the part model. You can then define offsets in any of the three
coordinate directions to apply to the computed bounding box.

D:I To Access this Command:

Ikclick:. Project > ﬁ Stock "/5 part Box Stock ...

D:I Part Box Stock menu item

© 2026 MecSoft Corporation




52 RhinoCAM 2026 G-Code Editor Reference

Project 2 gF @
‘:‘ﬁ Stock |~ _l Load 3 Merge Files EEEK‘r'Instance
Box Stock .. ransform [,_l—_l] Save
Part Box Stock ... lInstance | % Output
Cylinder Stock... File Operations

Part Cylinder Stock ...

Delete Stock
[l§ ToorLibrary

L J’ T ool Humbers

e M PR Necoded-haas-Seb

G-Code Browser: Part Box Stock menu item

[T] Dialog Box: Part Box Stock

The system calculates the bounding box of the part model as the XYZ extents of
geometry of the part model. You can then define offsets in any of the three coordinate
directions to apply to the computed bounding box. The system will expand the bounding
box by the offset amount in each of the coordinate directions. When you click on the OK
button, a stock model based on your definition will be created and displayed.
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Part Bounding Box Stock >
Stock Geometny

£ offset (z)

X offset (x)
¥ offset (v)

Offzetz
=] =] =]
J I < IR AT = N2 LI =
Z Offzet Direction
(®) Both +7 and = (042 Orily () Z Only

[] Ignare Wireframe Geometry in Bounds Computation

| k., || Cancel || Help

Dialog Box: Part Box Stock

1] Ignore Wireframe Geometry in Bounds Computation

Check this to ignore all 2D and 3D curve geometries present in the part from stock

bounding box computation.

53

Ignore Wireframe geometry - checked

Ignore Wireframe geometry —un-checked

1] Related Topics
Stock Menu
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Create Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.3 Cylinder Stock

f-‘ﬁ Stock ~| You can define the raw stock model as a simple cylinder by selecting this option.
When creating a cylinder stock, the axis of the cylinder is automatically set to the
World Z Axis unless you select a different axis from the dialog.

[T] To Access this Command:

(% click: | Preject |, |99 Stock - > Cylinder Stock ...

[T] Cylinder Stock menu item

Project o & @
‘:“ﬁ Stock |~ _L Load J Merge Files Eggx‘r’lnstance
Box Stock .. ransform [LT_I] Save
Part Box Stock ... lInstance | % Output

Cylinder Stock... File Operations

| Part Cylinder Stu:u:ln:..l.}’

Delete Stock
[lg ToorLibrany

_12__| J’ Tool Mumnbers

= % PPG-Decoded-haas-Setup 1.nc
m |8

G-Code Browser: CylinderStock menu item

[T Dialog Box: Cylinder Stock

You can define the cylinder by simply selecting the axis of the cylinder (either X Y or Z),
specifying the center coordinates by typing in the values or graphically picking the center
and then by specifying the radius and the length of the cylinder.

The Center (origin) of the stock can also be repositioned by specifying the coordinate
values in the corresponding edit boxes in the dialog (Xc, Yc, Zc). When you click on the
OK button, a stock model based on your definition will be created and displayed. You can
switch to the Simulate tab of the browser window to display the stock model that was
created.
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Create cylindrical stock model >

Stock Geometny

Axis

Center

(Ke.YxZc) Radius
iz
@ Oy 0oz
Center
i JE v e s
Dimengsians

| grore Wireframe Geometry ; .
] in Bounds Computation Copy kModel Bounding Cylinder

Cancel Help

Dialog Box: Cylinder Stock

[T Copy Model Bounding Cylinder

55

User can also select Copy Model Bounding Cylinder to determine the smaller possible

stock model that fit the part geometry.

[T] Ignore Wireframe Geometry in Bounds Computation

Check this ignore all 2D and 3D curve geometries present in the part from stock bounding

cylinder computation.

Make sure to click Copy Model Bounding Cylinder after you check or uncheck Ignore

Wireframe Geometry in Bounds Computation.
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Ignore Wireframe geometry - checked Ignore Wireframe geometry —un-checked

[1] Related Topics
Stock Menu

Create Box Stock

Create Part Box Stock

Create Part Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.4 Part Cylinder Stock

fj Stock - You can define the raw stock model as a bounding cylinder of the XYZ extents of
geometry of the part model. You can then define offsets to apply to the computed
bounding box.

Dj To Access this Command:

%click:. Project |, |EJ) Stock -/, Part Cylinder Stock ...

[1] Part Cylinder Stock menu item
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Project 2 gF @
‘:‘ﬁ Stock |~ _l Load 3 Merge Files EEEK‘r'Instance
Box Stock .. ransform [,_l—_l] Save
Part Box Stock ... lInstance | % Output
Cylinder Stock... File Operations

Part Cylinder Stock ... %
Delete Stock

[l§ ToorLibrary

12]’ Tool Mumnbers

= % PPG-Decoded-haas-Setup 1.nc
F o7

G-Code Browser: Part CylinderStock menu item

[T] Dialog Box: Part Cylinder Stock

You can define the cylinder by simply selecting the axis of the cylinder (either X, Y or Z)
and defining the radial and the axial offset distances. The bounding cylinder will be
calculated and these offset values will be used to expand the cylinder in both the radial
and axial direction.

Additionally you can specify the axial offset to be applied in both the positive and
negative directions or only in the positive or only in the negative axial directions.
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Part bounding cylinder stock >

Stock Geometny

Axis

Radial Offset (r)

\

Axial Offset (a)

Az
@x Oy Oz

Dimensians

Radial Offset ()01 |12 dvial Offset () [0 |12

Auial Offzet Direction

{®) Both + and - i3+ Only (- Only

[ Igrore ‘wireframe Geometry in Bounds Computation

Cancel Help

Dialog Box: Part Cylinder Stock

[T] Ignore Wireframe Geometry in Bounds Computation

Check this to ignore all 2D and 3D curve geometries present in the part from stock
bounding cylinder computation.

When you click on the OK button, a stock model based on the part geometry and your
definition will be created. You can switch to the Stimulate tab of the browser window to
display the stock model that was created.
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Ignore Wireframe geometry - checked Ignore Wireframe geometry —un-checked

1] Related Topics
Stock Menu

Create Box Stock

Create Part Box Stock

Create Cylinder Stock

Stock from Selection

Delete Stock

5.2.1.5 Delete Stock

] Stock ~| Use this command to Delete the currently defined Stock model. If there is no stock
defined, Simulations will only show tool motions and not a cut material simulation.

D:I To Access this Command:

Iéclick:. Project | €39 Stock ~ > Delete Stock

D:I Delete Stock menu item
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Project 2 gF @
‘:*ﬁ Stock |~ i Load 3 Merge Files EEEK‘r'Instance
Box Stock .. ransform LJ—_J Save
Part Box Stock ... lInstance | % Output
I Cylinder Stock... File Operations

Part Cylinder Stock ...

Delete Stock
[l§ ToorLibrary Ib
1

L J’ T ool Humbers

= % PPG-Decoded-haas-Setup 1.nc
J’ Trnl

G-Code Browser: Delete Stock menu item
[T Related Topics

Stock Menu

Create Box Stock

Create Part Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Stock from Selection

5.2.1.6 Stock from Selection

a stock || You can define the raw stock model from the currently active selected 3-D geometry.
You can select 3D surfaces and/or meshes and then selects Stock from Selection
option from Create Stock Model under the Program tab in Machining Browser.

No dialog will be invoked but the system will use the selected geometry and create a triangulated
stock model. You can switch to the Stock tab of the browser window to display the stock model
that was created.

n Stock from Selection will fail to create stock if the selected
3D geometry is not a watertight model.

1] To Access this Command:

%click:. Project > ﬁj Stock 7|5 stock from Selection

[T] Stock from Selection menu item
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Project
[WH ﬂ Load ¥ Merge Files %EE #Y Instance
Box Stock .. ransform H Save
Part Box Stock ... Instance | % Output
i Cylinder Stock... File Operations

Part Cylinder Stock ...
Stock from selection %

Delete Stock

“ T Ty

------- 12 Tool Mumbers
= : G-CODE-EDIT QuickStartGuide.ne

........ v Taool #14

- v Taol #4

— v Taal #2

G-Code Browser: Stock from Selection menu item

1] Stock from Selection Example

61

You can switch to the Simulate tab of the browser window to display the stock model

that was created.

3D geometry selection for stock

Stock created from 3D geometry

[T] Related Topics
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5.2.2

Stock Menu

Create Box Stock

Create Part Box Stock

Create Cylinder Stock

Create Part Cylinder Stock

Delete Stock

Tool Library

I3 Library - Use this command to load a pre-defined Tool Library file (*.csv). You can save a Tool
Library (*.csv) file from the MILL module Save Tool Library command. When you
create your Tool Crib, the tools are selected from this Tool Library.

[1] To Access this Command:

%click:. Project | i Library ~ | 0ad

[ Tool Library menu item

Project

f‘_ﬁ Stock ~ —L Load

17 Library |~| @ Info

& & @

4 Merge Files B85 XY Instance

===

"'{ﬁ. Transform L_.—_J Save

Load = Z Instance |_‘.., Output
Edit G-Code File Operations
=] | Project

l_.‘y tachine
@ Stack,

Jg Tool Library
i
" %

G-Code Browser: Tool Library menu item

1] Procedure

1. Select Library from the Project tab of the G-Code Browser and pick Load.

2. The File Open dialog will display. Navigate to the Tool Library file and pick Open
to load it. The file extension must be *.csv. You can save a Tool Library (*.csv) file
from the MILL module Save Tool Library command.

3. The Tool Library is loaded.
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Tool Library

388 Va9 xH.LaeI

2T/ MWW

Name

375 4FL (2,550 Loc )
3754FL(1.150 Loc )
375 4FL ( 550 Loc )
375 2FL(1.180 Loc )
375 2FL (500 Loc )
3754 FL (1.050 Loc )
3122 FL (850 Loc )
2504 FL {750 Loc )
2502 FL { 750 Loc )

FRNTICI 4 Ol ~n

Tool Type
Mill
il
il
il
il
Mill
il
Mill
Mill

RN

Diameter

0.375
0.37%
0.375
0.37%
0.375
0.375
0.375
0.25

0.25

naR

Comer Radius

[=T= T = =]

01875
0.1875
0125
0.125

Taper Fute Length Tool Length ~ Tool ™
0 255 423 0
0 115 .05 0
0 0.95 15 0
0 1.18 .04 0
0 09 253 0
0 1.05 1.54 0
0 0.85 2 0
0 0.75 25 0
0 0.75 25 0 v
n no TR n
>

Cancel Help

A Tool Libraryisloaded

4. Selecting atool type icon from the menu at the top will display those tool types.

Tool Library

38 VVd9gx.LLIEI

S AR I SR

Name

1716 Dl
1/16-Dril
1/4-Drill
1/8-Drill

Tool Type
Diill
Dirill
Diill
Cirill

Diameter

0.0625
0.0625
0.25
0.125

Comer Radius
0

= = =]

Taper WHLITE Length Tool Length Tool #

0 25 4 0
0 115 275 0
0 1 3 0
0 1 3 0

Listing only Drill Tools

5. The default Tool Library (*.csv) files saved from the MILL module contains the
following data fields as shown in each column of the dialog. You can edit *.csv
files using an Excel compatible spreadsheet program.

Default Tool Data Fields Supported by the MILL Module are:

e Name
e Tool Type

e Diameter

e CornerRadius

e Taper

e Flute Length

e Tool Length

[T] Tool Library Toolbar

Tool Number
Tool Material
Spindle RPM
Cut Feed

Adjust Register
Cutcom Register

Comments

Select an icon from the toolbar to display only those tools.Displays the Online Help

system.
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Ball

Flat

Corner Rad

Vee

X

Chamfer

ax

Taper

e
aun

Thread

=

Face

Dove Tail

Fillet

G & )=

Lollypop

sy

* User Defined

Drill

Center Drill

= & 49

Ream

il
s

Tap

riL

Bore

i

RBore

J,j' Show All

[T] Related Topics
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User Interface
Project Tab
Stock Menu
Tool Crib

5.2.3 ToolCrib

_“[f Mumbers  Use this command to create a Tool Crib for the current Project. This will assign a
tool station number to each tool you load into the Tool Crib. Be sure to assign the
same Tools and Tool Numbers that are used in your g-code files.

[T] To Access this Command:

. .
Ikclick;_ Project | J 2} Numbers

[T] Tool Crib menu item

Project o & @
@Stl:uck = '.:. Load # Merge Files EEEX‘r’Instance

Library ~ @ Info 4, Transform Save
y v &
lL[r MNumbers &= Z Instance |_':f Cutput

Setup Numbers 'I:II|E File Operations

= rojec

3 b achine
[‘Ei Stock
m Tool Library
12"[r Tool Mumbers
= bl PPG-Decoded-haas-blog?
o Toom

21_2 Az Profiling [Duter].ne

G-Code Browser: Tool Crib menu item

(1] Procedure
1. Select Numbers from the Project tab of the G-Code Browser.

2. The Tool Crib dialog will display.
Select the Add Station button to grab a tool from the default Tool Library.
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B Tool Crib x

Stn # |Mame |Type |D‘iameter |Corner Ra...|Tap-er |Length|MateriaI |Comments | |

There are ne items to show,

Add Station ‘. Help

The Tool Crib dialog, Add Station button

3. The Tool Crib dialog will minimize and the Tool Library dialog will display. Select a
tool from the library and then pick OK. The selected tool will be assigned as tool
station #1 (i.e., Tool #1).

Tool Library H

/88 V@ ¥ LLeO =3 TNNRLR

Dizmster GomarHadius Taper Fiute Length Tool Length Tool #

Name 3
MME_

Dt |00625 |

/ lDil_ [o2s | I E R E R
T R O : I F N
& | Left-click + Hols

{to Drag a selection window)

Cancel Help

Select a Tool from the Library and pick OK.

4. You can use the icons on the right side of each Tool Station # to delete that station
or reassign a tool to that station.
Pick OK to accept the Tool Crib.

[T] Related Topics

User Interface

Project Tab
Stock Menu

Tool Library
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5.3 G-Code Pane
5.3.1 Load

+'Load Use this command to Load a g-code file into the G-Code Browser. You can load as many
g-code files as you wish and work with them from the Project tab of the G-Code
Browser. The example below shows three files loaded.

[T] To Access this Command:

Ikclick:. Project > 1| Load

Then use the File Browser to select a G-Code file to load.

The following G-Code file type extensions are supported:
GCODE Files (*.nc)

PIM Files (*.pirn)
All GCODE Files (*ng™ pirn ™ tap ™ g™ et " ompf " fng™iso; ™. one)
File Extensions Supported by G-Code Editor

[1] Load menu item

Project o i @
@Stu:uck = —_:_ Lead 3§ Merge Files Eﬁﬁﬂlnstance
11 Library ~ @ Infd s 'Z‘ Transform =g Save
4 od l.
! [ Numbers = 7 Instance | 5 Output
Setup G-Code File Operations

ERNS] Proiec
3 achine
ﬁ Stock,

H Toal Library
}:J' T ool Humbers
% PPG-Decoded-hazs-blog? 2 1_2 Axiz Profiling [Outer].ne ‘
- % PPG-Decoded-haas-blog?_Hole Profiling. no
[ Tool#2

Y PPG-Decodedhass-blog? Deep Dril.n ‘

G-Code Browser: Load g-code file menu item

[ Related Topics
User Interface

Project Tab
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Stock Menu

Tool Library
Tool Crib

Info

5.3.2 Info

@ Info Use this command to get Information about all of the g-code files that are currently
loaded into the Project of the G-Code Browser. Information includes file Name, Tool #,
# of GoTo motions, Estimated Machining Time and file Size.

[T] To Access this Command:

Ikclick:. Project > @ Info

[1] Info menu item

Project o & @
@Stl:uck = i Lead 3 Merge Files EEEK‘r’Instance
1 Library ~ @ Info 'ﬁ‘.qgg. Transfarm L—j Save
lL[r Mumbers f &= Z Instance |_':, Output
nfo
Setup G-C File Operations

= | Project

3 k achine
ﬁ Stock,

m T ool Librany
lzlir T ool Mumnbers

Y PPG-Decodedhaas-blog? 212 Axiz Profiling [Outer].qe
" PPG-Decoded-haas-blogZ_Hole Prafiing. ne
bl PPG-Decoded-haas-blog? Deep Drill.nc

G-Code Browser: Info menu item

[T G-Code Files Information Dialog
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Info *

Files Information

MName Tools #Hof GOTOs  Machine Time  Size
PPG-Decoded-haas-blog?_2 1_2 Axis Profi.. 1 28 .17 min 1 kbs
PPG-Decoded-+haas-blog?_Hole Profiingne 2 9 (.83 min 1 kbs
PPG-Decoded-haas-blogZ_Deep Drll ne 3 8 (.54 min 1 kbs
Setupotal 1.54 min
£ >
Print

Concal | | o

Files Information Dialog

[T] Related Topics

User Interface

Project Tab
Stock Menu

Tool Library
Tool Crib

Load

5.4 File Operations Pane
541 Merge Files

I MergeFiles Use this command to merge g-code files that are currently loaded into the Project
tab of the G-Code Browser. Merged files can be output as one g-code file using

the Output command.

[1] To Access this Command:

[ dlick: | Proieet |, ¥ Merge Files

(1] Merge Files menu item
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Project o @ @

ﬂ Stock - —L Load ":f Merge Files EEEK‘r'Instance
ibrary = | ¥ Info ransfg
Library ~ @@ Info " Transf

lL[r Mumbers == 7 Insta

Merge Files

Setup G-Code File Operations

= | Project

u M achine
[fi Stock,

m Tool Librany
12? Tool Mumbers

ol PPG-Decoded-haas-blog2 2 12 sz Profiling [Duter].ne
bl FFPG-Decoded-haas-blog?_Haole Profiling. ne
bl FPG-Decoded-haas-blog2 Deep Drill.nc

G-Code Browser: Merge Files menu item

D:l Procedure

1. From the Project tab of the G-Code Browser, press and hold the <Ctrl> key while
left-click selecting the g-code files that you want to merge.

Project o g @
[fi Stock - '.:. Load f'.f Merge Files ﬁég)(‘flnstance
11 Library - @ Info 'ﬁ"ﬁr Transform H Save
lﬁ_f Murnbers = Z Instance B; Output
Setup G-Code File Operations
= | Project

3 Machine
Ei Stock,

m Tool Library
12Tr Tool Mumbers

ol PPG-Decoded-haas-blog? 2 1_2 Axiz Profiling [Outer].ng
ol PPG-Decoded-haas-blog? Hole Prafiling. nc

ol FPG-Decoded-haas-blog?_Deep Drill.ne L} <Cirl> + @

G-Code Browser: Merge Files menu item

2. With the g-code files highlighted and selected, pick the Merge Files command
from the Project tab.
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Project o @ @
ﬂ Stock - —L Load ?f Merge Files EEEK‘r'Instance
13 Library = @ Info f"’% Transfc
lL[r Mumbers == 7 Insta

Merge Files

Setup G-Code File Operations

= | Project

y M achine
[fi Stock,

m Tool Librany
12? Tool Mumbers

ol PPG-Decoded-haas-blog2 2 12 sz Profiling [Duter].ne
bl FFPG-Decoded-haas-blog?_Haole Profiling. ne
bl FPG-Decoded-haas-blog2 Deep Drill.nc

G-Code Browser: Merge Files menu item

3. Inthe example above we have selected three g-code files to merge. The second
and third files are merged into the first selected file that appears in the Project.

Project o g @
8 Stock - i Load E‘f Merge Files ﬁég)(‘flnstance
11 Library - @ Info 'ﬁ‘é@; Transform H Save
lﬁ_f Murnbers = Z Instance B; Output
Setup G-Code File Operations

= | Project

3 Machine
Ei Stock,

m Tool Library
12Tr Tool Mumbers

wiz Profiling [Outer).nc

T Toolt s

Tool g2
ﬂf Tool #2

L1

The second and third files are merged into the first selected file that appearsin the
Project.

4. Because the first g-code file has now changed, it is flagged (at the red arrow in the
image above) to let you know that it has not yet been saved.
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5. A double-left-click on the g-code file will load it into the G-Code Editor for

viewing.

Edit | Simulate = o & @
é: Add Line #5 __ Delline®#s & Cut O Find.. 2 Print
f’*_‘f Insert Spaces {ﬂf Del Spaces Copy -ﬂ:? Replace.. |== Save
A Upper Case ’-iﬂ Lower Case - Paste ¥ Undo @ Info

1 % "
2y Qo

3 H1G40G49GE0

4;: ( BEGIN TCOCL LIST )

5 ( TOCL 14 - FARACEMILL-Z.5 INCH - DESC: 2Z.5C
g | TOOL 4 - FlatMill-1/2 INCH - DESC: 0.25C
3 (=, 2 — DRILL "7 IN - DFSC: Q5000 0OL»

The merged file isloaded into the G-Code Editor

6. When done editing the g-code file, select the Back to Project icon to return to the

Project tab.
Edit | Simulate =2 & @
1— . N — . . [ i e
:  AddLine#s _ Delline#s = Cut M Find. [pack o Project
AV Insert Spaces  AY Del Spaces > Copy -t:? Replace... | f= Save
8\ Upper Case '-iﬂ Lower Case - Paste k-'} Undo g Info
1 % -
2: 00
3 H1G40G45GE0
4 { BEGIN TOOL LIST )
S { TOOL 14 - FACEMILL-2.S5 INCH - DESC: 2.5C
& [ TOOL 4 - FlatMill-1,/2 INCH - DESC: 0.25C
1 L T00T,. 2 TILL-™f2 IM — mRSC: 0.5700 DI~

Back to Project menu item

7. When satisfied, select the Output icon to save the new edited g-code file.
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Mj PPG-Decoded-haas-blog2_2 1_2 Axis Profiling (Quter) ..  — O *
File Edit Format View Help

B A
01234

G4e G49 GEO

( STOCK SIZE: X2.125 Y2.125 2Z8.25 )

( BEGIN TOOL LIST )

( TOOL 1 - FlatMill:®.25 - DESC: ©.25880 DIA, 2 FL
( ENDOF TQOL LIST )

(2 1/2 Axis Profiling (Outer))

( Tool Diameter = 0.25 Length = 2.0 )

G280 T1 M6

518888 M3

GOAGEaX-1.2533Y-8.3524

G43768.25H1

The merged g-code file is displayed

[T] Related Topics

User Interface

Project Tab

Transform
Z Instance
XY Instance

Save

Output

5.4.2 Transform

ﬁﬁ,}. Transform = You can use this command to perform transformations on a selected g-code file.
The transformations include Move, Rotate, Mirror and Scale. Each method is
documented in the topics below. Each tab of the Transform dialog below includes an example.

1] To Access this Command:

%CHck' Project | ’3”43. Transform
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[T] Transform menu item

Project £y g8y @

["‘aStDck & i Load Jf Merge Files 888 XY Instance

[a]n]=]

1 Library ~ @ Info ﬁ’?’% Transform LJ—_J Save

! ]' Mumbers == 7 Ins e utput
Transform
Setup G-Code e Operatens

= " Project

l—‘y M achine
@ Stock,

ﬂ Tool Librany
lzlj' Tool Mumnbers
= ol PPG-Decoded-haas-blog2 2 12 sz Profiling [Duter].ne
[ Tooim
Tool #2

G-Code Browser: Transform menu item

[ Procedure
1. Select the g-code file from the Project tab that you wish to transform.
2. Select Transform from the Project tab menu. The Transform dialog will display.

3. Select the type of transformation to make by selecting the corresponding tap at
the top of the dialog (Move, Rotate, Mirror or Scale).

4. Complete the necessary data fields and then pick OK from the dialog to perform
the transformation.

5. The transformation is displayed in the graphics screen and the g-code file is
flagged for Output.

[ Transform dialog, Move tab

The Move tab of the Transform Toolpath dialog allows you to translate the toolpath by
specifying From and To points for the move. You can either specify these points by
coordinate entry in the corresponding edit fields or could graphically pick the points by
selecting the Pick buttons. Once the points are specified, selecting the apply button will
perform the move operation.
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Transform >

Move Rotate  Mimor Scale

x 1z
g
M v From Move To
) I R RN =
I O =R ) CH =
S o -
Fick From Paint Pick Tao Faint

MNumber of Copies III =
Cancel Help

Dialog Box: Transform Toolpath, Move tab

Move From
Enter the X,Y,Z coordinate values for the Move From point or select the Pick From Part
button to select a point from the model.

Move To
Enter the X,Y,Z coordinate values for the Move To point or select the Pick To Part button
to select a point from the model.

Number of Copies
You can also Copy the toolpath by entering the number of copies.

Example: The original g-code file is moved along the Y axis making 3 copies.
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-
Z L
Y
d >
X
L
Original G-Code Transfored (Moved with 2 copies) G-Code

[T] Transform Dialog, Rotate tab

Selecting the Rotate tab allows you to rotate the toolpath.

Transform X

Move Rotate  Miror  Scale

Btz |M w |
About{P] | Drigin ~|

Murnber of Copies III

Cancel Help

Dialog Box: Transform Toolpath, Rotate tab

]

4

Axis / About(P) / Angle
Rotation can be performed around any of the three principal axes. The angle of rotation
as well as the point and Axis of rotation can be specified.

The point of rotation could be one of the Origin, Center of the part, Minimum point of
the part and the Maximum point of the part.
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The Axis of rotation could be the X, Y or the Z Axis. You can specify any arbitrary rotation
Angle.

Number of Copies
You can also Copy the toolpath by entering the number of copies.

Example: The original g-code file is rotated about the Z axis by 45 degrees.

Fi

z
v (= ‘D
d >
g
5 5
Original G-Code Transfored (Rotated) G-Code

[ Transform Dialog, Mirror tab

Selecting the Mirror tab allows you to Mirror the selected toolpath.

Transform X

Move PFotate Mimor  Scale

kirrar Plane |5

[ ] Create Copy Fick Plane Faint

Cancel Help

Dialog Box: Transform Toolpath, Mirror tab

Mirror Plane
Select the Mirror Plane from the list (XY Plane, XZ Plane or YZ Plane).

Point (P)
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Select a Mirror Point (P) from the list (Origin, Center of the part, Minimum point of the
part) or enter the X,Y,Z coordinate values of the desired point.

You can also select the Pick Plane Point button to select a point from the model.

Create Copy
Check this box to create a Copy of the mirrored toolpath.

Example: The original g-code file is mirrored about the YZ plane keeping the original.

Original G-Code Transfored (Mirrored) G-Code

Transform Dialog, Scale tab

Selecting the Scale tab allows you to scale the selected toolpath. All scaling is performed
about the zero of the coordinate axes. You can optionally scale from a mm to an inch or
vice-versa or by specifying a scale factor. You can also scale the selections uniformly or
perform non-uniform scaling in each of the three principal axes.

© 2026 MecSoft Corporation



Project Tab

Transform >

Move Fotate Miror Scale

/

@ Scale Unitz: | I

() Unifarm Scaling () Man-Unifarm Scaling
% Geale Factor || - # Length 15 -
Y Scale Factor |1 Z Ylength 1.8 =

£ Scale Factar 1 £ Length 05722

Cancel Help

Dialog Box: Transform Toolpath, Scale tab

Scale Units
Select the Scale Units from the list (To Millimeters or To Inches).

Uniform Scaling
Select this option and then enter the uniform X,Y and Z scale factors.

Non-Uniform Scaling

Select this option and then enter the actual non-uniform X,Y and Z length values.

Example: The original g-code file is scaled by 1.5 times the size of the original.

Original G-Code Transfored (Scaled) G-Code

[ Related Topics

User Interface

Project Tab

79
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Merge Files

Z Instance
XY Instance

Save

Output

5.4.3 Zlnstance

+ Zlnstance You can create multiple Z level instances of the toolpath via this dialog. This can be
useful in situations where you are manufacturing multiple instances of the same
part or want to create multiple z levels of the original path.

[1] To Access this Command:

% Project 5 &= Z Instance

[T] Z Instance menu item

Project o i @
@Stu:uck = —_:_ Load 3 Merge Files Eﬁﬁﬂlnstance
T Library = @ Info ", Transform Save
| y i &
! [ Numbers = Z Instance |_':, Output
Setup G-Code 7 Instance 'lcns

= | Project

3 achine
fiﬂ Stock,

H Toal Library

}:J' T ool Humbers
= ol PPG-Decoded-hass-blog? 2 1_2 Axiz Profiling [Outer].ng
Toaol #1
\ 4

G-Code Browser: Z Instance menu item

[T] Procedure
1. Select the g-code file from the Project tab that you wish to Z Instance.

2. SelectZInstance from the Project tab menu. The Z Instance dialog will display.
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3. Enterthe ZSpacing and #in Z values and then pick OK from the dialog.

4. The g-code is instanced in the Z axis.

[T] Instance Toolpath in Z dialog

The g-code will be copied multiple times in the Z axis. Negative values can be specified
in the Z spacing. In this case the instances will proceed below the current location of the
toolpath.

Instance Toolpath in Z >

T
£ Spacing
1

Spacing
Z Spacing 025 = #inz E:

Cancel Help

Dialog Box: Instance Toolpath in Z Dialog

Spacing
Specify the Spacing between the toolpaths in the Z direction.

#inZ
Specify the total number of instances of the toolpath to create.

Example: The original g-code file is moved along the Y axis making 3 copies.

Original G-Code ZInstanced 4copies of G-Code

[ Related Topics
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User Interface

Project Tab

Merge Files

Transform
XY Instance

Save

Output

544 XY Instance

EEE ¥Y¥ Instance You can create multiple instances of the g-code using this command. This can be
useful in situations where you are manufacturing multiple instances of the same
part.

[T] To Access this Command:

%click:. Project

ooa
N XY Instance

[T] XY Instance menu item

Project o & @
@Stu:uck & —L Load jf Merge Files EEEK‘H nstance
11 Library = @ Info ﬁ"ﬁ;. Transform L—j Savi
- N : u Y Inst
1‘[I' Mumbers = ZInstance | 5 Out s
Setup G-Code File Operations

= | Project

3 kachine
ﬁ Stack,

m Tool Library
12"[r Toaol Mumbers

(=Rl PP -Decoded-haas-blog?_ 2 12 &xzis Profiling [Outer).nc

‘T Tool

[ Toois2

G-Code Browser: XY Instance menu item

[T] Procedure
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1. Select the g-code file from the Project tab that you wish to Z Instance.

2. SelectZInstance from the Project tab menu. The Z Instance dialog will display.
3. Enterthe ZSpacing and #in Z values and then pick OK from the dialog.
4

The g-code is instanced in the Z axis.

[T] Instance Toolpath in a Rectangular Array dialog

You can specify multiple instances in the X and Y directions in two different ways.
Instance Toclpath in a Rectangular Array >
¥ Spacing

|<—>| X Spacing

Method Order
(®) Spaced () Fitted (®) = First (% First
Spaced

= Spacing 25 = finx 3 =

Y Spacing 5 = tiny E =
Fitted

#length 225 = Y Length 425 =

] I Cancel Help

Dialog Box: XY Instance Dialog

[T] Method = Spaced

Using the Spaced method, you specify the independent X Spacing and Y Spacing
values between the toolpaths.

The spacing is then used and applied to the bounding box of the part geometry as
shown in the picture on the dialog.

Enter the number of copies of the instanced toolpath using the #in Xand #in Y
values.

[T] Method = Fitted
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Using the Fitted method, you specify a rectangle in which the toolpaths will be
fitted by using the X Length and Y Length values.

The bounding box of the part geometry is considered when computing the number
of toolpaths that can be fitted in the specified space.

[T] Order
The order of the instancing can also be specified by selecting either X First or Y
First.

[T] Example

Example: The original g-code file is arrayed on the XY plane spaced 2.5 apartin X
and 5.0 apartin Y with a total of 3 copies in each direction.

&

F
X
Original G-Code XY Instance of G-Code

[T Related Topics

User Interface

Project Tab

Merge Files

Transform
Z Instance

Save

Output

54,5 Save

[u—_.] tave Use this command to Save a selected G-Code file to the Save Directory specified in the
Preferences dialog under Text Editor Preferences.

[1] To Access this Command:
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Ikclick:. Project > HSE"’E

[1] Save menu item
Project o & @

GStl:uck = i Load ﬁ Merge Files EEEK‘r’Instance
1 Library ~ @ Info '3".% Transfarm H Save

lL[r Mumbers = Z Instance |_':{ CE‘
' Save
Setup G-Code File Operatiorns

= | Project

3 k achine

ﬁ Stock,

m T ool Librany

lzlir Tool Mumbers

= ol PPG-Decoded-haas-blog2 212 Axiz Profiling [Outer].qe

 Tool
[ Tool#2
f Todlua

G-Code Browser: Save menu item

L] Procedure
1. Select one or more g-code files from the Project tab.

2. Select Save from the Project tab menu. The g-code files are saved to the Save
Directory specified in the Text Editor Preferences dialog.

This is the save directly by default:
C:\ProgramData\MecSoft Corporation\RhinoCAM 2023 for Rhino 7.0\Edited files\

[T] Related Topics

User Interface

Project Tab

Loa

o

=

nro

Merge Files

Transform
Z Instance

XY Instance
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Output

5.4.6 Output

| % Output  Use this command to Output a selected G-Code file to the program specified in the
Preferences dialog under Text Editor Preferences. For example it could be output to
another text editor or a DNC program to go directly to your CNC machine.

[T] To Access this Command:

%click:. Project > L= Output

[T] Output menuitem

Project £y g57 @

@Stu:uck & i Load Jf Merge Files B85 XY Instance

[a]=]=]

11 Library - @ Info ﬁ"ﬁ;. Transform L—j Save

! [ Mumbers &= Z Instance E, Output
Setup G-Code File Operations Outout
utpu

= | Project

3 kachine
@ Stack,

ﬂ Tool Library

12]' Tool Murnbers

(=Rl PP -Decoded-haas-blog?_ 2 12 &xzis Profiling [Outer).nc
T Taol#1
[ Tool#z

“r Tool 2

G-Code Browser: Output menu item

(1] Procedure
1. Selectag-code files from the Project tab.

2. Select Output from the Project tab menu. The g-code file is sent to the Program
to Output specified in the Text Editor Preferences dialog.

By default the Program to Output is set to notepad.

[T Related Topics

User Interface
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Project Tab

Loa

o

=

nro

Merge Files

Transform
Z Instance
XY Instance

Save

5.5 Right-Click Menu
5.5.1 Edit-G-Code-File

| Edit Use this command to Edit a G-Code file that is currently loaded into the Project
tab of the G-Code Browser.

[T] To Access this Command:

(i

i e ', -y :
Ikclick:. Project s T Lead| S\ S 1A Edit

[T] Right-Click Menu
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Project LA @

@Stu:uck & —_:_ Load Jf Merge Files B85 XY Instance

[a]=]=]

I Library - @ Info ﬁ"ﬁg_ Transform L.T_J Save

! [ Mumbers &= 7 Instance |_: Cutput
Setup G-Code File Operations

= | Project

3 b achine
@ Stack

ﬂ Tool Library
12]' Tool Murnbers
[SENRE G-C00E-EDITQuickStartGuide. ne

T Toolth14 | Edit
!
Tool #4 @ Simulate
[ Toolt2 @ Info
|& Delete

G-Code Browser, Project Tab

[1] Procedure

1. Select a G-Code file thatis currently loaded into the Project tab of the G-Code
Browser.

2. Right-click and select Edit from the menu.
3. The G-Code file is loaded into the Edit tab of the G-Code Browser.

[T] Related Topics
Edit-G-Code-File

Simulate G-Code File
Info on G-Code File
Delete G-Code File

5.5.2 Simulate G-Code File

@ Simulate Use this command to Simulate a G-Code file that is currently loaded into the
Project tab of the G-Code Browser.

[1] To Access this Command:
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[ click: | Proiect |47 Load |,/ , [ [B] Simulate

[T] Right-Click Menu
Project o & @
ﬁStu:uck = —L Load ¥ Merge Files Eﬁﬁﬂlnstance

'ﬂ'j Library ~ @ Info ﬁ"ﬁ; Transform H Save
lv Mumbers = £ Instance |_',r Output

Setup 5-Code File Operations

= | Project

3 k achine
[‘Ei Stock,

m Toal Library
12Tr Tool Mumbers
=] ol G-CODE-EDITQuickStartGuide. ne

[ ool |%  Edit
Tool #4 @ Simulate
[ Tool#2 @ Info
|& Delete

G-Code Browser, Project Tab

UJ Procedure

1. Selecta G-Code file thatis currently loaded into the Project tab of the G-Code
Browser.

2. Right-click and select Simulate from the menu.

3. The G-Code file is loaded into the Simulate tab of the G-Code Browser.

[ Related Topics
Edit-G-Code-File

Simulate G-Code File

Info on G-Code File

Delete G-Code File
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5.5.3 Info on G-Code File

0 Info Use this command to display Information about a G-Code file that is currently
loaded into the Project tab of the G-Code Browser.

1] To Access this Command:

=

Ikclick:. Project | /7| Load |, \J , @ Infe

[ Right-Click Menu

Project £ G5y @

@Stu:uck & —_:_ Load Jf Merge Files 888 XY Instance

[a]n]=]

I Library ~ @ Info l?"qie Transform L—j Save

! ]' Mumbers &= 7 Instance |_':, Cutput
Setup 5-Code File Operations

= | Project

3 b achine
ﬁ Stock,

ﬂ Tool Library
12'J' Tool Mumnbers
[SENRE G-CO0E-EDITQuickStartGuide. ne

[ Tool#4 | Edit
Tool #4 @ Simulate
f Tooluz @ Info
|& Delete

G-Code Browser, Project Tab

LU Procedure

1. Select a G-Code file thatis currently loaded into the Project tab of the G-Code
Browser.

2. Right-click and select Info from the menu.

[ Related Topics
Edit-G-Code-File

Simulate G-Code File
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Info on G-Code File

Delete G-Code File

5.5.4 Delete G-Code File

|& Delete

91

Use this command to Delete a G-Code file that is currently loaded into the

Project tab of the G-Code Browser.

[T] To Access this Command:

=

IS dlick: | Preieet | 1% Load | \\J . | |& Delete

1] Right-Click Menu

Project

o i @

@Stl:uck = —_:_ Load 3§ Merge Files B85 XY Instance

[=la]=]

I Library ~ @ Info l";'qge Transfarm L—j Save

lL[r Mumbers &= Z Instance |_':, Cutput
Setup G5-Code File Operations
= | Project

3 b achine
[‘Ei Stock

m Tool Library
12"[r Tool Mumnbers

= Bl G-CODE-EDITQuickStartGuide. nic

[ Tool#4 |%  Edit
Tool #4 @ Simulate
f Toolnz 0 Info
|& Delete

G-Code Browser, Project Tab

UJ Procedure

1.

Select a G-Code file that is currently loaded into the Project tab of the G-Code

Browser.
Right-click and select Delete from the menu.

The G-Code file is removed from the Project tab.
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[T] Related Topics
Edit-G-Code-File

Simulate G-Code File

Info on G-Code File

Delete G-Code File
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Edit Tab

Edit

When you double-left-click on a G-Code file from the Project tree, that file is loaded into

“the G-Code Editor. The Edit tab contains commands to Modify and Navigate the g-code
file. The Edit tab and commands are listed below.

[1] To Access this Command:

Ikclick:. Project > 17| Lead o

[1] Edit tab

Edit Simulate

i Add Line #s
f’*_‘f Insert Spaces
A Upper Case

~_ DelLine#s
{ﬂf Del Spaces

’-iﬂ Lower Case

Edit

o Cut

= & @

M Find...

“e= Print

I ¢

= Copy ¢Replace... b Save

% Paste ) Undo

g Info

3

1=
2 oo

3 N1G40G49GEO

4i ( BEGIN TOOL LIST )
5 { TOOL 1{ [ ————====
& ( TOOL 4| Bottom

7 { TOOL 2| %] Top

8 ( ENDOF | g poq

=] (Setup 1

100 (2 1/2 & 2. Spindle
11; H2Z(Tool | & Feedrate
2! N3G54

13 wagzoT1al ®  Cut

14. N5 510001 5:  Copy

15! MEGIOGOX; Paste

16 N7G4371.]

17i w2 Glaog|9®  Find..

18 M9 GO0 @1 Replace...
18! N10 G1Z1
20, W11 X252/ Undo
21 N1z G17
2743 GOR¥3I_4682Y-1.25I-F

“7& INCH - DESC: 2.5C
INCH - DESC: 0.25C
- DESC: 0.5000 DIZ

Length = 2.0 )

“14J1 .

G-Code Browser, Edit Tab

[1T] Ribbon Bar Options

Edit

.Contains file Edit related commands.
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“ Returns to the Project tab.
N I e .
Minimizes and maximizes the ribbon bar menu.

b Displays the Preferences dialog.

@

Displays the Online Help system.

L] editTab

- o
i AddLine®s Aq4 |ine numbers to the g-code file.

AV . ..
4 Insert Spaces | oot spaces (i.e., delimiters) between g-codes.

A UpperCase conyert g-code to all UPPERCASE text.

— Delline®s noete line numbers from the g-code file.

AV . .
2% DelSpaces polete spaces (i.e., delimiters) between g-codes.

g1 Lower Case c5nvert g-code to all lowercase text.

il Cut the selected text to the clipboard.

= CPP¥ copy the selected text to the clipboard.

W
.F‘ast;

Paste the selected text to the current cursor location.
@ Find... Find text within the G-Code file.
<7 Replace.. £ing & Replace text within the G-Code file.
)
Undo

-

Undo the last command.
== Print pint the G-Code file currently loaded in the editor.
B save - Save the G-Code file currently loaded in the editor.

@ Info Display information about the current g-code file.

[1] Edit Tab, Right-Click Menu

dkd  Botiom Go to the Bottom (End) of the G-Code file.
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4 Top Go to the Top (Start) of the G-Code file.
' Tool Go to the next Tool Change code.
2 - )
——— Go to the next Spindle code.
3 Feedrate Go to the next Feedrate code.
Se— Cut the selected text to the clipboard.
Copy :
2 Copy the selected text to the clipboard.
Paste Paste the selected text to the current cursor location.
R — Find text within the G-Code file.
¥A  Replace... . i .
Find & Replace text within the G-Code file.
) Unde

Undo the last command.

1] Edit Tab, Display Toolbar

26 %3.5

27 y0.25

28 x-3.5

300 %35 v
< >
86 12 [ ]

Display Toolbar

==
&é Stock Model Visibility: Turn on/off stock model
=
@—l‘ Part Model Visibility: Turn on/off part model display during simulation.
]
% | Toolpath Visibility: Turn on/off toolpath display
(e

Follow Toolpath Display: The toolpath is displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath after the tool passes.
(]

Trace Toolpath Display: The toolpath is not displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath before the tool passes.
|T|

Segment Toolpath Display: The toolpath is only displayed for the segment that the
tool is currently on.

[T] Related Topics
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6.1

Project Tab
Project Tree

Simulate Tab

Online Help

Add Line Numbers

1
3

¢ AddLine#s Use this command to Add Line Numbers to the g-code file. Comments are not

assigned line numbers. These line numbers are included when you save or output
the g-code file. The line numbers you see to the far left are for reference within the G-Code

Editor only and are notincluded in the g-code file.

[T] To Access this Command:

T k - = i
%click:_ Project 57| Load o Edit 5 i_ AddLine#s

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the

Project tab.

[1] Add Line # menu item

Edit | Simulate = a @ @
é: Add Line # __ Delline®#s & Cut O Find... L Print
‘E’: Insert Space f’_ﬁ; Del Spaces = Copy ¢ Replace.. i_:i Save
s Upper Car Case [ Paste ) Undo © Info

1 % "
2i H1 Q0
3 2 G40G49GE0

BEGIN TOOL LIST )

1

{ ENDOF TOOL LIST )
[(Setup 1)
(2 1/2 Awis Facing)

| o
S N )

Lo I P |

M4 G54

G-Code Browser: Edit G-Code tab, Add Line #menu item

[T] Procedure

(Tool Diameter = 2.5 Length = 2.

TOOL 14 - FACEMILL-2Z2.5 INCH - DESC: 2.5C
TCOL 4 — FlatMill-1/2 INMCH - DESC:
TOCL 2 - DRILL 1/2 IN - DESC: 0.5000 DIr

0.25C

}
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1. Select Add Line #is from the Edit tab. This will insert consecutive line numbers at
the beginning of every line that contains g-code. Note that comments are not
numbered.

[T] Related Topics
User Interface
G-Code Browser

G-Code Edit Tab

Delete Line Numbers

Insert Spaces

Delete Spaces
Make Upper Case

Make Lower Case

Show G-Code Info

6.2 Insert Spaces

4% |nsert Spaces Use this command to Insert Spaces between g-codes. These are also referred to
as "delimiters". One space is inserted between each g-code. An example of
inserted spaces is shown in the example below.

[T] To Access this Command:
%click:. Project > +'| Load > Edit S AV Insert Spaces

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[ Insert Spaces menu item
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Edit | Simulate = o @
é: Add Line #s __Delline®#s & Cut O Find.. £ Print
AV |nsert Spaces | AY Del Spaces = Copy tjr" Replace... i_:i Save
4 U ErCaselj' Case [ Paste Undo Info
A Lpr Insert Spaces ) °

1 % ~
2 H1 00

3 HZ 40 G45% G880

4 [ GIN TOOL LIST )

3 L 14 - FRACEMILL-Z2.5 INCH - DESC: 2.5C

[ 0L 4 - FlatMill-1/2 INCH - DESC: 0.25C
({ TOOL 2 - DRILL 1/2 IN - DESC: 0.5000 DIE
{ ENDOF TCOOL LIST )
[(Setup 1)
10f (2 1/2 BAxis Facing)

(Tool Diameter = 2.5 Length = 2.0 )
H4 4554

0.-T13 M

G-Code Browser: Edit G-Code tab, Insert Spaces menu item

=1

W o

| £ T 1

[T] Procedure

1. SelectInsert Spaces from the Edit tab. This will insert one a space character
between all g-codes in the g-code file.

[T] Related Topics
User Interface
G-Code Browser
G-Code Edit Tab
Add Line Numbers

Delete Line Numbers

Delete Spaces
Make Upper Case

Make Lower Case

Show G-Code Info

6.3 Make Upper Case

“wy Upper Case Use this command to convert all alphabetic letters to Upper Case in the g-code file.
An example of this is shown in the menu example below.
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[T] To Access this Command:

%click:. Project > -_:_Luad > Edit > “w\ Upper Case

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[ Upper Case menu item

Edit | Simulate = o @@
é: Add Line # __ Delline®#s & Cut O Find... Lt Print
f‘*_‘f Insert Spaces {ﬂf Del Spaces = Copy ¢ Replace.. I_:I Save
‘A Upper Case "4sy Lower Case : Paste ) Undo © Info

Upper Case
1 % "
2i N1 00
3 N2 40 G448 G880
4: | BjGIN TCOOL LIST )
5 14 - FACEMILL-2.5 INCH - DESC: 2.5(

i
& ( T@OL 4 - FLATMILL-1/2 INCH - DESC: 0.25C
7 ( T®OL 2 - DRILL 1/2 IN - DESC: 0.5000 DIZ
& ( ENDOF TOOL LIST )
o (SETUP 1)
T W - T 0 You |

G-Code Browser: Edit G-Code tab, Upper Case menu item

1] Procedure

1. Select Upper Case from the Edit tab. This will convert all alphabetic letters to
Upper Case characters in the g-code file.

[T] Related Topics
User Interface
G-Code Browser
G-Code Edit Tab
Add Line Numbers

Delete Line Numbers

Insert Spaces
Delete Spaces

Make Lower Case

Show G-Code Info
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6.4

Delete Line Numbers

__ Delline#s Use this command to Delete Line Numbers in the g-code file. Comments are not
assigned line numbers. Line numbers, if displayed, are included when you save or
output the g-code file. The line numbers you see to the far left are for reference within the G-

Code Editor only and are not included in the g-code file.

[1] To Access this Command:

[ click: | Project |47 Load | Edit | |7 DellLine#s

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the

Project tab.

[T] Delete Line # menu item

Edit | Simulate = o @ @
é: Add Line #= ~_ DelLine#s e, Cut M Find... = Print
AV |nsert Spaces | 4V Del SpacEjﬂy tjr" Replace... i_:i Save
| Del Line #s
‘w4 Upper Case "y Lower C i Jte h:'} Undo @ Info

% ~
oo

=40 G495 G80
( BEGIN TOOL LIST )

[ SO TR T o I S

i

=]

( ENDOF TOOL LIST )
(SETUE 1)
(2 1/2 BXIS FACING)

[
T N T v ]

54
G2 ™-Tl4d Mo

= =

-

;
T O R T Y T S

(TOOL DIAMETER = 2.5 LENGTH = 2

TOOL 14 - FACEMILL-2Z2.5 INCH - DESC: 2.5C
TCOL 4 - FLATMILL-1/2 INCH - DESC: 0.25C
{ TCOL 2 - DRILL 1/2 IN - DESC:

0.5000 DII

.0 )

G-Code Browser: Edit G-Code tab, Delete Line # menu item

[T] Procedure

1. Select Del Line #s from the Edit tab. This will remove all consecutive line
numbers from the beginning of every line that contains g-code. Note that

comments are not numbered.

[T] Related Topics

User Interface
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G-Code Browser
G-Code Edit Tab
Add Line Numbers

Insert Spaces

Delete Spaces
Make Upper Case

Make Lower Case

Show G-Code Info

6.5 Delete Spaces

4% Del Spaces  Use this command to Delete Spaces between g-codes. These are also referred to as
"delimiters". One space is deleted between each g-code. An example of deleted
spaces is shown in the example below.

[T To Access this Command:
%click:. Project | | Load >] EdE |, AV Del Spaces

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[T] Delete Spaces menu item
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Edit | Simulate = o & @
é: Add Line #s5 __Delline®#s & Cut O Find.. £ Print
AV |nsert Spaces | Y Del Spaces = Copy tjr" Replace... i_:i Save
“w Upper Case "4e1 Lower [ % Dacte ) Undo i@ Info

Del Spaces -
10 % ~
2i 00
3 (40G439G80
4 [ GIN TOOL LIST )
2 [ I. 14 — FACEMILL-Z2.5 INCH - DESC: 2.3C

( L 4 - FLATMILL-1/2 INCH - DESC: 0.25C
{ TOOL 2 - DRILL 1/2 IN - DESC: 0.5000 DIZ
( ENDOF TOOL LIST )

(SETUE 1)

10i (2 1/2 BXIS FRCING)

(TOOL DIRMETER = 2.5 LENGTH = 2.0 )

G54
G20T14Mé
57.000M3

=1

W o

;
[ SO TR T o I S

Co= .

G-Code Browser: Edit G-Code tab, Delete Spaces menu item

[T] Procedure

1. Select Del Spaces from the Edit tab. This will remove all space characters
between all g-codes in the g-code file.

[ Related Topics
User Interface
G-Code Browser
G-Code Edit Tab
Add Line Numbers

Delete Line Numbers

Insert Spaces
Make Upper Case

Make Lower Case

Show G-Code Info

6.6 Make Lower Case

‘i) Lower Case Use this command to convert all alphabetic letters to Lower Case in the g-code file.
An example of this is shown in the menu example below.
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[T To Access this Command:
Iéclick:. Project 5|7 | Load Edit 5 ‘%) Lower Case

Note: To access this tab activate (i.e., double-left-click) on aloaded g-code file from the
Project tab.

LT—] Lower Case menu item

Edit | Simulate = o g @
é: Add Line #s —_ DelLine#s o Cut M Find... S Print
f‘_‘f Insert Spaces {ﬁf Del Spaces = Copy i.f? Replace... L:I Save
A Upper Case 427 Lower Case - Paste ¥ Undo i Info

1 % -
2: ol

3i g40g4SgB0

q begin tool list }

5 ool 14 - facemill-2.5 inch - desc: 2.5(C
& tool 4 - flatmill-1/2 inch - desc: 0.25C
7 [ tool 2 - drill 1/2 in - desc: 0.5000 die
] { endof tool list |}

S {setup 1}

108 {2 172 axi=s facing)

11 {tool diameter = 2.5 length = 2.0 }

121 g54

13

g20tldme

G-Code Browser: Edit G-Code tab, Lower Case menu item

[1] Procedure

1. Select Lower Case from the Edit tab. This will convert all alphabetic letters to
Lower Case characters in the g-code file.

[ Related Topics
User Interface
G-Code Browser

G-Code Edit Tab

Add Line Numbers

Delete Line Numbers

Insert Spaces
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Delete Spaces
Make Upper Case

Show G-Code Info

6.7 Cut Text

< cut| Use this edittool to Cut (i.e., delete) the currently highlighted text. The cut text is added
to your Windows clipboard and can be Pasted back into any g-code file within the G-Code
Editor or other Windows program that can display text.

[1] To Access this Command:
L

%click:. Project S i | Load 5| Edit S s Cut

or

% click: . Project |5 10 Load | Bt [ o Cut

[T] Cut Text (Right-Click Menu)
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Edit | Simulate = o & @
é: Add Line #s5 __Delline®#s & Cut O Find.. £ Print
AV |nsert Spaces | AY Del Spaces = Copy tjr" Replace... L:ISaxre
“w, UpperCase | g Lower Case - Paste ) Undo @ Info

1: % LS
2i o

3 g40g45g80

q { begin EDD‘”_“"" -

5 { tool 14 - & Bottom nch - desc: 2.5C
g6 [ tool 4 - | Y Top ich - desc: 0.25C
T [ Cool 2 - _r Tool desc: 0.5000 die
] [ endof tog oo

g9 (setup 1) 2 Spindle

10 (2 172 axis '=5 Feedrate

11 [tool diames n=2.0)

121 g54 o Cut

13 g20tcl4dme o Copy

14; s1000m3 Past

15 g90gOx-2.50 aste

16 g43z1.25h14 & Find.

17 gla®0.£300. s Replace..

181 gO

19 glzl.f29.33 ) Undo

20 x2.5014f14-~/7

G-Code Browser: Edit tab, Cut Text (Right-Click Menu)

[T] Procedure
1. Use the mouse cursor left-click-drag to highlight the text you wish to remove.

2. Select Cut from the Edit tab or right-click and select Cut from the menu and the
text is removed and added to the Windows clipboard.

[ Related Topics

User Interface

Project Tab
Project Tree
Edit Tab

Copy Text
Paste Text
Undo Last Edit
Print G-Code
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Save G-Code
6.8 Copy Text

‘. copy| Use this edit tool to Copy the currently highlighted text. The copied text is added to

your Windows clipboard and can be Pasted back into any g-code file within the G-Code

Editor or other Windows program that can display text.

[T] To Access this Command:

%click:. Project |7 Load|, | Edit | 8/, =y Copy

or

-

Ikclick:. Project |, 7| Load | Edit ||~ Copy|

[T Copy Text (Right-Click Menu)

Edit | Simulate = o g @
é: Add Line #s __Delline®#s & Cut O Find.. <t Print
f’*_‘_f’lnsert Spaces {ﬁf Del Spaces = Copy ¢Replace... EISaxre
A Upper Case ’-iﬂ Lower Case - Paste ¥ Undo i Info

1 %
2: ol
3i g40g4SgB0
4 |{ begin tool| .
Bott
S5 tool 14 - | & PORem ch - desc: 2.5C
Ll
& { tool 4 - £] 11 Top h - desc: 0.25C
7 { tool 2 - di l]' Tool esc: 0.5000 dies
] { endof tool 2 .
9 (setup 1) ¥  Spindle
108 {2 1/2 axis | £ Feedrate
11 {tool diamet = 2.0}
12 g54 “f Cut
13 g20tl4mé : Copy
14 s1000m3 . Paste N
15, g890g0x-2.501; ,
16 g43z1.25h1g | Find.
178 glaS0.£300. | A Replace.
18 g0 k) Unde
1% gl=zl1.£25.334
20 =x2.5014f14.667
21 e

G-Code Browser: Edit tab, Copy Text (Right-Click Menu)
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(1] Procedure
1. Use the mouse cursor left-click-drag to highlight the text you wish to copy.

2. Select Copy from the Edit tab or right-click and select Copy from the menu and
the text is copied to the Windows clipboard.

[T] Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Cut Text
Paste Text
Undo Last Edit
Print G-Code
Save G-Code

6.9 Paste Text

Use this edit tool to Paste the contents of the Windows clipboard into the g-code file at
- | the location of the cursor.
Paste

[1] To Access this Command:

(I
. k . | |
%click:. Project S i | Load 5| Edit NS Paste
or
L
Paste

(% click: | Preject |17 Load |, | Edit |

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file.

[T Paste Text (Right-Click Menu)
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Edit | Simulate = o & @
é: Add Line #= ~_ DelLine#s e, Cut M Find... = Print
AV |nsert Spaces | AY Del Spaces = Copy tjr" Replace... i_:iSave
“w Upper Case ‘21 Lower Case > Paste J"} Undo @ Info

1: % LS
2i o

3 g40g45g80

4 { begin tc'”_‘l_ N

5 { tool 14 | & Bottom inch - desc: 2.5C
g6 [ tool 4 448 Top inch - desc: 0.25C
T [ cool 2 - - desc: 0.5000 die
8 [ endof tcC 'r Toal

o (setup 1) | % Spindle

100 (2 1/2 ax1 £ Feedrate

11 (tool diam jth = 2.0 )

121 g54 o Cut

13 g20tcl4dme o Copy

14; s1000m3

15 g90qgox-z.q = Paste %

16 g43=z1.25hl & Find.

17; gla90.£300 4 Replace..

18! g0

19 glzl.f29.4 ¥} Undo

20; x2.5014f14 -g£67

G-Code Browser: Edit tab, Paste Text (Right-Click Menu)

[T] Procedure
1. Use the mouse to locate the cursorin the desired location.

2. Select Paste from the Edit tab or right-click and select Paste from the menu and
the textis inserted into the G-Code file at the cursor location.

[T] Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Cut Text

Copy Text
Undo Last Edit
Print G-Code
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Save G-Code

6.10 Find Text

¢ Find... Use this dialog to Find text within your gcode file. You can use additional optionsin
the Find dialog shown below.

[1] To Access this Command:

(% click: | Preject |17 Load |, | Edit | |o% Find..

or
=

%click:. Project 1] Load |, Edit .>-U->|ﬂ:| Find...

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file.

[1] The Find dialog

1 % LS

2: 00

3 HN1G40G4SGEO

4 [ BEGIN TOOL LIST )

LY { TCOL 14 - FACEMILIL-2.5 INCH - DESC: 2.5000 1

£ { TODL. 4 — FlatMill-1/2 INWNCH - DESC: 0.2500 D
Find >
Find What | TEOURICENS “| [ Findnext |

Options Direction Close

[ ] Match whole word only (") search Up

[ Match case (®) Search Down
T ’ HE GIASO . F300.

18 N9 GO

Use this dialog to Find text within your gcode file.

Find What
Enter the text you wish to find and then pick Find Next to locate it.

Find Next
Go to the next location of the text.

Options
e Match whole word only: Only complete words will be located.
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e Match case: Use case sensitivity: Only words that match the
upper/lower case will be located.

Direction

e Search Up: Search upwards in the g-code file.

e Search Down: Search downwards in the g-code file.

[T] Procedure

1. Select Find from the Edit tab or right-click and select Find from the menu. The
Find dialog will display.

2. Enterthe text to find and then pick Find Next.

[T] Related Topics

User Interface

Project Tab

Project Tree
Edit Tab

Cut Text

Copy Text

Paste Text

Find & Replace Text

Undo Last Edit
Print G-Code
Save G-Code

6.11 Find & Replace Text

£7 Replace.. Use this dialog to Find & Replace text within your gcode file. You can find and
replace all occurrences of text and use additional options in the Find & Replace

dialog shown below.

1] To Access this Command:

%click:. Project

or

Ikclick:. Project

S _l Load >

S _l Load >

Bdit | £7 Replace...

n

(5

Edit .>I'U'I> ¥# Replace...
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Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file.

[T The Find & Replace dialog

% A
oo
H1G40G49G30

{ ( BEGIN TOOL LIST )

i TOOL 14 - FACFMILI-2 5 THCH - DFESC- 2 SO0
Find & Replace X
Find Text | BEGIN TOOL LIST il | Find Mext
Replace With | ISToNS v| [ Replace |

Options Direction Replace Al

] Match whole word only i) search Up

[ Match caze (®) Search Down Jose

WTGISLL . 2001 T
N& GlAS0.F300.
=0

2 N33

=}
el

Use this dialog to Find & Replace text within your gcode file.

Find Text
Enter the text you wish to find and then pick Find Next to locate it.

Find Next
Go to the next location of the text.

Replace With
Enter the text you wish to replace with.

Replace
Replace the currently highlighted text with the text entered into the
Replace With field.

Replace All
Search the entire g-code file and replace all occurrences of the Find
Text with the text entered into the Replace With field.

Options
e Match whole word only: Only complete words will be located.

e Match case: Use case sensitivity: Only words that match the
upper/lower case will be located.

Direction
e Search Up: Search upwards in the g-code file.

e Search Down: Search downwards in the g-code file.

111
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[T] Procedure

1. Select Find & Replace from the Edit tab or right-click and select Replace from the
menu. The Find & Replace dialog will display.

2. Use the Find & Replace dialog shown above to complete the process.

[T] Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Cut Text

Copy Text
Paste Text
Find Text
Undo Last Edit
Print G-Code
Save G-Code

6.12 Undo Last Edit

E) Use this command to Undo the last edit made to the g-code file. You can repeat the
selection to Undo all edits made in the current session.
Undo

-

[T] To Access this Command:

L [

")
%click:. Project | /7] Load | Edit _>'\_/'>|":1 Unda

or

)

Project 2 Edit | _ [
%click:. roject |5 ¢ |Lead| | EAEL [ T~

[T] Undo Last Edit (Right-Click Menu)
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Edit | Simulate = o & @
é: Add Line #= ~_ DelLine#s e, Cut M Find... == Print
AV |nsert Spaces | AY Del Spaces ~ Copy -E:?Replace... FISaxre
“w Upper Case 41 Lower Case - Paste ) Undo @ Info

1: % LS
2i o
3 g40g45g80
q ( begin too™ = 7
S { tool 14 —-| = Bottom nch - desc: 2.50
& ( tool 4 — |4 Top ch - desc: 0.25C
T [ Cool 2 - n] Tool desc: 0.5000 diec
] [ endof too
% (zetup 1) ¥ Spindle
10! (2 1/2 axis| T Feedrate
11 ([tool diame h = 2.0 )
12 gs4 oy Cut
13 g20tl4me > Copy
14; s1000m3 ™ Paste
15 g90g0x-2.50
16 g43zl.25h14 & Find.
17: gla%0.£300. |¢| Replace...
18 g0
1% glzl.f£29.33 k) Unde b
A0 -SR] 414, 667

G-Code Browser: Edit tab, Undo Last Edit (Right-Click Menu)

[T] Procedure

1. Select Undo from the Edit tab or right-click and select Undo from the menu. The
last edit will be undone.

[T] Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Cut Text

Copy Text

Paste Text

Find Text

Find & Replace Text
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Print G-Code
Save G-Code

6.13 Print G-Code

.t Print  Use this command to Print the current g-code file. The default Windows Print dialog
will display allowing you to select a printing device and print preferences.

[T] To Access this Command:

[ click: . Preiect |5 4% Load | Edit | 4k Print

Note: To access this tab activate (i.e., double-left-click) on aloaded g-code file from the
Project tab.

[T] Print menu item

Edit | Simulate = o g @
é: Add Line #s __Delline®#s & Cut O Find.. L Print
‘Ef': Insert Spaces {ﬁf Del Spaces = Copy i.f? Replace... i_:I
) - nnt
“wy Upper Case "4y Lower Case - Paste ¥ Undo D frre

1 % -
2: ol

3i g40g4SgB0

4 { begin tool 1list }

5 tool 14 - facemill-2.5 inch - desc: 2.5C

=]

{
[ tool 4 - flatmill-1/2 inch - desc: 0.25(
[ tool 2 - drill 1/2 in — desc: 0.5000 die

£

G-Code Browser: Edit tab, Print menu item

[T] Procedure

1. Select Print from the Edit tab. This will display the Windows Print dialog allowing
you to select a printer or device to print to.

[ Related Topics
User Interface
Project Tab
Project Tree
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Edit Tab

Cut Text

Copy Text
Paste Text
Undo Last Edit
Save G-Code

6.14 Save G-Code

= Save Select this command to Save the g-code file to the default Save Directory
defined in the Text Editor Preferences dialog. You original g-code file IS NOT

overwritten.

[T To Access this Command:
%click:_ Project | /4| Load |, | Edit | B save - > k= Save

Note: To access this tab activate (i.e., double-left-click) on aloaded g-code file from the
Project tab.

[1] Save menu item

Edit | Simulate = o 5 @
é: Add Line #5 __ Delline#s & Cut O®Find... L Print
AV Insert Spaces = AV Del Spaces > Copy i;:? Replace... H Save |~
W\ Upper Case | 'z Lower Case - Paste &) Undo I Save
B Saveas I'\"}
i % ~
2: Q0
3 HN1G40G45GE0
4 { BEGIN TOOL LIST )
5 { TOOL 14 - FALCEMTILL-2.5 INCH - DESC: 2.5000
& { TOOL 4 - FlatMill-1,/2 INCH - DESC: 0.Z2500
7 { TOOL 2 - DRILL 1/2 IN - DESC: 0.5000 DIA,
{

W TR T~ T.JST .}

G-Code Browser: Edit tab, Save menu item

[T] Procedure

1. Select Save from the Edit tab. This will save the g-code file to the default Save
Directory defined in the Text Editor Preferences dialog. You original g-code file
IS NOT overwritten.
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[T] Related Topics

User Interface

Project Tab

Project Tree
Edit Tab

Cut Text

Copy Text

Paste Text
Undo Last Edit
Print G-Code

6.15 Save As
k= Save Select this command to save the g-code file as another name. The Save As

dialog will display allowing you to select the save as folder and the name of the
saved file.

[T] To Access this Command:
Ikclick:. Project > 7| Load Edit S ESEVE s B Saveas

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

1] Save menu item
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Edit | Simulate = o & @
é: Add Line #5 __ Delline#s & Cut O® Find.. =L Print
AV |nsert Spaces | Y Del Spaces = Copy t‘ﬁ Replace... L:I Save | T
‘A Upper Case 47 Lower Case . Paste ) Undo b Save
B Saveas [}
1 % .«.
2i Q0
3 H1G40G439GE0
4 BEGIN TOCOL LIST )
5 TOOL 14 - FACEMILL-Z2.5 INCH - DESC: 2.500

!

!

( TOOL 4 - FlatMill-1/2 INCH - DESC: 0.2500
{ TOOL 2 - DRILL 172 IN - DESC: 0.5000 DIL,
{ ENDOF TOOL LIST )

[Setup 1)

10: (2 1/2 Axis Facing)

HZ (Tool Diameter = 2.5 Length = 2.0 )

o

-1

WEn

G-Code Browser: Edit tab, Save As menu item

[T] Procedure

1. Select Save from the Edit tab and then Save As. This will save the g-code file to
the folder of your choice.

[T] Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Cut Text

Copy Text
Paste Text
Undo Last Edit
Print G-Code

6.16 Show G-Code Info

# Info Use this command to display an information window of the current contents of the G-
Code Editor.
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[T] To Access this Command:

Ikclick:. Project > T Load o Edit > @ Info

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

1] Info menu item

Edit | Simulate = o g @
é: Add Line #5 __ Delline®#s & Cut O Find... Lt Print
f‘*_‘f Insert Spaces {ﬂf Del Spaces = Copy ¢ Replace.. I_:I Save
A\ Upper Case "4sy Lower Case - Paste ) Undo @ Info

Info
1 %
2: o0
3 g40g48g80
q { begin tool 1list )
5 [ tool 14 - facemill-2.5 inch - desc: 2.5(
o ({ cool 4 — flatmill-1/2 inch - desc: 0.25(

tool e in.-_des= QoA

G-Code Browser: Edit G-Code tab, Info menu item

1] Procedure
1. SelectInfo from the Edit tab.

2. This will display the Information dialog containing information related to the
current g-code file.

-

Info M

Files Information

MName Tools Hof GOTOs  Machine Time  Size

2AxisMethods-Z2_2 1_2 Axis Pocketing txt 1 303 18.35 min Tkbs

£ >
Print

Concad | | o

Information dialog
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[T] Related Topics
User Interface
G-Code Browser
G-Code Edit Tab
Add Line Numbers

Delete Line Numbers

Insert Spaces

Delete Spaces
Make Upper Case

Make Lower Case

6.17 Select Full Line

You can select the full line of code. To do so, first make sure Line Numbers are displayed by
selecting Add line #s from the Edit tab menu. Then select the line number displayed in the line
number column. This will select the full line of code. Refer to the example below.

[T] To Access this Command:
N [ 9 . = i -
%click:_ Project 5|7 Load o Edit 5 i_ AddLine#s

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

1] Info menu item
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Edit | Simulate = o & @

é: Add Line #s __Delline®#s & Cut &% Find.. L Print
AV |nsert Spaces | Y Del Spaces  Copy ¢ Replace... L:I Save ¥
4 UpperCase | ‘b LowerCase [ Paste k) Unde © Info

17: WS GlA%0.F300. L

18 NS GO

1% H10 G1Z21. F29.334

2 X2.5014 Fl4.667

= 12 17

2 GO03X3.4682Y-1.251-0.0014J1. +

2. 14 1X-3.4682

e GOZ2¥-3.5Y-1.I0.9682J0.25

2 G1¥-0.5

2 X3.5

0., ™5

G-Code Browser: Edit G-Code tab, Select Whole Line

6.18 Right-Click Menu
6.18.1 Go to Bottom

l] Bottom Use this command to move the cursor to the last g-code numbered line in the
g-code file.

1] To Access this Command:

=

%C“Ck:. PFD_]EI:t > Load > Edit _>'\_/' s | = Bottomn

[T] Bottom (Right-Click Menu)
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Edit | Simulate = o & @
é: Add Line #= ~_ DelLine#s e, Cut M Find... = Print
AV |nsert Spaces | AY Del Spaces = Copy tjr" Replace... L:ISave
“w Upper Case ‘21 Lower Case > Paste k—'} Undo @ Info

1: % LS
2i o

3 g40g45g80

4 [ begin tool list )

] [ cool 14 - facemill-2.5 inch - desc: 2.5(
€ ( tool 4|l Bottom inch - desc: 0.25C
T [ cool 2 N I}, - desc: 0.5000 die
5 ( endof f 11 TP

S (setup 1) _r Tool

10 2 ¥ 2 o

G-Code Browser: Edit tab, Bottom (Right-Click Menu)

1] Procedure

1. Select Bottom from the Edit tab. This will move the cursor to the last g-code
numbered line in the g-code file.

[T] Related Topics
Go To Bottom

Go to Top
Go to Next Tool

Go to Next Spindle

Go to Next Feedrate

Cut Text
Copy Text
Paste Text

Undo Last Edit

6.18.2 Go to Top

=L

Top Use this command to move the cursor to the first line in the g-code file.

[1] To Access this Command:
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. S — (@
%click:. Project | |7 | Lead|, | Edit | \g/, M1 Top
[T] Top (Right-Click Menu)

Edit | Simulate = o g @
é: Add Line #5 __ Delline®#s & Cut O Find.. L Print
‘E’:Insert Spaces {ﬂ;’ Del Spaces = Copy t;? Replace... i_:iSaxre
W UpperCase | ‘iz Lower Case % Paste ¥} Undo @ Info

1 % ES
2: od

3 g40g49gi0

- { begin | 1] Bottom

5 [ tool 1 .. T 5 inch - desc: 2.5C
_ 1 op o -

& [ tool 4 I}b ! inch - de=sc: 0.25C
7 | tool 2 Tool | - desc: 0.5000 diz
S0 ( endof | 2 Spindle

f: (zetup 1 T Feedrate

RS2 a8

G-Code Browser: Edit tab

[T] Procedure

, Top (Right-Click Menu)

1. Select Top from the Edit tab. This will move the cursor to the first line in the g-

code file.

[ Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Go to Bottom

Go to Next Tool

Go to Next Spindle

Go to Next Feedrate

6.18.3 Go to Next Tool

T Tool

contains a tool number.

Use this command to move the cursor to the next line in the g-code file that
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[T] To Access this Command:

%click:. Project | /7] Load|, | Bdit | NgJ, T Tool

1] Next Tool (Right-Click Menu)

Edit | Simulate = o & @
é: Add Line #5 __ Delline®#s & Cut O Find.. 2 Print
f‘_‘{lnsert Spaces {ﬂf Del Spaces = Copy t;? Replace... I_:ISEVE
A Upper Case ’-iﬂ Lower Case | Paste ) Undo @ Info

1 % ~
Zi ol
3l g40gap=so
4 ( beg 1Y Bottom
50 tool Y Top —2.5 inch - desc: 2Z.5C
& [ tool T Tool 1/2 inch - desc: 0.25(
7 too. s % in - desc: 0.5000 diz
5 ( end ¥ Spindle
9 (==ty 2 Feedrate

100 {2 1/]
A plell - = =

G-Code Browser: Edit tab, Next Tool (Right-Click Menu)

UJ Procedure

1. Select Tool from the Edit tab. This will move the cursor to the next line in the g-
code file that contains a tool number.

[T] Related Topics

User Interface

Project Tab

Project Tree
Edit Tab

Go to Bottom

Go to Top
Go to Next Spindle

Go to Next Feedrate
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6.18.4 Go to Next Spindle

£ Spindle Use this command to move the cursor to the next line in the g-code file that
contains a Spindle code.

1] To Access this Command:

@

%click:. Project .>—l|_.|_gad > Edit S ® Spindle

[T] Next Spindle (Right-Click Menu)

Edit | Simulate = o & @
é: Add Line #s __ Delline®#s = Cut O Find.. L Print
AV |nsert Spaces | AY Del Spaces = Copy {? Replace... i_:i Save
“u Upper Case ‘21 Lower Case > Paste k—"} Undo @ Info

1 % L
2i o

3 g40g45gi80

4i [ begin tdg k] Bottom

] { cool 14 | - Top inch - desc: 2.5(C
g | tool 4 - ° nch — desc: 0.25C
7 ( tool 2 4 T Tool - desc: 0.5000 diz

{ endof tg & Spindle

[

11 (tool diam ef Cut jthh = 2.0 )
i g5 _

UL N I )

[setup 1) o
10 (2 172 axi 3 Feedrate

G-Code Browser: Edit tab, Next Spindle (Right-Click Menu)

[T] Procedure

1. Select Spindle from the Edit tab. This will move the cursor to the next line in the
g-code file that contains a Spindle code.

[T] Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Go to Bottom

GotoTop
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Go to Next Tool

Go to Next Feedrate

6.18.5 Go to Next Feedrate

4 Feedrate Use this command to move the cursor to the next line in the g-code file that
contains a Feedrate code.

[T] To Access this Command:

. . ] (@
Iéclick:. Project S 7| Load > Edit NS 2 Feedrate
[T Next Feedrate (Right-Click Menu)

Edit | Simulate = o g @
é: Add Line #5 __ Delline®#s & Cut O Find.. L Print
AV Insert Spaces  AY Del Spaces > Copy {? Replace... Eiave
8\ Upper Case ‘21 Lower Case > Paste J"—'} Undo @ Info

1 % -
2i ol

3i g40g45g80

4 { begi .

s ( tool = Bettem 2.5 inch - desc: 2.5C
g { tood Top /2 inch - desc: 0.25C
7 [ tool T Tool in - desc: 0.5000 die
] | endc @ )

5 (setug ¥ Spindle

10; {2 1/2 & Feedrate

11 (tool Cut m length = 2.0 }

121 g54 il

17 g20y Ay Cpm

G-Code Browser: Edit tab, Next Feedrate (Right-Click Menu)

[1] Procedure

1. Select Spindle from the Edit tab. This will move the cursor to the next line in the
g-code file that contains a Feedrate code.

[ Related Topics

User Interface

Project Tab

© 2026 MecSoft Corporation



126 RhinoCAM 2026 G-Code Editor Reference

Project Tree
Edit Tab

Go to Bottom

GotoTop
Go to Next Tool

Go to Next Spindle

6.18.6 Cut Text

< cut| Use this edittool to Cut (i.e., delete) the currently highlighted text. The cut text is added
to your Windows clipboard and can be Pasted back into any g-code file within the G-Code
Editor or other Windows program that can display text.

[1] To Access this Command:
L

%click:. Project S i | Load 5| Edit S s Cut

or

[ click; . Projeet |5 20 Load |, | Edit [ | Cut

[T] Cut Text (Right-Click Menu)
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Edit | Simulate = o & @
é: Add Line #s5 __Delline®#s & Cut O Find.. £ Print
AV |nsert Spaces | AY Del Spaces = Copy tjr" Replace... L:ISaxre
“w, UpperCase | g Lower Case - Paste ) Undo @ Info

1: % LS
2i o

3 g40g45g80

q { begin EDD‘”_“"" -

5 { tool 14 - & Bottom nch - desc: 2.5C
g6 [ tool 4 - | Y Top ich - desc: 0.25C
T [ Cool 2 - _r Tool desc: 0.5000 die
] [ endof tog oo

g9 (setup 1) 2 Spindle

10 (2 172 axis '=5 Feedrate

11 [tool diames n=2.0)

121 g54 o Cut

13 g20tcl4dme o Copy

14; s1000m3 Past

15 g90gOx-2.50 aste

16 g43z1.25h14 & Find.

17 gla®0.£300. s Replace..

181 gO

19 glzl.f29.33 ) Undo

20 x2.5014f14-~/7

G-Code Browser: Edit tab, Cut Text (Right-Click Menu)

[T] Procedure
1. Use the mouse cursor left-click-drag to highlight the text you wish to remove.

2. Select Cut from the Edit tab or right-click and select Cut from the menu and the
text is removed and added to the Windows clipboard.

[ Related Topics

User Interface

Project Tab
Project Tree
Edit Tab

Copy Text
Paste Text
Undo Last Edit
Print G-Code
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Save G-Code

6.18.7 Copy Text

" Copy Use this edit tool to Copy the currently highlighted text. The copied textis added to

your Windows clipboard and can be Pasted back into any g-code file within the G-Code

Editor or other Windows program that can display text.

[T] To Access this Command:

Iéclick:. Project > 7 Lead o Edit > 52 Copy

or

™

Ikclick:. Project | 17 Load | Edit ||~ Copy|

[T] Copy Text (Right-Click Menu)

Edit | Simulate = o & @
é: Add Line #s __ Delline®#s = Cut O Find.. ot Print
AV |nsert Spaces | AY Del Spaces = Copy {?Replace... I_:ISaxre
“u Upper Case '-iﬂ Lower Case - Paste "-'} Undo 9 Info

1 % L
2i o
3 g40g45gi80
4: { begin tool| .
Bott
S tool 14 - | o ToRem ch - desc: 2.5C
_ﬂl-
o [ coocl 4 - £l Top h - desc: 0.25C
T [ cool 2 - 4 ‘]' Tool esc: 0.5000 die
g [ endof tool 9 .
o (setup 1) % Spindle
10f {2 1/2 axis | £ Feedrate
11 (ool diamet: = 2.0 )
12 gs4 ul Cut
13 g20tl4mé ;. Copy
14 =s1000m3 . Paste [
15! g90g0x-2.501 _
16, g43zl.25h14 |00 Find..
17: glaS0.£300. | A Replace.
18 g0 ) Unde
1% glzl.f£295.334
20; x2.5014fl4.667
51 -

G-Code Browser: Edit tab, Copy Text (Right-Click Menu)
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(1] Procedure
1. Use the mouse cursor left-click-drag to highlight the text you wish to copy.

2. Select Copy from the Edit tab or right-click and select Copy from the menu and
the text is copied to the Windows clipboard.

[T] Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Cut Text
Paste Text
Undo Last Edit
Print G-Code
Save G-Code

6.18.8 Paste Text

L Use this edit tool to Paste the contents of the Windows clipboard into the g-code file at
= | the location of the cursor.
Paste

[1] To Access this Command:

(iR
1 = B I |
% click: | Project |15 Load |, | Edit | 1), Paste
or
| 9
Paste

IS dlick: | Proiect | 1Y Load | Edit |

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file.

[T] Paste Text (Right-Click Menu)

© 2026 MecSoft Corporation



130 RhinoCAM 2026 G-Code Editor Reference

Edit | Simulate = o & @
é: Add Line #= ~_ DelLine#s e, Cut M Find... = Print
AV |nsert Spaces | AY Del Spaces = Copy tjr" Replace... i_:iSave
“w Upper Case ‘21 Lower Case > Paste J"} Undo @ Info

1: % LS
2i o

3 g40g45g80

4 { begin tc'”_‘l_ N

5 { tool 14 | & Bottom inch - desc: 2.5C
g6 [ tool 4 448 Top inch - desc: 0.25C
T [ cool 2 - - desc: 0.5000 die
8 [ endof tcC 'r Toal

o (setup 1) | % Spindle

100 (2 1/2 ax1 £ Feedrate

11 (tool diam jth = 2.0 )

121 g54 o Cut

13 g20tcl4dme o Copy

14; s1000m3

15 g90qgox-z.q = Paste %

16 g43=z1.25hl & Find.

17; gla90.£300 4 Replace..

18! g0

19 glzl.f29.4 ¥} Undo

20; x2.5014f14 -g£67

G-Code Browser: Edit tab, Paste Text (Right-Click Menu)

[T] Procedure
1. Use the mouse to locate the cursorin the desired location.

2. Select Paste from the Edit tab or right-click and select Paste from the menu and
the textis inserted into the G-Code file at the cursor location.

[T] Related Topics
User Interface
Project Tab

Project Tree
Edit Tab

Cut Text

Copy Text
Undo Last Edit
Print G-Code
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6.18.9 Undo Last Edit

131

E) Use this command to Undo the last edit made to the g-code file. You can repeat the
selection to Undo all edits made in the current session.

Undo

-

[T] To Access this Command:

%click:_ Project s> 7| Lead o Edit o

or

%click:_ Project s> 7| Lead o Edit o

[L] undo Last Edit (Right-Click Menu)

Edit Simulate

é: Add Line #5 —_ DelLine#s

f’*_‘f Insert Spaces {ﬂf Del Spaces

% UpperCase ‘b Lower Case

Undo
o @0
M Find... “om Print
o Copy i!:? Replace... FI Save
g Info

A

u> m Undo

)

o Cut

. Paste ) Undo

11 %
2: od
3 g40g49gi0
q { begin too
5 ([ tool 14 - =
g ( tool 4 — |ff
7 [ ool 2 - 7
] [ endof too
S (setup 1) %
108 (2 172 axis b
11 (tool diame
12i g54 i 1
13 g20tldme "
14 s1000m3 )
15 gf0g0x-2.50
16 g43z1._25hl4| OB
178 gla90.£300. qh
18 gO
19 gl=zl.f29.33 -
20i 2. BR]l4f14. 667

Bottom
Top

Teol
Spindle
Feedrate
Cut
Copy
Paste
Find...

Replace...

Undo L}

nch - desc:
ch - desc:

2.5C
0.25C

desc: 0.5000 dies

o
I
8]

.0 )

G-Code Browser: Edit tab, Undo Last Edit (Right-Click Menu)
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[T] Procedure

1. Select Undo from the Edit tab or right-click and select Undo from the menu. The

last edit will be undone.

[ Related Topics

User Interface

Project Tab

Project Tree
Edit Tab

Cut Text

Copy Text

Paste Text

Find Text

Find & Replace Text

Print G-Code
Save G-Code
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Simulate Tab

When you double-left-click on a G-Code file from the Project tree, that file is loaded
into the G-Code Editor. The Simulate tab contains commands to perform tool
motions and cut material simulations of the g-code file. The Simulate tab and commands are
listed below. Note: You must have Stock, Tool Library and Tool Crib defined before performing a
Simulation.

Simulate

[T] To Access this Command:

I}click:_ Project | 4| Load , | Simulate

[T] Simulate tab

Edit | Simulate = o & @
(3;1 Preferences g Play EI To End
» m Step ml Pause
Simulate by Mowves El Step Levels Dl Stop
Options Simulate
! A
0l234

[ R % T

J01 40 G458 G880
HOoZ  STOCE SIZE: X2.125 Y2.125 E0.

( BEGIN TOOL LIST )

( TOOL 1 - FlatMill:0.25 - DESC: 0.2300
([ TOOL 2 - FlatMill:0.1Z5 - DESC: 0.1250
{
{

ks
%]

=1

TCOL 3 — Drill: 1/4™ - DESC: 0.2500 DL
ENDOF TOOL LIST )

W o

10 (Setup 1)
11 J04 [(Work Zero)

005 G54

Ty,

G-Code Browser, Simulate Tab

1] Ribbon Bar Options

Simulat 1< file Simulati
MRS IContains file Simulation related commands.

Returns to the Project tab.
)| e .
Minimizes and maximizes the ribbon bar menu.

w Displays the Preferences dialog.
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@

Displays the Online Help system.

[T Simulate Tab, Options Pane

L@ Preferences pisplay Simulation Preferences.

Simulation speed adjustment (Left: Slow, Right: Fast).

Simulate by Moves . . .
41 g Check to simulate by moves. Uncheck to simulate by distance. See

Preferences to set the default mode.

1] Simulate Tab, Simulate Pane
DIPiay play the simulation.
L step Step through the simulation by distance or by moves.
& Step Levels Display simulation in Levels.

£ ToEnd Go direction to the End result of the simulation.

[/ Pause payse the simulation.

L] stop Stop the simulation.

1] Simulate Tab, Display Toolbar

26 x3.5

27 y0.25

2 ®x—3.5
£ >
%l%lw fz ke | R

Display Toolbar
3
Stock Model Visibility: Turn on/off stock model

&
Part Model Visibility: Turn on/off part model display during simulation.

[ 5]
% | Toolpath Visibility: Turn on/off toolpath display

Follow Toolpath Display: The toolpath is displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath after the tool passes.

© 2026 MecSoft Corporation



Simulate Tab 135

(4]
Trace Toolpath Display: The toolpath is not displayed as it follows the behind the
movement of the tool (i.e., you will only see the toolpath before the tool passes.

Segment Toolpath Display: The toolpath is only displayed for the segment that the
tool is currently on.

1] Related Topics
Project Tab

Project Tree
Edit Tab

Online Help

7.1 Simulate Options
7.1.1 Simulation Preferences

.;-'j';ﬂ Preferences  Select this button to display the Simulation Preferences dialog. This is the same as
i

selecting >Simulation.

[1] To Access this Command:

%click:_ Project o +"| Load 5| Simulate | ';_'iﬂ Preferences

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[T] G-Code Browser: Simulate tab, Preferences menu item

Edit | Simulate = o & @

(3;1 Preferences g Play EI To End
" m Step ml Pause
El Step Levels Dl Stop

Preferences
Simulate By

Options Simulate
-‘-]-I N4z (Hole Profiling) LS
49§ H4Z ( Tool Diameter = (0.125 Length = 2.0
'5| H44 G20 T2 HMe

51!

G-Code Browser: Simulate, Preferences menu item

[T] Procedure
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1. Select Preferences from the Simulate tab. This will display the Simulate
Preferences dialog.

Preferences >

User Interface Simulation Mode

Text Editor 0 simulate By Moves () Simulate By Distance
Toolpath

Min . Max
Stock Maximum Display Interval (# -

h 100
Cutting Tools of Moves Distance): 7
i ] Simulation Accuracy
Standard Medium Fine

Simulation tolerance: 0.01

Additional Options

|| Disable advanced OpenGL

Reset to Defaults Cancel Apply Help

Preferences >Simulation

2. Make desired changes and then pick Apply. Pick OK to close the dialog.

[T] Related Topics
Simulate Tab

Simulation Speed

Simulation Mode

7.1.2 Simulation Speed

" You can use this slider to adjust the simulation speed. Leftisslowerand
right is faster. You can set the default speed for simulations from the
Simulation Preferences dialog.

[1] To Access this Command:

%click:_ Project | 4| Load , | Simulate

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[ G-Code Browser: Simulate, Speed menu item
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Edit | Simulate = o & @
&;ﬂ Preferences g Play EI Tz End
m Step ml Pauze
Simulatep-—tde—e =l Step Levels DI stop
Simulation Speed
Optiore Simulate
-‘-]E H4Z (Hole Profiling) ~
49§ H4Z ( Tool Diameter = 0.125 Length = 2.0
2 ' H44 G20 T2 Me

G-Code Browser: Simulate, Speed menu item

1] Procedure

1. Left-click and drag the slider to adjust the Simulation Speed. Leftis slowerand
right is faster.

[T] Related Topics
Simulate Tab

Simulation Preferences

Simulation Mode

7.1.3 Simulation Mode

Simulate by Moves YOU can use this checkbox to Simulate by Moves. If unchecked, the
simulation is calculated by distance as defined in the Simulation
Preferences dialog.

[T To Access this Command:
. i % i Simulate by Mowes
%cllck:. Project ST Load S Simulate S [ ¥

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[T] G-Code Browser: Simulate, Mode menu item
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Edit | Simulate = o & @
@?1 Preferences g Play EI Tz End
] m Step ml Pause
| Simulate by Mowves % Step Levels DI stop
— Cleticer | Simulate
= Simulate by Moves
ree—prre——rrrerre Profiling) ~
49§ H4Z ( Tool Diameter = 0.125 Length = 2.0

= LR T Xy

G-Code Browser: Simulate, Mode menu item

[T] Procedure

1. Check the box to Simulate by Moves. Uncheck the box to Simulate by Distance.
The increment for moves and distance can be controlled from the Simulation
Preferences dialog.

[ Related Topics
Simulate Tab

Simulation Preferences

Simulation Speed

7.2 Simulation Controls

7.2.1  Play Simulation

E| Play Select this commend to Play the simulation. If Stock is defined, a cut material simulation
is displayed. If no Stock is defined only the tool motions is simulated.

1] To Access this Command:

bclick:_ Project s 7| Load Simulate | | Play

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[1] G-Code Browser: Simulate, Play menu item
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Edit | Simulate = o & @
J;ﬂ Preferences g Play EI Ta End
L ES mlpause
= | Play
Simulate by Moves &5 Stepmitels |[]] Stop
Opticns Simulate
-‘-]-I H4Z (Hole Profiling) ~
49§ H4Z ( Tool Diameter = 0.125 Length = 2.0
50 _N44 G20,.T2_ MF

G-Code Browser: Simulate, Play menu item

[1] Procedure

1. Select Play from the Simulate tab and the simulation will begin from the current
tool location.

[ Related Topics
Simulate Tab

Step Thru Simulation

Display Simulation Levels

Simulate to End

Pause Simulation

Stop Simulation

7.2.2 Step Thru Simulation

7] step  Select this command to Step through the simulation. Each step is determined by the
Simulation Mode. You can control this from the Simulation Preferences dialog.

[1] To Access this Command:

%click:. Project |, /7| Load , | Simulate | O step (with Simulation Window
displayed)

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[T] G-Code Browser: Simulate, Step menu item
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Edit | Simulate = o & @
@?1 Preferences | Play [ To End
" m Ste ml Pause
Simulate by Mowves = st Step Is |C]] Stop
Opticns simulate
-‘-]-I H4Z (Hole Profiling) ~
49§ H4Z ( Tool Diameter = 0.125 Length = 2.0
S ' H44 G20 T2 Me
5_ H45 G54
52 H4e 510000 M3
5747, GIOGNYO, 4375¥F 10002

——

G-Code Browser: Simulate, Step menu item

[T] Procedure

1. Select Step from the Simulate tab and the simulation will advance by one
increment. The increment is determined by the Simulation Mode. You can
control this from the Simulation Preferences dialog.

[T] Related Topics
Simulate Tab

Play Simulation

Display Simulation Levels

Simulate to End

Pause Simulation

Stop Simulation

7.2.3 Display Simulation Levels

& Step Levels If your toolpath has multiple Z levels, you can select this command to move the
tool to the end of each level. If Stock is defined, the cut material simulation at
each Z level is displayed.

[T] To Access this Command:

Iéclick:. Project > 7| Load simulate > = Step Levels

Note: To access this tab activate (i.e., double-left-click) on aloaded g-code file from the
Project tab.

[1] G-Code Browser: Simulate, Step Levels menu item
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Edit | Simulate = o @@
(-Iﬂ Preferences g Play EI To End
L m Step ml Pauze

Simulate by Mowves & StepLevels |[]] Stop

Options Step Levels l

455 H4Z2 (Hole Profiling) ~
49§ H4Z ( Tool Diameter = 0.125 Length = 2.0
53§ H44 G20 T2 HMe
51 N45 G54

Y L VI o

G-Code Browser: Simulate, Step Levels menu item

[T] Procedure
1. Select Step Levels from the Simulate tab and the simulation will advance to the
end of the current Z level.
[ Related Topics
Simulate Tab

Play Simulation

Step Thru Simulation

Simulate to End

Pause Simulation

Stop Simulation

7.24 Simulate to End

E| To End You can select this command to move the End of the simulation. If Stock is defined,
the final cut material simulation is displayed.

[1] To Access this Command:

%click:_ Project _>—_-__Lcrad > Simulate S ™Y To End
displayed)

(with Simulation Window

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[T] G-Code Browser: Simulate, To End menu item
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Edit | Simulate = o & @

&;ﬂ Preferences g Play EI To End
L m Step ml

Simulate by Moves EStEF' Levels _I o

Opticns Simulate
-‘-]E H4Z2 (Hole Profiling) ~
49§ H4Z ( Tool Diameter = 0.125 Length = 2.0
535 H44 G20 T2 Me
51 N45 G54
52i N4& S10000 M3
= ga T er T K. 4375y aea

G-Code Browser: Simulate, To End menu item

[T] Procedure

1. Select To End from the Simulate tab to move the End of the simulation.

[ Related Topics
Simulate Tab

Play Simulation

Step Thru Simulation

Display Simulation Levels

Pause Simulation

Stop Simulation

7.2.5 Pause Simulation

m| Pause You can select this command to Pause the simulation at the current tool location. If
Stock is defined, the cut material simulation is also paused.

[1] To Access this Command:

%click:_ Project 5|7 Load |, Simulate >m||:'ause

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[T] G-Code Browser: Simulate, Pause menu item
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Edit | Simulate = o & @
&;ﬂ Preferences | Play [ To End
" )] Step [M)| Papse
Simulate by Mowves % Step Levels |[] St Pause
Opticns Simulate
48; H4Z (Hole Profiling) ~
4% M43 ( Tool Diameter = 0.125 Length = 2.0
50 H44 G20 T2 Me
51; H45 G54
52i H4e 510000 M3
53 N47.GI0GOXQ, AM7EY0 00072

G-Code Browser: Simulate, Pause menu item

[T] Procedure

1. Select Pause from the Simulate tab to Pause the simulation at the current tool
location.

[ Related Topics
Simulate Tab

Play Simulation

Step Thru Simulation

Display Simulation Levels

Simulate to End

Stop Simulation

7.2.6 Stop Simulation

[ stop You can select this command to Stop the simulation at the current tool location. If Stock
is defined, the cut material simulation is also stopped.

[1] To Access this Command:

%click:. Project o 1 Load Sirnulate >D|Stc|-p

Note: To access this tab activate (i.e., double-left-click) on a loaded g-code file from the
Project tab.

[T] G-Code Browser: Simulate, Stop menu item
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Edit | Simulate = o & @
&';‘l Preferences | Play [ To End
] m Step ml Pause
Simulate by Mowves E Step Levels DI stop
.Optlcns Simulate Stop
-‘-lf H4Z (Hole Profiling) ~
-‘-19 H4Z ( Tool Diameter = 0.125 Length = 2.0
50! H44 G20 T2 Mé
51 H45 G54
52 W4~ 510000 M3

G-Code Browser: Simulate, Stop menu item

[T Related Topics
Simulate Tab

Play Simulation

Step Thru Simulation

Display Simulation Levels

Simulate to End

Pause Simulation
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Functions from the MILL Module

You can access the G-Code Editor module from within the MILL module by clicking on the G-Code
icon located in each machining operation (Mop) folder as shown below if the icon is not flagged.
However, ONLY the Edit tab is available and you cannot simulate G-Code.

[T] How G-Code is Stored

Your G-Code data is stored with your CAM part files. When you generate a toolpath
operation in the MILL module the G-Code related to that operation is stored with the
CAM part file. This means that you will always have access to the latest G-Code
generated for any operation.

[1] To Access G-Code from the MILL Module

To access the G-Code Editor from an operation that you have generated within the MILL
module simply click on the G-Code icon within the mop folder as shown below:

= Machining Job

y Machine - 3 Axis

iz Post - Haas

f‘ﬂ Stock - Box Stock

@ Fixtures - Mene

=-F&d Setup 1

E Haorizontal Roughing
Control Geometry
{ FLATMILL- 172 INCH
3 Feeds/Speeds

[ Clearance
Parameters

Toclpath
Y G-Code
f_ﬁj In-process Stock
Parallel Finishing
Radial Machining

G-Code Browser: Tool Crib menu item
The Machining Browser will be replaced with the Edit tab of the G-Code Editor as shown

below. To return to the MILL module pick the left arrow icon at the top of the G-Code
Editor browser as shown below.
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Edit = o & B
é: Add Line #s " DelLine#s = Cut & Find.. ot Print
AV |nsert Spaces | Y Del Spaces - Copy f;?‘ Replac EI Save
% UpperCase | ‘i Lower Case " paste k) Undo @ Info
i % "
2i 00
3 H1G40G435GE80
4 (Horizontal Roughing)
5 HZ(Tool Diameter = 0.5 Length = 5.0 )
i H3G54
Ti H4G20T1Me
i W5 58000M3
@ eEe0m0F N

G-Code Browser: Tool Crib menu item

© 2026 MecSoft Corporation



Find More Resources 147

Find More Resources

Download this PDF Guide for a list of the available RhinoCAM Resources.

[T] 2025 RhinoCAM Resource Guide

-_3\% The 2026 RhinoCAM Resource Guide!
RhinoCAM

. 18 Pages
Resource Guide |

Lists PDF downloads and Online resources including Quick Start
Guides, Reference Guides, Exercise Guides, Tutorials and
More.

Prefer Printed Documentation? Check Here!

What's New | Quick Start Play List
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Index
-A -

Add Line Numbers 96

-C -

Colors

Cut Stock 20
Cutting Tool 21
Stock 20
Text Editor 17
Tool Motion Display 18
Copy Text 106, 128
Cut Text 104, 126
Cutting Tools

Crib 65
Library 62
Preferences 21

-D -

Delete
a G-Code File from the Project 91
Delete Line Numbers 100
Delete Spaces 101
Display Toolbar
Toggle Follow Toolpath Display 32, 93
Toggle Part Visibility 32, 93
Toggle Segment Toolpath Display 32, 93
Toggle Stock Visibility 32, 93
Toggle Toolpath Visibility 32, 93
Toggle Trace Toolpath Display 32, 93

-E -

Edit

G-Code File 87
Edit > Select Full Line 119
Edit Tab 32, 93

-F -

Find Text 109

-G -

G-Code
Add Line Numbers 96
Copy Text 106, 128
Cut Text 104, 126
Delete Line Numbers 100
Delete Spaces 101
Find Text 109
From the MILL Module 145
Go to Bottom 120
Go to Next Feedrate 125
Go to Next Spindle 124
Go to Next Tool 122
GotoTop 121
Information 68
Insert Spaces 97
Load 67
Make Lower Case 102
Make Upper Case 98
Merge Files 69
Output 86
Paste Text 107, 129
Print G-Code 114
Replace Text 110
Sawe 84
Save As 116
Save G-Code 115
Show Info 117
Transform 73
Undo Last Edit 112, 131
XY Instance 82
Zlnstance 80

G-Code Editor
About 5
Features of 6
Oweniew 5
Understanding 7
Workflow 7
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Index

Information
G-Code 68
on a G-Code File 90

Insert Spaces 97

-L -

Load G-Code 67

Machine Tool Setup 42
Make Lower Case 102
Make Upper Case 98
MCS Setup 42

Merge Files 69

MILL Module 145
Mirror G-Code 73
Mowe G-Code 73

-N -

Navigate
Go to Bottom 120
Go to Next Feedrate 125
Go to Next Spindle 124
Go to Next Tool 122
GotoTop 121

-0 -

Output G-Code 86

-P-

Part
Toggle Visibility 32, 93
Paste Text 107, 129

Preferences 13
Cutting Tools 21
Simulation 22, 135
Stock 20
Text Editor 17
Toolpath 18
User Interface 14

Print G-Code 114

Project
Tab 27, 40
Tree 29

-R -

Replace Text 110
Rotate G-Code 73

-S.-

Save As 116

Savwe G-Code 84, 115
Scale G-Code 73
Select

Full Line 119
Show G-Code Info 117
Simulate

G-Code File 88
Tab 35, 133
Simulation

Display Lewvels 140
Mode 137
Pause 142
Play 138
Preferences 22, 135
Speed 136
Step Thru 139
Stop 143
ToEnd 141
Stock

Box 48
Cylinder 54
Delete 59

from Selection 60
Menu 47

Part Box 51
Part Cylinder 56
Preferences 20
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Stock
Toggle Visibility 32, 93
Transparency 20

-T -

Text Editor Preferences 17
Toggle Follow Toolpath Display
Toggle Part Visibility 32, 93

-7 -

Z Instance G-Code

32, 93

Toggle Segment Toolpath Display 32, 93
Toggle Stock Visibility 32, 93
Toggle Toolpath Visibility 32, 93
Toggle Trace Toolpath Display 32, 93
Tool Crib 65
Tool Library 62
Toolpath
Display width 18
Follow Display 32, 93

Preferences 18

Segment Display 32, 93
Toggle Visibility 32, 93
Trace Display 32, 93

Tools (See Cutting Tools) 62
Transform G-Code

Mirror 73
Mowe 73
Rotate 73
Scale 73

-U-

Undo Last Edit 112, 131

User Interface 13
Display Toolbar
Edit Tab 32, 93
G-Code Browser 24
Preferences 14
Project Tab 27, 40

-W -

Where to go for more help 147

- X -

XY Instance G-Code 82

32, 93

80

© 2026 MecSoft Corporation



	Welcome
	Overview
	Features
	Understanding
	Work Flow

	Quick Start
	CAM Resource Guide
	User Interface
	Preferences
	User Interface
	Text Editor
	Toolpath
	Stock
	Cutting Tools
	Simulation

	G-Code Browser
	Project Tab
	Project Tree
	Edit Tab
	Simulate Tab
	Online Help


	Project Tab
	Machine MCS Setup
	Setup Pane
	Stock
	Box Stock
	Part Box Stock
	Cylinder Stock
	Part Cylinder Stock
	Delete Stock
	Stock from Selection

	Tool Library
	Tool Crib

	G-Code Pane
	Load
	Info

	File Operations Pane
	Merge Files
	Transform
	Z Instance
	XY Instance
	Save
	Output

	Right-Click Menu
	Edit-G-Code-File
	Simulate G-Code File
	Info on G-Code File
	Delete G-Code File


	Edit Tab
	Add Line Numbers
	Insert Spaces
	Make Upper Case
	Delete Line Numbers
	Delete Spaces
	Make Lower Case
	Cut Text
	Copy Text
	Paste Text
	Find Text
	Find & Replace Text
	Undo Last Edit
	Print G-Code
	Save G-Code
	Save As
	Show G-Code Info
	Select Full Line
	Right-Click Menu
	Go to Bottom
	Go to Top
	Go to Next Tool
	Go to Next Spindle
	Go to Next Feedrate
	Cut Text
	Copy Text
	Paste Text
	Undo Last Edit


	Simulate Tab
	Simulate Options
	Simulation Preferences
	Simulation Speed
	Simulation Mode

	Simulation Controls
	Play Simulation
	Step Thru Simulation
	Display Simulation Levels
	Simulate to End
	Pause Simulation
	Stop Simulation


	Functions from the MILL Module
	Find More Resources

